X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox does not delete history even though "Clear History when Firefox closes" option is checked.

Kuphostiwe

Hi

I always have "Clear history when Firefox closes" checked. But since a few days it doesn't work. I close Firefox, then restart it, hit Ctrl+H and see that the history is still there. When I hit Ctrl+Alt+Delete and click OK(in Clear Recent History window) it works, it deletes the history but it doesn't delete user names even though I have everything checked in that window.

I hope that's a detailed description. English is not my first language, if you don't understand anything I said, please tell me.

Hi I always have "Clear history when Firefox closes" checked. But since a few days it doesn't work. I close Firefox, then restart it, hit Ctrl+H and see that the history is still there. When I hit Ctrl+Alt+Delete and click OK(in Clear Recent History window) it works, it deletes the history but it doesn't delete user names even though I have everything checked in that window. I hope that's a detailed description. English is not my first language, if you don't understand anything I said, please tell me.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Shockwave Flash 16.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

Does it make a difference if only the history is selected as the only item to clear when you close Firefox?

Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. Does it make a difference if only the history is selected as the only item to clear when you close Firefox?
garza 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Telling Firefox not to remember history does nothing. All history is remembered. Even when I click 'clear history', it remembers. At least with IE the option to clear browsing history works. It does not work in Firefox.

I am running the latest version of Firefox in Windows 8.11 on an hp laptop.

Telling Firefox not to remember history does nothing. All history is remembered. Even when I click 'clear history', it remembers. At least with IE the option to clear browsing history works. It does not work in Firefox. I am running the latest version of Firefox in Windows 8.11 on an hp laptop.
garza 0 izisombululo 3 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Apparently there is no solution. Firefox is set to always remember history and there's nothing we can do about it. I've dumped Firefox, which I've used since 2.0, and this is sent using Internet Explorer 11, the first time I've used IE in many many years. If Firefox refuses to do what it's supposed to do then the only answer is to use a browser that works as it should.

Apparently there is no solution. Firefox is set to always remember history and there's nothing we can do about it. I've dumped Firefox, which I've used since 2.0, and this is sent using Internet Explorer 11, the first time I've used IE in many many years. If Firefox refuses to do what it's supposed to do then the only answer is to use a browser that works as it should.
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

It is possible that something went wrong with "Clear history when Firefox closes".

Firefox will try to clear private data on the next start when "Clear history when Firefox closes" is used and Firefox failed to do this on the previous close (pref privacy.sanitize.didShutdownSanitize is missing or false).

You can try to only clear the history as a test and remove the ticks on all other items.


You can check for problems with the places.sqlite database file in the Firefox profile folder.

It is possible that something went wrong with "Clear history when Firefox closes". Firefox will try to clear private data on the next start when "Clear history when Firefox closes" is used and Firefox failed to do this on the previous close (pref privacy.sanitize.didShutdownSanitize is missing or false). You can try to only clear the history as a test and remove the ticks on all other items. ---- You can check for problems with the <b>places.sqlite</b> database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *Places Maintenance: https://addons.mozilla.org/firefox/addon/places-maintenance/
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

NavajoWhite said

When I hit Ctrl+Alt+Delete and click OK(in Clear Recent History window) it works, it deletes the history but it doesn't delete user names even though I have everything checked in that window.

User names that drop-down below fields on forms?

  • If you expand the Details section of Clear Recent History, do you have the box for "Form & Search History" checked to clear that category?
  • Presumably you already turned off saving of passwords but, if not, that is managed separately under Options > Security > Saved Passwords
''NavajoWhite [[#question-1060316|said]]'' <blockquote> When I hit Ctrl+Alt+Delete and click OK(in Clear Recent History window) it works, it deletes the history but it doesn't delete user names even though I have everything checked in that window.</blockquote> User names that drop-down below fields on forms? * If you expand the Details section of Clear Recent History, do you have the box for "Form & Search History" checked to clear that category? * Presumably you already turned off saving of passwords but, if not, that is managed separately under Options > Security > Saved Passwords
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

Also, when using Clear Recent History, make sure to choose the "Everything" time range.

Also, when using Clear Recent History, make sure to choose the "Everything" time range.
garza 0 izisombululo 3 izimpendulo
Kuphostiwe

None of this is of any value. None of it works. And there continues to be the issue of no vertical navigation bar and no vertical navigation arrows. I tried to answer the survey and could not because of the lack of vertical navigation ability. Keyboard arrows don't work with the survey. They only change the answers already given.

Give it up, I say. IE is more secure and has full navigation ability. Firefox is good for downloading Youtube, but the only way to clear history is to run Ccleaner.

None of this is of any value. None of it works. And there continues to be the issue of no vertical navigation bar and no vertical navigation arrows. I tried to answer the survey and could not because of the lack of vertical navigation ability. Keyboard arrows don't work with the survey. They only change the answers already given. Give it up, I say. IE is more secure and has full navigation ability. Firefox is good for downloading Youtube, but the only way to clear history is to run Ccleaner.
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

Hi garza, you didn't mention this before:

And there continues to be the issue of no vertical navigation bar and no vertical navigation arrows.

Do you mean the scroll bar? That could be an issue relating to private browsing which might not be relevant if you are using regular windows that accumulate history:

Firefox 38 has a glitch with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link coded with target="_blank", which launches the link in a new window

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug:

(1) Use tabbed browsing (this is a checkbox under Options > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.


For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Hi garza, you didn't mention this before: <blockquote> And there continues to be the issue of no vertical navigation bar and no vertical navigation arrows.</blockquote> Do you mean the scroll bar? That could be an issue relating to ''private browsing'' which might not be relevant if you are using regular windows that accumulate history: Firefox 38 has a glitch with this combination of circumstances: (1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned ''off'' (3) You click a link coded with target="_blank", which launches the link in a new window The new window opens without menus, toolbar, scroll bars, etc. Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. These are the currently known workarounds so you can keep using private browsing windows -- any one of them will work around the bug: (1) Use tabbed browsing (this is a checkbox under Options > General > "Open new windows in a new tab instead"); (2) Shift+click links to open them in a new window with the standard features; or (3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed. ---- For #3, here are the steps: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''feat''' and pause while the list is filtered (C) For every preference that starts with '''dom.disable_window_open_feature.''' if it is not "true", double-click it to switch it to true. You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.