X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Flash content flashing and crashing mac

Kuphostiwe

Hello,

Since the latest FF and Flash update (37 and 17) I can't watch any videos or flash content - like (annoying ad) banners. Everything literally FLASHES. Like a strobe light. Then videos get stuck, the cursor jumps/freezes, sound stutters and eventually mac crashes (panic). The fans are constantly hyperventilating but nothing weird is running in activity monitor.

I have:

  • Uninstalled and reinstalled flash; same for Firefox; cleaned flash cache - nothing
  • I only have flash, java and QuickTime plugins installed
  • Downgraded flash to previous version (16) - better, no flashes, but still stutters and crashes after watching video for 10-15 minutes most (sometimes not even that)
  • Tried to watch using VPN but after a while graphics and sound go crazy
  • Decided to upgrade again to flash 17. Now it flashes again and I can't watch videos for even 1 minute.
  • Tried the about:config media.mediasource.enabled (change to true); dom.ipc.plugins.flash.disable-protected-mode (change to false); Firefox "get info" open with 32-bit mode; - nothing worked

What can I do? Any idea? Thanks

Hello, Since the latest FF and Flash update (37 and 17) I can't watch any videos or flash content - like (annoying ad) banners. Everything literally FLASHES. Like a strobe light. Then videos get stuck, the cursor jumps/freezes, sound stutters and eventually mac crashes (panic). The fans are constantly hyperventilating but nothing weird is running in activity monitor. I have: * Uninstalled and reinstalled flash; same for Firefox; cleaned flash cache - nothing * I only have flash, java and QuickTime plugins installed * Downgraded flash to previous version (16) - better, no flashes, but still stutters and crashes after watching video for 10-15 minutes most (sometimes not even that) * Tried to watch using VPN but after a while graphics and sound go crazy * Decided to upgrade again to flash 17. Now it flashes again and I can't watch videos for even 1 minute. * Tried the about:config media.mediasource.enabled (change to true); dom.ipc.plugins.flash.disable-protected-mode (change to false); Firefox "get info" open with 32-bit mode; - nothing worked What can I do? Any idea? Thanks

Okulungisiwe ngu omgfirefox

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:37.0) Gecko/20100101 Firefox/37.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4220 izisombululo 58909 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Install this and use it

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? ------------------------------- If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' ----------------------------- Install this and use it '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Umnikazi wombuzo

Hi, Well, in safe mode it seems to work. It doesn't flash, I can scroll down and the video keeps smooth and the fans seem to be quiet.

About the other tips:

  • I have a mac. I don't have graphic driver updates.
  • That mms.cfg is that a mac thing? As I said, I already tried changing the dom.ipc.plugins.flash.disable-protected-mode to false. But it didn't help.
  • I forgot to mention that I already tried to disable hardware acceleration. That doesn't work.

Now, it works with add-ons disabled (safe mode), but I only have java, flash and QuickTime (all updated) enabled.

One thing I've noticed is that I have 2 disabled plugins: Real Player and "Openh264". I can't delete them. I deleted Real Player plugin from my folder some days ago: mac>library>internet plugins but it created a new one again, so it's there (still disabled). The openh264 I have no idea how it got there, I don't have such plugin (that name) in my "internet plugins" folder, but it's there (also disabled).

So what can I do now? Thank you

Hi, '''Well, in safe mode it seems to work. It doesn't flash, I can scroll down and the video keeps smooth and the fans seem to be quiet'''. About the other tips: * I have a mac. I don't have graphic driver updates. * That mms.cfg is that a mac thing? As I said, I already tried changing the dom.ipc.plugins.flash.disable-protected-mode to false. But it didn't help. * I forgot to mention that I already tried to disable hardware acceleration. That doesn't work. Now, it works with add-ons disabled (safe mode), but I only have java, flash and QuickTime (all updated) enabled. One thing I've noticed is that I have 2 disabled plugins: Real Player and "Openh264". I can't delete them. I deleted Real Player plugin from my folder some days ago: mac>library>internet plugins but it created a new one again, so it's there (still disabled). The openh264 I have no idea how it got there, I don't have such plugin (that name) in my "internet plugins" folder, but it's there (also disabled). So what can I do now? Thank you

Okulungisiwe ngu omgfirefox

FredMcD
  • Top 10 Contributor
4220 izisombululo 58909 izimpendulo
Kuphostiwe

Impendulo Ewusizo

mms.cfg = Flash Player

Go to your plugins page. Set everything video to Ask.


You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.


1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.

mms.cfg = Flash Player Go to your plugins page. Set everything video to '''Ask.''' ------------------------- You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. ------------------------------------- 1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.

Umnikazi wombuzo

Well, I did what you said and it worked BUT then I undid it and it still worked.

So, now it works with plugins set to "always activate" and the "media.mediasource.webm.enabled set to false (like it was before)

and also with plugins set to "always ask" and the webm set to true (like you suggested)...

Go figure! I'll mark it as "This solved my problem" anyway :)

But I've changed my youtube to html5 (following your link)...maybe that's it?

Thank you

Well, I did what you said and it worked BUT then I undid it and it still worked. So, now it works with plugins set to "always activate" and the "media.mediasource.webm.enabled set to false (like it was before) and also with plugins set to "always ask" and the webm set to true (like you suggested)... Go figure! I'll mark it as "This solved my problem" anyway :) But I've changed my youtube to html5 (following your link)...maybe that's it? Thank you

Okulungisiwe ngu omgfirefox

FredMcD
  • Top 10 Contributor
4220 izisombululo 58909 izimpendulo
Kuphostiwe

Could have been a corrupted file was at fault, and was replaced.

As long as it works. Safe Surfing. Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Could have been a corrupted file was at fault, and was replaced. As long as it works. Safe Surfing. Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

Umnikazi wombuzo

Oops...Sorry FredMcD,

It only solved the problem with youtube videos. So I guess it was the html5

Facebook videos and flash banners are still flashing. I have all plugins set to "ask to activate" and mediasource.webm enabled.

I've tested other videos and thought everything was fine, but it's not.

Oops...Sorry FredMcD, It only solved the problem with youtube videos. So I guess it was the html5 Facebook videos and flash banners are still flashing. I have all plugins set to "ask to activate" and mediasource.webm enabled. I've tested other videos and thought everything was fine, but it's not.

Okulungisiwe ngu omgfirefox

FredMcD
  • Top 10 Contributor
4220 izisombululo 58909 izimpendulo
Kuphostiwe

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Umnikazi wombuzo

Thank you so much FredMcd.

Big guys...

Thank you so much FredMcd. Big guys...