Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Search bar does not work. Cannot add search engines.

  • 50 uphendule
  • 14 zinale nkinga
  • 1666 views
  • Igcine ukuphendulwa ngu cor-el

more options

Search bar does not work. Cannot add search engines.

Isisombululo esikhethiwe

right click the mozilla icon click properties click compatibility uncheck the box that forces Mozilla to use windows 95

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (20)

more options

It would be helpful in fixing your problem if we know a little about your Firefox version and OS, by the way have you tried opening the menu and going to options and then search tab that should do it i guess.

If you do not have the latest version of firefox then update now.

more options

I already re-installed Firefox (latest version), operating system is windows XP. In tools/option there are no search engines in the drop down menu. I cannot install a search engine as there are none.

more options

Can you reach firefox menu and then search option through it,

If yes there is a add button below it which should solve the problem.

more options

There are no search engines there. I can go to option but the search engines don't exist. The add button has no search engines.

more options

Go to this link and download search engine addons and check

https://addons.mozilla.org/en-US/firefox/search/?atype=4

more options

Tried that. Nothing happens when I click on the buttons. It doesn't add any search engines.

more options

The problem is that this issue is rare which suggests it might not be the problem with firefox in general but maybe the problem with the installation or with addon. Give us a list of all addons installed.

more options

I don't think I have any addon's installed. How do I check that?

more options

Type "about:addons" in your action bar

more options

OK I got to the addons list....how do I send that to you?

more options

Just type the names one by one here

more options

Here they are as screen shots but I disabled all of them an still have the problem...

more options

I also need you to post the screen shot of extensions in your browser

more options

Where do I find those?

more options

In the add-on menu right above there is a extensions tab on the left

more options

there are no extensions and the address bar does not work either. I tried it in safe mode and it doesn't work there either. m

more options

It is not possible that address bar doesn't work,

Two possible scenarios: 1. Installation is corrupted, reinstall.

                                           2. Malware, attention required
more options

I've reinstalled it 4 times already, the search bar does not work, ran norton antivirus (everything is clean), here is NO response from the adress bar if I type in a link! Google chrome works fine. Internet explorer works fine. Mozilla just has no search engine unless I set the default page to google then I can search from THAT main toolbar.

more options

You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder.

If not then you need to reinstall Firefox.

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the currently used Firefox profile folder:

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

more options

I have the same problem and tried all of these solutions but to no avail. It would be much simpler to have a button in options to access this info and then turn things off and on and add search engines. When i click on the magnifying glass it does not say add or change search engines so all is lost from the first instruction. If this is a bug, you would think Firefox would know about it. I hope someone can help me.

Okulungisiwe ngu briansmyrealty

  1. 1
  2. 2
  3. 3