Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Yahoo Mail on Firefox thinks javascript disabled - even though Not

  • 7 uphendule
  • 1 inale nkinga
  • 8 views
  • Igcine ukuphendulwa ngu alan5577

more options

My javascript became disabled in Java 37. I went onto my Yahoo mail and the page then showed the yahoo mail screen for no javascript. Things like there is no settings icon - just a drop down with things like "profile" "account info". Everything else is in drop downs. No tabs, etc. I then went to about:config and reenabled javascript. So javascript works fine. But yahoo mail page won't change back. Clicking on "switch to latest yahoo mail" does nothing. In every other browser, my yahoo mail looks fine and I cannot find anywhere in settings to change anything.

Ideas please?

My javascript became disabled in Java 37. I went onto my Yahoo mail and the page then showed the yahoo mail screen for no javascript. Things like there is no settings icon - just a drop down with things like "profile" "account info". Everything else is in drop downs. No tabs, etc. I then went to about:config and reenabled javascript. So javascript works fine. But yahoo mail page won't change back. Clicking on "switch to latest yahoo mail" does nothing. In every other browser, my yahoo mail looks fine and I cannot find anywhere in settings to change anything. Ideas please?

All Replies (7)

more options

This is somewhat generic advice, but I think it's worth a try:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Thanks but I tried all of that. No luck.

more options

Are there any unusual icons in the address bar that could indicate a security issue? For example, instead of a padlock, a gray triangle with an exclamation point, or a shield icon to the left of that.


Have you tried the site in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?


If the above doesn't help, could you post a screen shot showing what the layout looks like? This article has tips on doing that: How do I create a screenshot of my problem? Please cut out or blur any sensitive information before attaching the image to a reply.

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:

more options

Thanks but starting in safe mode doesn't do anything.

I have attached two pictures. The second one is the right side of the page where the options usually is.

thanks for the help.

more options

Try to click "Switch to the newest Yahoo Mail" that you see in the second screenshot under the Profile selector as it looks that you are currently in Basic mode.

more options

Sorry but I tried that. It thinks for a while..... and then just redisplays the screen as I have shown it.