Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Browser gets temporarily choppy after using it for a period of time until reset

  • 3 uphendule
  • 2 zinale nkinga
  • 1218 views
  • Igcine ukuphendulwa ngu DKielby

more options

I just installed Windows 8.1 to my computer, and I am currently using the latest version of Firefox. I've noticed that after I've used the browser for a while, when I am watching a stream/video, or scrolling/clicking through pages, the browser stalls temporarily for a second.

The thing that stops the choppiness is restarting Firefox (both with and without addons). While the browser turns choppy, I tried other browsers like IE to see if it applies to that as well, and it behaves more smoothly.

After a while, it gets really annoying having to reset exit and start up the browser, every time it starts to get choppy. Any guesses as to what could cause it?

Isisombululo esikhethiwe

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Isisombululo Esikhethiwe

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

It fixed it, though it did make browsing through the different tabs kinda glitchy when watching videos or streams in the background.

more options

Pretty much the same problem. Streaming movies from tvweb360.tv > Veetle Entertainment has become very non-stop choppy after the first 30 to 40 seconds of streaming. I've been using this site for years. Been choppy for 2 or three weeks (guessing). Tried disabling acceleration and changing various settings all one at a time and with restarts in between. Tried increasing video cash in Firefox. Tried changing Quicktime settings. Tried turning various add-ons off one at a time. Windows Action Center has reported that I have a video problem but was unable to connect to MS to search for a resolution. IE is not choppy. Running Windows 7 Home Premium 64 bit and Firefox 38.0.5. Have Core 2 Quad CPU at 2.5 GHz and 8 GB of RAM. Mozilla, Mozilla...Please don't make me use IE.