X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox against freedom: Users can't disable video auto-play

Kuphostiwe

My netbook becomes extremely inefficient when encountering auto-play video advertisements on the internet. I followed every online self-help, and in all made the following changes:

1) Menu Bar | Tools | Add-ons All video-> Never Activate 2) about:config plugins.click_to_play true http://www.pcadvisor.co.uk/how-to/internet/3497991/how-stop-autoplaying-ads-videos-media-on-web-pages/ media.autoplay.enabled false https://support.mozilla.org/en-US/questions/961940 media.autoplay.enabled false media.play-stand-alone false plugin.disable_full_page_plugin_for_types application plugin.state.gecko-mediaplayer 0 plugin.state.gecko-mediaplayer-dvx 0 plugin.state.gecko-mediaplayer-qt 0 plugin.state.gecko-mediaplayer-rm 0 plugin.state.gecko-mediaplayer-wmp 0 layers.async-video-oop.enabled false layers.async-video.enabled false media.navigator.video.enabled false media.peerconnection.video.enabled false media.video_stats.enabled false plugin.disable_full_page_plugin_for_types app media.cache_readahead_limit;9999 media.cache_resume_threshold;9999 media.encoder.webm.enabled;false media.getusermedia.aec_enabled;false media.getusermedia.agc;0 media.getusermedia.browser.enabled;false media.getusermedia.screensharing.enabled;false media.gmp-eme-adobe.hidden;false media.gmp-manager.cert.checkAttributes;false media.gmp-manager.cert.requireBuiltIn;false media.gmp-provider.enabled;false media.gstreamer.enable-blacklist;false media.gstreamer.enabled;false media.mediasource.webm.enabled;false media.mediasource.youtubeonly;false media.navigator.enabled;false media.navigator.load_adapt;false media.ogg.enabled;false media.opus.enabled;false media.raw.enabled;false media.wave.enabled;false media.webm.enabled;false media.webvtt.enabled;false

One last thing before I switch to another browser for linux, 50% of the online tutorial say to set "plugins.click_to_play" to "true" and others say set to false. Thus I tried both and NONE worked for https://login.yahoo.com/! The annoying video advertisement always plays on the left half of the screen and my netbook becomes unusable.

My netbook becomes extremely inefficient when encountering auto-play video advertisements on the internet. I followed every online self-help, and in all made the following changes: 1) Menu Bar | Tools | Add-ons All video-> Never Activate 2) about:config plugins.click_to_play true http://www.pcadvisor.co.uk/how-to/internet/3497991/how-stop-autoplaying-ads-videos-media-on-web-pages/ media.autoplay.enabled false https://support.mozilla.org/en-US/questions/961940 media.autoplay.enabled false media.play-stand-alone false plugin.disable_full_page_plugin_for_types application plugin.state.gecko-mediaplayer 0 plugin.state.gecko-mediaplayer-dvx 0 plugin.state.gecko-mediaplayer-qt 0 plugin.state.gecko-mediaplayer-rm 0 plugin.state.gecko-mediaplayer-wmp 0 layers.async-video-oop.enabled false layers.async-video.enabled false media.navigator.video.enabled false media.peerconnection.video.enabled false media.video_stats.enabled false plugin.disable_full_page_plugin_for_types app media.cache_readahead_limit;9999 media.cache_resume_threshold;9999 media.encoder.webm.enabled;false media.getusermedia.aec_enabled;false media.getusermedia.agc;0 media.getusermedia.browser.enabled;false media.getusermedia.screensharing.enabled;false media.gmp-eme-adobe.hidden;false media.gmp-manager.cert.checkAttributes;false media.gmp-manager.cert.requireBuiltIn;false media.gmp-provider.enabled;false media.gstreamer.enable-blacklist;false media.gstreamer.enabled;false media.mediasource.webm.enabled;false media.mediasource.youtubeonly;false media.navigator.enabled;false media.navigator.load_adapt;false media.ogg.enabled;false media.opus.enabled;false media.raw.enabled;false media.wave.enabled;false media.webm.enabled;false media.webvtt.enabled;false One last thing before I switch to another browser for linux, 50% of the online tutorial say to set "plugins.click_to_play" to "true" and others say set to false. Thus I tried both and NONE worked for https://login.yahoo.com/! The annoying video advertisement always plays on the left half of the screen and my netbook becomes unusable.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:37.0) Gecko/20100101 Firefox/37.0

Eminye Imininingwane

the-edmeister
  • Top 25 Contributor
  • Moderator
5411 izisombululo 40287 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You're not blocking advertisements? https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

Impendulo Ewusizo

I also checked the above yahoo login site with midori and chromium, and they too fall victim to this TOMMY HILFIGER auto-play scam. Finally I installed Flashblock 1.5.18 and wala! The page loads but only displays the picture, and then it doesn't play the ensuing video. So basically this solves the problem: “How to block auto-play video advertisements and be a productive citizen.”

Unanswered Questions: 1) Why if I didn't have flash installed in the first place does flashblock 1.5.18 take effect? 2) Is there anyway of disabling autoplay in firefox without bloating up my system by installing extra firefox add-ons?

Andrew

I also checked the above yahoo login site with midori and chromium, and they too fall victim to this TOMMY HILFIGER auto-play scam. Finally I installed Flashblock 1.5.18 and wala! The page loads but only displays the picture, and then it doesn't play the ensuing video. So basically this solves the problem: “How to block auto-play video advertisements and be a productive citizen.” Unanswered Questions: 1) Why if I didn't have flash installed in the first place does flashblock 1.5.18 take effect? 2) Is there anyway of disabling autoplay in firefox without bloating up my system by installing extra firefox add-ons? Andrew

Umnikazi wombuzo

the-edmeister said

You're not blocking advertisements? https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

Thank you for this wonderful add-on, I'm sure it will help me also.

''the-edmeister [[#answer-719924|said]]'' <blockquote> You're not blocking advertisements? https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/ </blockquote> Thank you for this wonderful add-on, I'm sure it will help me also.
user293 39 izisombululo 279 izimpendulo
Kuphostiwe

All flashblock does is block flash from running, so if it worked, then you had flash player installed. (You can check this by going to about:addons, and clicking on plugins. If you have flash, you will see something that says shockwave flash or similar).

Firefox has a similar feature to flashblock built in. Find flash player in the plugins section of about:addons, and you should see a dropdown next to the plugin. Then, you can choose "ask to activate". Whenever you come across a flash animation, firefox will then show you a banner at the top of the screen asking if you want to use flash player or not.

All flashblock does is block flash from running, so if it worked, then you had flash player installed. (You can check this by going to about:addons, and clicking on plugins. If you have flash, you will see something that says shockwave flash or similar). Firefox has a similar feature to flashblock built in. Find flash player in the plugins section of about:addons, and you should see a dropdown next to the plugin. Then, you can choose "ask to activate". Whenever you come across a flash animation, firefox will then show you a banner at the top of the screen asking if you want to use flash player or not.