X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox crashes

Kuphostiwe

I can't understand why my Firefox crashes, it behaves just fine for days then it crashes on time and after the that there's no way it stop crashing, it happens mostly on youtube but on random sites too. It doesn't crash on start but after loading sites, especially those that use Flash like Youtube. The only way to stop the crashes is to reboot the PC, then it behaves normally until after some days it crashes for the first time and after that keeps crashing.

I don't know if it can help but this happens on a fairly old machine: a Sempron 3.2GHz, 1GB RAM, Nvidia 6100 with shared memory and Win XP OEM. This PC is always on and doesn't get rebooted for weeks, even months. The send crash report feature doesn't work either.

59edeb9a-3c25-405e-8384-e0a37cfcaf23 17/04/2015 12.25 6cca796a-bdff-4a93-add5-a4c6ce36ffa6 17/04/2015 10.00 67332c45-ff0b-4b97-9b28-b3b1ab8c0d03 17/04/2015 9.48 a4cd1b2a-4bf3-41ef-a3d2-b448476fcf47 17/04/2015 9.10 308bb6b2-a024-43c1-a116-9597268fb6d4 16/04/2015 21.33 cea80ad6-ec4b-46b6-bd0a-e16f7018bed3 16/04/2015 21.09 7e01a859-5d16-4fa0-84e8-2cd57eec0399 16/04/2015 18.32 768c1e23-941e-4308-b3ab-f7dbc003bf9b 16/04/2015 16.50 1ef957b9-857e-4e41-80a6-ec08acbff056 16/04/2015 15.33 0cd9f8ac-30fd-40b7-8d8a-6de3527120b7 16/04/2015 14.56 b3064407-a0e0-4e7c-8da1-c3cef42f9dad 16/04/2015 10.29 798f0f90-a6cd-4e60-9f5d-69dbdbfc38d5 15/04/2015 23.48 17b12d96-121b-473f-8d6d-247a835b2cfa 15/04/2015 20.12 31320270-f9f6-42e1-995b-04b1a06679aa 15/04/2015 8.42 8b7e7cef-89d0-48a2-a41a-adfe0967b6d7 15/04/2015 8.37 8489e20a-1512-4bb0-a97c-1871a6330a87 15/04/2015 8.26 6ee199bb-5aad-4f8d-b85b-575b9721a8c8 15/04/2015 8.24 c0014113-a281-4da8-ab71-a1ce37139066 14/04/2015 13.17 89c872cb-a9a0-460b-89f0-e9a031a52caf 14/04/2015 13.16 fdd94f30-780c-4af6-8067-e728bd86a9b2 14/04/2015 13.13 0436b527-6025-4a64-9dca-c954989c294c 14/04/2015 13.11 75a834fa-92bf-4dc6-b6f1-f623670329d7 14/04/2015 12.57 07e1e3dc-a765-4b5e-8e3f-a4e402f8b60e 14/04/2015 12.46 45e9200f-5650-411c-801c-0289bcf50969 14/04/2015 12.45 f55fba76-f869-4a76-bc6f-edd00e19336c 14/04/2015 12.44 3cf86fd4-9fc0-44a8-bf33-a6fab958cdc1 14/04/2015 12.26 beb3586e-52dc-4969-84a5-d340e3b15c12 13/04/2015 23.39 5bf715c4-2a03-4eeb-93c8-a6fc4402ed76 13/04/2015 23.02 3d0ed6dd-ca42-4e61-b4b7-a7a887a255aa 13/04/2015 22.56 2c6dac67-ba3f-438d-82f2-bf8cff097d9b 12/04/2015 16.04 2072e1f9-be0a-497d-b173-e5f82cf62e99 12/04/2015 13.45 f1c6f290-aaa5-41e9-beb8-24e76400a548 11/04/2015 18.08 7fe5d60e-4930-4ed5-99d9-1dab2679f8eb 11/04/2015 15.56 eecc640e-26af-4b35-a96b-8a0d07fb0201 11/04/2015 12.23 c69e4b07-ec73-45f3-b6ac-bb94e50a18e4 11/04/2015 2.11 eb855fba-55fa-4a99-a48e-b1f9f27e3c85 11/04/2015 0.26 49cf9f1b-c51d-453c-946b-6526b5edeee8 11/04/2015 0.03 de939bb5-918b-46f9-98cf-b71e749199e5 10/04/2015 23.15 e7176b78-452e-4992-8f0d-a392c1a048b0 10/04/2015 16.29 fee2fe76-4459-445e-8358-11fe07ad5ff6 08/04/2015 19.10 a0823fcc-3aac-420a-97ef-31ff94bb9de1 01/04/2015 15.21

Can anyone help me with this? Thanks.

I can't understand why my Firefox crashes, it behaves just fine for days then it crashes on time and after the that there's no way it stop crashing, it happens mostly on youtube but on random sites too. It doesn't crash on start but after loading sites, especially those that use Flash like Youtube. The only way to stop the crashes is to reboot the PC, then it behaves normally until after some days it crashes for the first time and after that keeps crashing. I don't know if it can help but this happens on a fairly old machine: a Sempron 3.2GHz, 1GB RAM, Nvidia 6100 with shared memory and Win XP OEM. This PC is always on and doesn't get rebooted for weeks, even months. The send crash report feature doesn't work either. 59edeb9a-3c25-405e-8384-e0a37cfcaf23 17/04/2015 12.25 6cca796a-bdff-4a93-add5-a4c6ce36ffa6 17/04/2015 10.00 67332c45-ff0b-4b97-9b28-b3b1ab8c0d03 17/04/2015 9.48 a4cd1b2a-4bf3-41ef-a3d2-b448476fcf47 17/04/2015 9.10 308bb6b2-a024-43c1-a116-9597268fb6d4 16/04/2015 21.33 cea80ad6-ec4b-46b6-bd0a-e16f7018bed3 16/04/2015 21.09 7e01a859-5d16-4fa0-84e8-2cd57eec0399 16/04/2015 18.32 768c1e23-941e-4308-b3ab-f7dbc003bf9b 16/04/2015 16.50 1ef957b9-857e-4e41-80a6-ec08acbff056 16/04/2015 15.33 0cd9f8ac-30fd-40b7-8d8a-6de3527120b7 16/04/2015 14.56 b3064407-a0e0-4e7c-8da1-c3cef42f9dad 16/04/2015 10.29 798f0f90-a6cd-4e60-9f5d-69dbdbfc38d5 15/04/2015 23.48 17b12d96-121b-473f-8d6d-247a835b2cfa 15/04/2015 20.12 31320270-f9f6-42e1-995b-04b1a06679aa 15/04/2015 8.42 8b7e7cef-89d0-48a2-a41a-adfe0967b6d7 15/04/2015 8.37 8489e20a-1512-4bb0-a97c-1871a6330a87 15/04/2015 8.26 6ee199bb-5aad-4f8d-b85b-575b9721a8c8 15/04/2015 8.24 c0014113-a281-4da8-ab71-a1ce37139066 14/04/2015 13.17 89c872cb-a9a0-460b-89f0-e9a031a52caf 14/04/2015 13.16 fdd94f30-780c-4af6-8067-e728bd86a9b2 14/04/2015 13.13 0436b527-6025-4a64-9dca-c954989c294c 14/04/2015 13.11 75a834fa-92bf-4dc6-b6f1-f623670329d7 14/04/2015 12.57 07e1e3dc-a765-4b5e-8e3f-a4e402f8b60e 14/04/2015 12.46 45e9200f-5650-411c-801c-0289bcf50969 14/04/2015 12.45 f55fba76-f869-4a76-bc6f-edd00e19336c 14/04/2015 12.44 3cf86fd4-9fc0-44a8-bf33-a6fab958cdc1 14/04/2015 12.26 beb3586e-52dc-4969-84a5-d340e3b15c12 13/04/2015 23.39 5bf715c4-2a03-4eeb-93c8-a6fc4402ed76 13/04/2015 23.02 3d0ed6dd-ca42-4e61-b4b7-a7a887a255aa 13/04/2015 22.56 2c6dac67-ba3f-438d-82f2-bf8cff097d9b 12/04/2015 16.04 2072e1f9-be0a-497d-b173-e5f82cf62e99 12/04/2015 13.45 f1c6f290-aaa5-41e9-beb8-24e76400a548 11/04/2015 18.08 7fe5d60e-4930-4ed5-99d9-1dab2679f8eb 11/04/2015 15.56 eecc640e-26af-4b35-a96b-8a0d07fb0201 11/04/2015 12.23 c69e4b07-ec73-45f3-b6ac-bb94e50a18e4 11/04/2015 2.11 eb855fba-55fa-4a99-a48e-b1f9f27e3c85 11/04/2015 0.26 49cf9f1b-c51d-453c-946b-6526b5edeee8 11/04/2015 0.03 de939bb5-918b-46f9-98cf-b71e749199e5 10/04/2015 23.15 e7176b78-452e-4992-8f0d-a392c1a048b0 10/04/2015 16.29 fee2fe76-4459-445e-8358-11fe07ad5ff6 08/04/2015 19.10 a0823fcc-3aac-420a-97ef-31ff94bb9de1 01/04/2015 15.21 Can anyone help me with this? Thanks.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Npdsplay dll

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:37.0) Gecko/20100101 Firefox/37.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4258 izisombululo 59615 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode;

Some of your crash reports weren’t sent to the Mozilla Servers.

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? While still in Safe Mode; Some of your crash reports weren’t sent to the Mozilla Servers. In the address bar, type '''about:crashes'''<enter>.''' Note:''' If any reports do not have '''BP''' in front of the numbers, click it and select '''Submit'''. Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in.

Umnikazi wombuzo

Firstly thanks for your help. Here they are:

bp-c9b6e370-7e61-4ff7-9ee5-d25192150418 bp-8971515b-328e-4bd9-9cf6-48c702150418 bp-83d0cc26-0e7c-4f09-944f-7b8832150418 bp-0980b565-ff17-411d-b961-b40a42150418 bp-160ac602-0086-44ae-b370-47d7b2150418 bp-a3a573d6-a108-4247-a829-0696c2150418 bp-5b8d0581-ead9-454d-a2c2-796932150418 bp-b1b373d4-04da-4e24-89bf-e5a832150418 bp-f66711cf-f339-4282-bdfd-d01162150418 bp-a9d9485d-7bde-438f-9a7f-b8fef2150418 bp-8eedb92d-582b-488b-b404-ae98d2150418 bp-0c658e80-bf2d-4286-8e7f-9f27a2150418

Firstly thanks for your help. Here they are: bp-c9b6e370-7e61-4ff7-9ee5-d25192150418 bp-8971515b-328e-4bd9-9cf6-48c702150418 bp-83d0cc26-0e7c-4f09-944f-7b8832150418 bp-0980b565-ff17-411d-b961-b40a42150418 bp-160ac602-0086-44ae-b370-47d7b2150418 bp-a3a573d6-a108-4247-a829-0696c2150418 bp-5b8d0581-ead9-454d-a2c2-796932150418 bp-b1b373d4-04da-4e24-89bf-e5a832150418 bp-f66711cf-f339-4282-bdfd-d01162150418 bp-a9d9485d-7bde-438f-9a7f-b8fef2150418 bp-8eedb92d-582b-488b-b404-ae98d2150418 bp-0c658e80-bf2d-4286-8e7f-9f27a2150418

Okulungisiwe ngu Judicator

FredMcD
  • Top 10 Contributor
4258 izisombululo 59615 izimpendulo
Kuphostiwe

Impendulo Ewusizo

It looks like the crashes is related to flash as you suspected, but the reports don't give specific information.

Please do these in turn;


Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

This should stop the crashes when the pages are loaded. Do not start the clips until the issue is fixed. Just for now.


Flash and Java were recently upgraded. Please use these links;

Flash Player Version 17.0.0.169
https://www.adobe.com/products/flashplayer/distribution3.html

Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 40


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


See what these pages report;

Flash Player Test Page YouTube Test Page: What video does this browser support

It looks like the crashes is related to flash as you suspected, but the reports don't give specific information. Please do these in turn; --------------------- '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it This should stop the crashes when the pages are loaded. Do not start the clips until the issue is fixed. Just for now. ------------------------------ Flash and Java were recently upgraded. Please use these links; Flash Player '''Version 17.0.0.169<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''[http://java.com/en/download/installed.jsp Verify Java and Find Out-of-Date Versions]''' {web link} Version 8 Update 40 -------------------------- If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' --------------------------------- See what these pages report; '''[https://www.adobe.com/software/flash/about/ Flash Player Test Page]''' '''[https://www.youtube.com/html5 YouTube Test Page: What video does this browser support]'''

Umnikazi wombuzo

So I updated Java but not to the latest version because apparently I need to change OS to run the latest version of Java. :| Updated the graphic driver also, apparently there was an update a year ago.

I've already disabled Flash Hardware Acceleration and Protected Mode so the last thing is to give a try to the tweaks listed on the last page you linked as soon as possible.

I don't know if it matters that I only have installed Service Pack 2 because SP3 slows down this PC, I wonder if this can cause incompatibilities.

I guess I'll have to wait and see what happens, in the mean time I thank you for being helpful. I will reach out and update the topic in a few weeks to see if all the changes have had an effect. Bye.

So I updated Java but not to the latest version because apparently I need to change OS to run the latest version of Java. :| Updated the graphic driver also, apparently there was an update a year ago. I've already disabled Flash Hardware Acceleration and Protected Mode so the last thing is to give a try to the tweaks listed on the last page you linked as soon as possible. I don't know if it matters that I only have installed Service Pack 2 because SP3 slows down this PC, I wonder if this can cause incompatibilities. I guess I'll have to wait and see what happens, in the mean time I thank you for being helpful. I will reach out and update the topic in a few weeks to see if all the changes have had an effect. Bye.
FredMcD
  • Top 10 Contributor
4258 izisombululo 59615 izimpendulo
Kuphostiwe

Have you installed Flash Block? This will help prevent flash crash (unless you start the flash yourself).

Have you installed Flash Block? This will help prevent flash crash (unless you start the flash yourself).

Umnikazi wombuzo

No I haven't, do you think I shoud? I mean shouldn't we see if what we've done until now has an affect?

No I haven't, do you think I shoud? I mean shouldn't we see if what we've done until now has an affect?
jscher2000
  • Top 10 Contributor
8767 izisombululo 71704 izimpendulo
Kuphostiwe

Of the last group of reports, #2-#7 and #9-#11 are linked to an entry in the bug tracking system. That entry relates to a problem characterized as an out-of-memory issue. Your reports show between 87% and 98% memory usage, which is definitely a situation in which Firefox will be incredibly sluggish at best, and crashes become common.

But that bug -- addressed to a flaw in the built-in HTML5 video player instead of in the Flash plugin -- was fixed in Firefox 36. Since you have Firefox 37, the problem must be something new.

Is there any way you can reduce the number of running programs to make more memory available for Firefox? (Sounds greedy, I know...)

Do you want to disable the built-in video player to see whether that helps? Hopefully this will do it:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false (this might only affect MP3s...)

(4) Double-click the media.mediasource.enabled preference to switch it from true to false (if it's already false in XP, you can leave it as is)

(5) Double-click the media.ogg.enabled preference to switch it from true to false (should disable playing of OGG/OGV video)

(6) Double-click the media.webm.enabled preference to switch it from true to false (should disable playing of WebM video)

The changes might not take effect until the next time you exit Firefox and start it up again.

Of the last group of reports, #2-#7 and #9-#11 are linked to an entry in the bug tracking system. That entry relates to a problem characterized as an out-of-memory issue. Your reports show between 87% and 98% memory usage, which is definitely a situation in which Firefox will be incredibly sluggish at best, and crashes become common. But that bug -- addressed to a flaw in the built-in HTML5 video player instead of in the Flash plugin -- was fixed in Firefox 36. Since you have Firefox 37, the problem must be something new. Is there any way you can reduce the number of running programs to make more memory available for Firefox? (Sounds greedy, I know...) Do you want to disable the built-in video player to see whether that helps? Hopefully this will do it: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.directshow.enabled''' preference to switch it from true to false (this might only affect MP3s...) (4) Double-click the '''media.mediasource.enabled''' preference to switch it from true to false (if it's already false in XP, you can leave it as is) (5) Double-click the '''media.ogg.enabled''' preference to switch it from true to false (should disable playing of OGG/OGV video) (6) Double-click the '''media.webm.enabled''' preference to switch it from true to false (should disable playing of WebM video) The changes might not take effect until the next time you exit Firefox and start it up again.
cor-el
  • Top 10 Contributor
  • Moderator
17534 izisombululo 158551 izimpendulo
Kuphostiwe

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Umnikazi wombuzo

That makes sense indeed. This PC has just 1GB RAM and Firefox, Thunderbird, AVG, a bandwidth monitor and F@H apparently suck up all the memory and make FF crash. This would explain why FF just behaves for days until it crashes a first time, mainly with sites that use Flash, and then keeps crashing until the PC gets rebooted.

I can try to reduce the numbers of programs running but I'm afraid that 1GB RAM, shared between programs and GPU, actually 750MB, don't leave much room.

Yes, I can disable the built in player.

(3) Double-click the media.directshow.enabled preference to switch it from true to false (this might only affect MP3s...) Done.

(4) Double-click the media.mediasource.enabled preference to switch it from true to false (if it's already false in XP, you can leave it as is) Done.

(5) Double-click the media.ogg.enabled preference to switch it from true to false (should disable playing of OGG/OGV video) Done.

(6) Double-click the media.webm.enabled preference to switch it from true to false (should disable playing of WebM video) Done.

Many thanks. I'll let you know how it behaves.

That makes sense indeed. This PC has just 1GB RAM and Firefox, Thunderbird, AVG, a bandwidth monitor and F@H apparently suck up all the memory and make FF crash. This would explain why FF just behaves for days until it crashes a first time, mainly with sites that use Flash, and then keeps crashing until the PC gets rebooted. I can try to reduce the numbers of programs running but I'm afraid that 1GB RAM, shared between programs and GPU, actually 750MB, don't leave much room. Yes, I can disable the built in player. (3) Double-click the media.directshow.enabled preference to switch it from true to false (this might only affect MP3s...) Done. (4) Double-click the media.mediasource.enabled preference to switch it from true to false (if it's already false in XP, you can leave it as is) Done. (5) Double-click the media.ogg.enabled preference to switch it from true to false (should disable playing of OGG/OGV video) Done. (6) Double-click the media.webm.enabled preference to switch it from true to false (should disable playing of WebM video) Done. Many thanks. I'll let you know how it behaves.

Umnikazi wombuzo

cor-el said

You can try to disable hardware acceleration in Firefox.
  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
You need to close and restart Firefox after toggling this setting.

I've already done that. Thanks anyway cor-el.

''cor-el [[#answer-719463|said]]'' <blockquote> You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration </blockquote> I've already done that. Thanks anyway cor-el.