X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox not responding to keyboard

Kuphostiwe

I've noticed this over the past several versions of Firefox for OS X, and under Mavericks as well as Yosemite, on 2 different Macs of Mine: a 2009 Mac Pro and a 2012 Mac Book Pro.

The issues are: sometimes Firefox will not create a new tab or window when I press those keyboard commands, and sometimes, I am unable to type into form fields. Restarting Firefox will remedy the problem, until it happens again.

Otherwise, I find Firefox to be a great browser! Thank you for producing it.

I've noticed this over the past several versions of Firefox for OS X, and under Mavericks as well as Yosemite, on 2 different Macs of Mine: a 2009 Mac Pro and a 2012 Mac Book Pro. The issues are: sometimes Firefox will not create a new tab or window when I press those keyboard commands, and sometimes, I am unable to type into form fields. Restarting Firefox will remedy the problem, until it happens again. Otherwise, I find Firefox to be a great browser! Thank you for producing it.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/600.5.17 (KHTML, like Gecko) Version/8.0.5 Safari/600.5.17

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4256 izisombululo 59602 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? ----------------------- Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.'''

Umnikazi wombuzo

After a relatively short-term test, operating FF in Safe Mode, the key commands appear to be OK.

After a relatively short-term test, operating FF in Safe Mode, the key commands appear to be OK.

Umnikazi wombuzo

sorry..meant to include that this is FF version: 37.0.1

sorry..meant to include that this is FF version: 37.0.1
FredMcD
  • Top 10 Contributor
4256 izisombululo 59602 izimpendulo
Kuphostiwe

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Umnikazi wombuzo

Fred, thanks..I disabled them all.

Initially, it seemed that did the trick, but after an hour or two, neither CMD-N or CMD-T had any effect. FireFox was clearly the "in front" application.

It seemed to help to click on the FF chrome, and then those commands worked. Feels as though FF wasn't fully "sure" that it was indeed in front, and being interacted with.

Fred, thanks..I disabled them all. Initially, it seemed that did the trick, but after an hour or two, neither CMD-N or CMD-T had any effect. FireFox was clearly the "in front" application. It seemed to help to click on the FF chrome, and then those commands worked. Feels as though FF wasn't fully "sure" that it was indeed in front, and being interacted with.
FredMcD
  • Top 10 Contributor
4256 izisombululo 59602 izimpendulo
Kuphostiwe

Hmm. Most odd.

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

After, restart Firefox.

Poke around safe web sites. Are there any problems?

Hmm. Most odd. Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. After, restart Firefox. Poke around safe web sites. Are there any problems?

Umnikazi wombuzo

located and turned off hardware acceleration, restarted Firefox, problems persist.

Namely: with Firefox the active (in front) application, CMD-T produces no new tab, CMD-N produces no new window.

located and turned off hardware acceleration, restarted Firefox, problems persist. Namely: with Firefox the active (in front) application, CMD-T produces no new tab, CMD-N produces no new window.
FredMcD
  • Top 10 Contributor
4256 izisombululo 59602 izimpendulo
Kuphostiwe

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Umnikazi wombuzo

Tried that..about an hour was all I could take and I did not notice the aforementioned problems in Firefox. What does this tell us? That something in non-safe-boot mode is conflicting with FireFox?

Tried that..about an hour was all I could take and I did not notice the aforementioned problems in Firefox. What does this tell us? That something in non-safe-boot mode is conflicting with FireFox?

Okulungisiwe ngu mozcatt

FredMcD
  • Top 10 Contributor
4256 izisombululo 59602 izimpendulo
Kuphostiwe

That means one of the other programs on your computer is the cause.

Open the options on all of your protection programs, and tell them to leave the browses alone. For anti-virus, look under; Autoprotect or Programs Monitor

Check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

mac

http://www.clamxav.com/ free malware scanner for Mac OS X https://discussions.apple.com/docs/DOC-3291

That means one of the other programs on your computer is the cause. Open the options on all of your protection programs, and tell them to leave the browses alone. For anti-virus, look under; Autoprotect or Programs Monitor Check the programs that are on your computer '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. Go thru the list. If you find something that you don't know what it is, use a web search. '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Troubleshoot Firefox Issues Caused By Malware]''' {web link} :mac http://www.clamxav.com/ free malware scanner for Mac OS X https://discussions.apple.com/docs/DOC-3291