X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Graphical glitches in YouTube HTML5 player

Kuphostiwe

When I've been playing YouTube videos lately, I've noticed that a bunch of black boxes have been appearing over the player interface (The controls below the video) while the video is playing. Unfortunately, I can't provide a good screenshot, as the boxes come and go too quickly for me to get them. This issue still occurs if I restart Firefox in safe mode. I think it started happening with Firefox 37.

When I've been playing YouTube videos lately, I've noticed that a bunch of black boxes have been appearing over the player interface (The controls below the video) while the video is playing. Unfortunately, I can't provide a good screenshot, as the boxes come and go too quickly for me to get them. This issue still occurs if I restart Firefox in safe mode. I think it started happening with Firefox 37.

Isisombululo esikhethiwe

This problem doesn't seem to occur anymore with the new YouTube player.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • DivX Web Player version 1.4.0.233
  • This is the DjView-4.9 version of the DjVu plugin.See DjVuLibre.
  • Version: 5.41.0.0
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Unity Player 5.0.1f1
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Isisebenziso

  • Firefox 37.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/37.0.1/Linux/en-US/

Izandiso

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Context Search 0.6.3 ({902D2C4A-457A-4EF9-AD43-7014562929FF})
  • DownThemAll! 2.0.18 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Flagfox 5.0.13 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Form History Control 1.4.0.3 (formhistory@yahoo.com)
  • GNotifier 1.8.8 (jid1-OoNOA6XBjznvLQ@jetpack)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • MathML-fonts 2.1 (MathML-fonts@mozilla.com)
  • Mozilla Archive Format 3.0.4 ({7f57cf46-4467-4c2d-adfa-0cba7c507e54})
  • Multiple Tab Handler 0.8.2015030601 (multipletab@piro.sakura.ne.jp)
  • Open With 5.7.2 (openwith@darktrojan.net)
  • Places Maintenance 1.3 (places-maintenance@bonardo.net)
  • Print Edit 15.4 (printedit@DW-dev)
  • Restartless Restart 9 (restartless.restart@erikvold.com)
  • SPDY indicator 2.2 (spdyindicator@chengsun.github.com)
  • Tab Scope 1.6.1 (tabscope@xuldev.org)
  • Translate This! 3.0.2 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • UAControl 0.1.3.1 (uacontrol@qz.tsugumi.org)
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 3.0.2 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2014.07.01.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})
  • URL Fixer 4.1 ({0fa2149e-bb2c-4ac2-a8d3-479599819475})
  • webmFF 0.6 (jid1-jC0Q82QgwC1EJQ@jetpack)
  • Y U no validate 2013052401 ({20d36f97-15da-47ed-9f0a-13cbe85bdc84})
  • Zotero 4.0.26.4 (zotero@chnm.gmu.edu)
  • Zotero LibreOffice Integration 3.5.9 (zoteroOpenOfficeIntegration@zotero.org)
  • Flash Video Downloader - YouTube HD Download [4K] 7.2.3 (artur.dubovoy@gmail.com) (Akusebenzi)
  • Lightbeam 1.2.1 (jid1-F9UJ2thwoAm5gQ@jetpack) (Akusebenzi)
  • NoScript 2.6.9.21 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Akusebenzi)
  • Print pages to PDF 0.1.9.3 (printPages2Pdf@reinhold.ripper) (Akusebenzi)
  • Shumway 0.10.344 (shumway@research.mozilla.org) (Akusebenzi)
  • YouTube ALL HTML5 2.1.3 (jid1-qj0w91o64N7Eeg@jetpack) (Akusebenzi)
  • YouTube Center 2.1.0 (jid1-cwbvBTE216jjpg@jetpack) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Ivybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.3.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Umnikazi wombuzo

guigs2 said

Hello, Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35
If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. When you figure out what's causing your issues, please let us know. It might help others with the same problem.

As stated above, the issue persists in safe mode.

''guigs2 [[#answer-717759|said]]'' <blockquote> Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. </blockquote> As stated above, the issue persists in safe mode.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Sorry I should have been more careful. So this means that it is not due to hardware acceleration or and add on, but it might still be caused by an extension.

I did find some other solutions in the ubuntu forums, however I am not entirely sure which version you have.

Sorry I should have been more careful. So this means that it is not due to hardware acceleration or and add on, but it might still be caused by an extension. *[[Upgrade your graphics drivers to use hardware acceleration and WebGL]] *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] I did find some other solutions in the ubuntu forums, however I am not entirely sure which version you have. *[http://askubuntu.com/questions/125245/how-do-i-stop-video-tearing-nvidia-prop-driver-non-compositing-window-manager]
cor-el
  • Top 10 Contributor
  • Moderator
17483 izisombululo 158000 izimpendulo
Kuphostiwe

I think I've seen such moving black glitches as well on YouTube in Firefox 37 on Linux. They are most discernible on the red progression bar. I can't reproduce it, so I don't know what causes it. It is possible that sometimes the player content extends beyond the playing area into the controls area when there are switches between various sizes (i.e a video is available at higher resolution).

I think I've seen such moving black glitches as well on YouTube in Firefox 37 on Linux. They are most discernible on the red progression bar. I can't reproduce it, so I don't know what causes it. It is possible that sometimes the player content extends beyond the playing area into the controls area when there are switches between various sizes (i.e a video is available at higher resolution).

Umnikazi wombuzo

cor-el said

I think I've seen such moving black glitches as well on YouTube in Firefox 37 on Linux. They are most discernible on the red progression bar. I can't reproduce it, so I don't know what causes it. It is possible that sometimes the player content extends beyond the playing area into the controls area when there are switches between various sizes (i.e a video is available at higher resolution).

Yes, this is exactly what I'm seeing. This happens most of the time when I watch YouTube videos.

''cor-el [[#answer-718367|said]]'' <blockquote> I think I've seen such moving black glitches as well on YouTube in Firefox 37 on Linux. They are most discernible on the red progression bar. I can't reproduce it, so I don't know what causes it. It is possible that sometimes the player content extends beyond the playing area into the controls area when there are switches between various sizes (i.e a video is available at higher resolution). </blockquote> Yes, this is exactly what I'm seeing. This happens most of the time when I watch YouTube videos.

Umnikazi wombuzo

guigs2 said

Sorry I should have been more careful. So this means that it is not due to hardware acceleration or and add on, but it might still be caused by an extension. I did find some other solutions in the ubuntu forums, however I am not entirely sure which version you have.

The problem I have is not video tearing. It is the same thing that cor-el describes.

I am using the latest GPU drivers provided by the Ubuntu repositories. However, according to the troubleshooting information in Firefox, hardware acceleration actually isn't being used, despite being enabled.

''guigs2 [[#answer-718363|said]]'' <blockquote> Sorry I should have been more careful. So this means that it is not due to hardware acceleration or and add on, but it might still be caused by an extension. *[[Upgrade your graphics drivers to use hardware acceleration and WebGL]] *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] I did find some other solutions in the ubuntu forums, however I am not entirely sure which version you have. *[http://askubuntu.com/questions/125245/how-do-i-stop-video-tearing-nvidia-prop-driver-non-compositing-window-manager] </blockquote> The problem I have is not video tearing. It is the same thing that cor-el describes. I am using the latest GPU drivers provided by the Ubuntu repositories. However, according to the troubleshooting information in Firefox, hardware acceleration actually isn't being used, despite being enabled.

Umnikazi wombuzo

I managed to capture a video of the issue happening. I also attached a few representative screenshots from that video in case you can't watch the video.

https://docs.google.com/uc?id=0BzKVhsbqDk0MNGNJd18zcU9fYVk&export=download

I managed to capture a video of the issue happening. I also attached a few representative screenshots from that video in case you can't watch the video. [https://docs.google.com/uc?id=0BzKVhsbqDk0MNGNJd18zcU9fYVk&export=download https://docs.google.com/uc?id=0BzKVhsbqDk0MNGNJd18zcU9fYVk&export=download]

Umnikazi wombuzo

Are there any more troubleshooting steps I can try? None of the provided ones have helped.

Are there any more troubleshooting steps I can try? None of the provided ones have helped.

Umnikazi wombuzo

I am still having this issue, can anyone help?

I am still having this issue, can anyone help?
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Its possible to disable hardware acceleration in Flash or in Firefox however these may have been tried already and are only temporary solutions.

Its possible to disable hardware acceleration in Flash or in Firefox however these may have been tried already and are only temporary solutions.

Umnikazi wombuzo

guigs2 said

Its possible to disable hardware acceleration in Flash or in Firefox however these may have been tried already and are only temporary solutions.

I've already tried both of those. Neither helps.

''guigs2 [[#answer-728649|said]]'' <blockquote> Its possible to disable hardware acceleration in Flash or in Firefox however these may have been tried already and are only temporary solutions. </blockquote> I've already tried both of those. Neither helps.

Umnikazi wombuzo

Any advice for this? It still happens on Firefox 39.

Any advice for this? It still happens on Firefox 39.
cor-el
  • Top 10 Contributor
  • Moderator
17483 izisombululo 158000 izimpendulo
Kuphostiwe

On Linux hardware acceleration is usually not available, both for Firefox and for Flash.

I assume that the HTML5 media player is used in cases where this is happening?

You can try to disable GStreamer support to see if that makes websites switch to a Flash based player that might work better. about:config: media.gstreamer.enabled = false

On Linux hardware acceleration is usually not available, both for Firefox and for Flash. I assume that the HTML5 media player is used in cases where this is happening? You can try to disable GStreamer support to see if that makes websites switch to a Flash based player that might work better. <b>about:config</b>: media.gstreamer.enabled = false

Umnikazi wombuzo

cor-el said

On Linux hardware acceleration is usually not available, both for Firefox and for Flash. I assume that the HTML5 media player is used in cases where this is happening? You can try to disable GStreamer support to see if that makes websites switch to a Flash based player that might work better. about:config: media.gstreamer.enabled = false

While I haven't observed the issue with the Flash based player, using that for any extended length of time is highly undesirable. The Flash based YouTube player doesn't support all of the features, Flash will sometimes randomly crash on my computer, since I'm running the Windows version of Flash via Pipelight.

Should I try force-enabling hardware acceleration to see if that fixes the issues with the HTML5 player?

''cor-el [[#answer-754412|said]]'' <blockquote> On Linux hardware acceleration is usually not available, both for Firefox and for Flash. I assume that the HTML5 media player is used in cases where this is happening? You can try to disable GStreamer support to see if that makes websites switch to a Flash based player that might work better. <b>about:config</b>: media.gstreamer.enabled = false </blockquote> While I haven't observed the issue with the Flash based player, using that for any extended length of time is highly undesirable. The Flash based YouTube player doesn't support all of the features, Flash will sometimes randomly crash on my computer, since I'm running the Windows version of Flash via Pipelight. Should I try force-enabling hardware acceleration to see if that fixes the issues with the HTML5 player?

Isisombululo Esikhethiwe

This problem doesn't seem to occur anymore with the new YouTube player.

This problem doesn't seem to occur anymore with the new YouTube player.