X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Font not displaying properly

Kuphostiwe

Recently did a clean install of Windows 7. Installed Firefox, and text on webpages looks horrible. Here is a screenshot

http://i.imgur.com/U5R84Bc.png

I tried disabling hardware acceleration, no effect. I reinstalled the Arial font, which the web inspector says is being used, no effect. I have font smoothing turned off, and I am keeping it that way, I hate font smoothing

I know it can be fixed since I fixed it in the past without turning on font smoothing, I just can't remember how I did it.

Recently did a clean install of Windows 7. Installed Firefox, and text on webpages looks horrible. Here is a screenshot http://i.imgur.com/U5R84Bc.png I tried disabling hardware acceleration, no effect. I reinstalled the Arial font, which the web inspector says is being used, no effect. I have font smoothing turned off, and I am keeping it that way, I hate font smoothing I know it can be fixed since I fixed it in the past without turning on font smoothing, I just can't remember how I did it.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 17.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4267 izisombululo 59835 izimpendulo
Kuphostiwe

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.'''
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158892 izimpendulo
Kuphostiwe

Can you post the graphics section of the troubleshooting information page?

Also check for updates of your graphics display driver.

You can try to disable OMTC.

  • about:config page: layers.offmainthreadcomposition.enabled = false
Can you post the graphics section of the troubleshooting information page? *https://support.mozilla.org/kb/Using+the+Troubleshooting+Information+page Also check for updates of your graphics display driver. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration You can try to disable OMTC. *<b>about:config</b> page: <b>layers.offmainthreadcomposition.enabled</b> = false

Umnikazi wombuzo

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

I looked and it was already checked

My video driver is up to date.

I set layers.offmainthreadcomposition.enabled to false, no help.

''FredMcD [[#answer-713200|said]]'' <blockquote> Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' </blockquote> I looked and it was already checked My video driver is up to date. I set layers.offmainthreadcomposition.enabled to false, no help.

Umnikazi wombuzo

Video info from troubleshooting page

Graphics


Adapter Description: ATI Mobility Radeon X1300 Adapter Drivers: atiumdag atiumdva atitmmxx Adapter RAM: Unknown Device ID: 0x7149 Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer. DirectWrite Enabled: false (6.2.9200.16571) Driver Date: 6-21-2007 Driver Version: 8.383.1.1000 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer. Subsys ID: 200517aa Vendor ID: 0x1002 WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer. windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Video info from troubleshooting page Graphics -------- Adapter Description: ATI Mobility Radeon X1300 Adapter Drivers: atiumdag atiumdva atitmmxx Adapter RAM: Unknown Device ID: 0x7149 Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer. DirectWrite Enabled: false (6.2.9200.16571) Driver Date: 6-21-2007 Driver Version: 8.383.1.1000 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer. Subsys ID: 200517aa Vendor ID: 0x1002 WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer. windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Umnikazi wombuzo

I know it says to upgrade my video driver, but I have the latest one from the Lenovo page. There is no other diver I can find for the X1300

I know it says to upgrade my video driver, but I have the latest one from the Lenovo page. There is no other diver I can find for the X1300
FredMcD
  • Top 10 Contributor
4267 izisombululo 59835 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Download the current full installer anyway,

Download the current full installer anyway,

Umnikazi wombuzo

FredMcD said

Download the current full installer anyway,

I did, it didn't change the driver.

''FredMcD [[#answer-713417|said]]'' <blockquote> Download the current full installer anyway, </blockquote> I did, it didn't change the driver.

Umnikazi wombuzo

Something else I found

If I go to a page that uses Arial font, the font look all messed up like in the screenshot. If I go under Tool, Options, and select Arial as the Default Font, and UNCHECK "Allow pages to choose their own fonts", the font renders correctly

So apparently Firefox can correctly display the font, but only when I tell it to display it, not when the web page tells it to display it.

Something else I found If I go to a page that uses Arial font, the font look all messed up like in the screenshot. If I go under Tool, Options, and select Arial as the Default Font, and UNCHECK "Allow pages to choose their own fonts", the font renders correctly So apparently Firefox can correctly display the font, but only when I tell it to display it, not when the web page tells it to display it.

Umnikazi wombuzo

FYI, the text looks fine in IE. Same page, text is broken in Firefox, correct in IE

FYI, the text looks fine in IE. Same page, text is broken in Firefox, correct in IE

Okulungisiwe ngu lanceg

Umnikazi wombuzo

I can confirm it's not the driver at fault. I uninstalled the driver and tested the page using the standard VGA driver and got the same issue.

If this isn't fixable than it's bye bye Firefox. Kind of unbelievable that in 2015 a browser can't show text right.

I can confirm it's not the driver at fault. I uninstalled the driver and tested the page using the standard VGA driver and got the same issue. If this isn't fixable than it's bye bye Firefox. Kind of unbelievable that in 2015 a browser can't show text right.
Rimas Kudelis
  • Locale Leader
3 izisombululo 28 izimpendulo
Kuphostiwe

Haven't tried that (I love font smoothing), but here's a couple-years-old solution that I found on MozillaZine forums (I suppose you know about the about:config page):

  1. gfx.direct2d.disabled;false
  2. gfx.font_rendering.cleartype.use_for_downloadable_fonts;false
  3. gfx.font_rendering.cleartype_params.rendering_mode;2
  4. gfx.font_rendering.directwrite.enabled;true

Apparently, there is even an addon which helps tune antialiasing settings (also thanks to that thread).

Haven't tried that (I love font smoothing), but here's a couple-years-old solution that I found [http://forums.mozillazine.org/viewtopic.php?f=38&t=2428091 on MozillaZine forums] (I suppose you know about the about:config page): # gfx.direct2d.disabled;false # gfx.font_rendering.cleartype.use_for_downloadable_fonts;false # gfx.font_rendering.cleartype_params.rendering_mode;2 # gfx.font_rendering.directwrite.enabled;true Apparently, there is even [https://addons.mozilla.org/en-US/firefox/addon/anti-aliasing-tuner/?src=api an addon] which helps tune antialiasing settings (also thanks to that thread).

Okulungisiwe ngu Rimas Kudelis

Umnikazi wombuzo

Rimas Kudelis said

Haven't tried that (I love font smoothing), but here's a couple-years-old solution that I found on MozillaZine forums (I suppose you know about the about:config page):
  1. gfx.direct2d.disabled;false
  2. gfx.font_rendering.cleartype.use_for_downloadable_fonts;false
  3. gfx.font_rendering.cleartype_params.rendering_mode;2
  4. gfx.font_rendering.directwrite.enabled;true
Apparently, there is even an addon which helps tune antialiasing settings (also thanks to that thread).

Made those changes, made no difference

''Rimas Kudelis [[#answer-713872|said]]'' <blockquote> Haven't tried that (I love font smoothing), but here's a couple-years-old solution that I found [http://forums.mozillazine.org/viewtopic.php?f=38&t=2428091 on MozillaZine forums] (I suppose you know about the about:config page): # gfx.direct2d.disabled;false # gfx.font_rendering.cleartype.use_for_downloadable_fonts;false # gfx.font_rendering.cleartype_params.rendering_mode;2 # gfx.font_rendering.directwrite.enabled;true Apparently, there is even [https://addons.mozilla.org/en-US/firefox/addon/anti-aliasing-tuner/?src=api an addon] which helps tune antialiasing settings (also thanks to that thread). </blockquote> Made those changes, made no difference
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158892 izimpendulo
Kuphostiwe

Did you verify in the Inspector what Firefox is actually using?

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Did you verify in the Inspector what Firefox is actually using? You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector

Umnikazi wombuzo

cor-el said

Did you verify in the Inspector what Firefox is actually using? You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector.


Various fonts, Arial or some sort of San Serif

''cor-el [[#answer-714118|said]]'' <blockquote> Did you verify in the Inspector what Firefox is actually using? You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector </blockquote> Various fonts, Arial or some sort of San Serif

Umnikazi wombuzo

Well, I think I managed to fix it. I installed Stylish and added this CSS

@font-face { font-family: "Open Sans"; src: local("Verdana"); }


And that eliminated the problem. Looks like Open Sans font was the culprit. I tried adding that code in a userContent.css but it did nothing. In Stylish it worked

Well, I think I managed to fix it. I installed Stylish and added this CSS @font-face { font-family: "Open Sans"; src: local("Verdana"); } And that eliminated the problem. Looks like Open Sans font was the culprit. I tried adding that code in a userContent.css but it did nothing. In Stylish it worked
Rimas Kudelis
  • Locale Leader
3 izisombululo 28 izimpendulo
Kuphostiwe

Open Sans is most likely a downloadable font, in which case gfx.font_rendering.cleartype.use_for_downloadable_fonts should have an effect on it. I hope you tried restarting Firefox after changing these preferences?

Open Sans is most likely a downloadable font, in which case ''' gfx.font_rendering.cleartype.use_for_downloadable_fonts''' should have an effect on it. I hope you tried restarting Firefox after changing these preferences?
Rimas Kudelis
  • Locale Leader
3 izisombululo 28 izimpendulo
Kuphostiwe

Alternatively, you may want to disable downloadable fonts altogether (you already know how to do that) instead of using Stylish in every website which uses them. If you choose this path, you should also clear Firefox cache to get rid of fonts that have already been downloaded. You should then be able to browse websites without having Stylish installed and enabled.

Alternatively, you may want to disable downloadable fonts altogether ([https://support.mozilla.org/en-US/questions/1055566#answer-713698 you already know how to do that]) instead of using Stylish in every website which uses them. If you choose this path, you should also clear Firefox cache to get rid of fonts that have already been downloaded. You should then be able to browse websites without having Stylish installed and enabled.

Okulungisiwe ngu Rimas Kudelis

jscher2000
  • Top 10 Contributor
8785 izisombululo 71847 izimpendulo
Kuphostiwe

Actually, disabling downloadable fonts will cause missing icons on many sites that have switched from image icons to font-based icons, so the font-switching CSS rule probably makes more sense if this font is the only one that looks terrible.

Actually, disabling downloadable fonts will cause missing icons on many sites that have switched from image icons to font-based icons, so the font-switching CSS rule probably makes more sense if this font is the only one that looks terrible.
Rimas Kudelis
  • Locale Leader
3 izisombululo 28 izimpendulo
Kuphostiwe

jsher2000: good point indeed, I didn't think about this! Although in my opinion still the best thing to do is to figure out how to disable font smoothing properly, and to do just that.

jsher2000: good point indeed, I didn't think about this! Although in my opinion still the best thing to do is to figure out how to disable font smoothing properly, and to do just that.

Umnikazi wombuzo

SO while this works, every time I come across a page with busted fonts I need to edit the stylish page to fix them

Does no one know why firefox does not display fonts correctly?

SO while this works, every time I come across a page with busted fonts I need to edit the stylish page to fix them Does no one know why firefox does not display fonts correctly?