Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox crashes

  • 2 uphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Greetings, after extensive research on how to avoid the firefox browser from crashing when visiting a site like youtube or grooveshark.com i have run out of all suggested options available on the help links supplied by the mozilla site. After folling all troubleshooting directions still no response when i visit youtube, the site hangs and i must use the "force quit" option on my macbook pro. any help would be grateful. dominic.

edit: removed your mail address from public display, since the only thing it will attract are spam bots. you will be notified per mail once somebody replies to the thread. (philipp)

Okulungisiwe ngu philipp

All Replies (2)

more options

You did not say what you tried to do, so you may get told to do something again.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Since those are media sites, to see whether this is a problem with the Flash player, could you try this experiment: set Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it so we can distinguish between general page load issues and problem starting or using Flash.

To set "Ask to Activate", open the Add-ons page using either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and usually one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

If you do not need to activate Flash, I suggest just ignoring those notifications and not bothering to close them. Closing them may stop Firefox from showing them again when you actually want to use them.