X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"This plug-in is disasbled" OK *Which* plug-in?

Kuphostiwe

Sioe is supposed to display a P_DF or some other text or image format., , Got that message. , ,It links to the Add-on manager, but gives no clue about what plug-in needs to be managed.

And of course I have Acrobat reader, and it's not disabled.

Sioe is supposed to display a P_DF or some other text or image format., , Got that message. , ,It links to the Add-on manager, but gives no clue about what plug-in needs to be managed. And of course I have Acrobat reader, and it's not disabled.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Microsoft Lync 2010 Meeting Join Plug-in
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • WebEx64 General Plugin Container Version 205
  • iPhoto6

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Could you try clicking the plugin notification icon in the address bar: it looks like a small Lego block and appears to the left of the site address. It should report the status of plugins used by the page and let you activate a plugin if your permission is required.

If that doesn't have more specific information, do you want to post the address of the page (assuming no account/login is required to view the page).

Could you try clicking the plugin notification icon in the address bar: it looks like a small Lego block and appears to the left of the site address. It should report the status of plugins used by the page and let you activate a plugin if your permission is required. If that doesn't have more specific information, do you want to post the address of the page (assuming no account/login is required to view the page).
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hmm, your plugin list (see the More System Details link next to your post) doesn't show Adobe Acrobat/PDF. When you view the Add-ons page, Plugins category, is it set to "Never Activate"? If so, I suggest using "Ask to Activate" for this and other "in-page viewer" type plugins.

Hmm, your plugin list (see the More System Details link next to your post) doesn't show Adobe Acrobat/PDF. When you view the Add-ons page, Plugins category, is it set to "Never Activate"? If so, I suggest using "Ask to Activate" for this and other "in-page viewer" type plugins.
cor-el
  • Top 10 Contributor
  • Moderator
17673 izisombululo 159870 izimpendulo
Kuphostiwe

Impendulo Ewusizo

See also: *https://support.mozilla.org/kb/view-pdf-files-firefox-without-downloading-them *https://support.mozilla.org/kb/disable-built-pdf-viewer-and-use-another-viewer

Umnikazi wombuzo

I went to Adobe and downloaded the latest reader. (Previously,, I had Firefox configured to open PDF's with Acrobat.)

The notification icon tells me that the plug-in enabled. No more "Plug-in is disabled" message, but the page is still blank.

This is the US patent office; there may be something about limited access, although the whole idea of patents is "disclosure."

I went to Adobe and downloaded the latest reader. (Previously,, I had Firefox configured to open PDF's with Acrobat.) The notification icon tells me that the plug-in enabled. No more "Plug-in is disabled" message, but the page is still blank. This is the US patent office; there may be something about limited access, although the whole idea of patents is "disclosure."
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Adobe's plugin giving blank pages in Firefox on Mac sounds like an issue that has existed for several years now. Our support article "PDF files are blank or cause an error message on Mac" dates back to 2012. You might have to use a different viewer.

Just a note about patents online:

USPTO PDFs should be widely compatible, but many pages or drawings actually are TIFF files, and those often do not show correctly in QuickTime for some reason.

On Windows, the recommended plugin for USPTO TIFF files is AlternaTIFF, but I don't know what works best on Mac. The USPTO might have suggestions.

Adobe's plugin giving blank pages in Firefox on Mac sounds like an issue that has existed for several years now. Our support article "[[PDF files are blank or cause an error message on Mac]]" dates back to 2012. You might have to use a different viewer. Just a note about patents online: USPTO PDFs should be widely compatible, but many pages or drawings actually are TIFF files, and those often do not show correctly in QuickTime for some reason. On Windows, the recommended plugin for USPTO TIFF files is AlternaTIFF, but I don't know what works best on Mac. The USPTO might have suggestions.

Umnikazi wombuzo

A couple of clarifications:

1. I have had Firefox configured to open PDFs with acrobat, not with the Acrobat Reader plug-in.

2. I wanted to point out that the error message is useless if it doesn't identify the plug-in that it thinks is causing a problem.

A couple of clarifications: 1. I have had Firefox configured to open PDFs with acrobat, not with the Acrobat Reader plug-in. 2. I wanted to point out that the error message is useless if it doesn't identify the plug-in that it thinks is causing a problem.
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

If you have selected to open PDFs outside of Firefox in Adobe Reader but Firefox still tries to open a PDF in a tab, one possibility is that the website is not sending the content type header (application/pdf) that Firefox uses to select the application. This is tricky to work around.

Another possibility is that the settings file which stores the application preferences has become corrupted. The standard medicine for that is to remove the file and let Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Finder.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit/Quit

Pause while Firefox finishes its cleanup, then in the Finder window rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. Hopefully the next time you indicate your PDF preference, it will stick.

If you have selected to open PDFs outside of Firefox in Adobe Reader but Firefox still tries to open a PDF in a tab, one possibility is that the website is not sending the content type header (application/pdf) that Firefox uses to select the application. This is tricky to work around. Another possibility is that the settings file which stores the application preferences has become corrupted. The standard medicine for that is to remove the file and let Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Finder. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit/Quit Pause while Firefox finishes its cleanup, then in the Finder window rename '''mimeTypes.rdf''' to something like mimeTypes.old. Start Firefox back up again. Hopefully the next time you indicate your PDF preference, it will stick.

Umnikazi wombuzo

Seems a bit drastic given that I have no problem whatsoever reading PDFs on other sites. One possibility is that he Patent Office is requiring some other plug-in, so an error message that doesn't say WHAT plug-in is no help.

I just checked my add-ons and note that several plug-ins are set to "Ask to activate." Is it possible that the "Plug-in is disabled" message is how it asks? Again, no help if it doesn't say which one.

Seems a bit drastic given that I have no problem whatsoever reading PDFs on other sites. One possibility is that he Patent Office is requiring some other plug-in, so an error message that doesn't say WHAT plug-in is no help. I just checked my add-ons and note that several plug-ins are set to "Ask to activate." Is it possible that the "Plug-in is disabled" message is how it asks? Again, no help if it doesn't say which one.
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Yes, if the content-type indicated by the website does not match a content-type one of your plugins says it knows how to handle, then Firefox does not know what plugin is required. In the old days (maybe still?) there was a button to search for a compatible plugin, perhaps on the Mozilla Add-ons site, but I don't know how effective that feature was.

Can you provide a link to a page that has this problem?

Yes, if the content-type indicated by the website does not match a content-type one of your plugins says it knows how to handle, then Firefox does not know what plugin is required. In the old days (maybe still?) there was a button to search for a compatible plugin, perhaps on the Mozilla Add-ons site, but I don't know how effective that feature was. Can you provide a link to a page that has this problem?
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

By the way, I previously mentioned that the plugin notification icon in the address bar is your best source of information about plugins the page wants to use. If a plugin set to Ask to Activate is needed, clicking that icon will let you activate it.

By the way, I previously mentioned that the plugin notification icon in the address bar is your best source of information about plugins the page wants to use. If a plugin set to Ask to Activate is needed, clicking that icon will let you activate it.

Umnikazi wombuzo

Knock yourself out. http://pdfpiw.uspto.gov/.piw?Docid=08897573&idkey=NONE

The person who supplied the link says that no ID key is needed. Maybe he's wrong.

On that page the plug-in button informs me that the Acrobat reader plug-in is enabled, so that's probably what the page wants. And I just checked Adobe, and yes I have the latest version.

Knock yourself out. http://pdfpiw.uspto.gov/.piw?Docid=08897573&idkey=NONE The person who supplied the link says that no ID key is needed. Maybe he's wrong. On that page the plug-in button informs me that the Acrobat reader plug-in is enabled, so that's probably what the page wants. And I just checked Adobe, and yes I have the latest version.
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

I see: with the Adobe Acrobat plugin enabled, the page uses the plugin despite having chosen the external viewer, and with the plugin disabled, Firefox still does not use the external viewer. (Screen shots attached)

The page uses the "embed" tag, which does not seem to trigger Firefox's download instincts, at least on your system and mine. I don't recall whether there is a way to override that.

I see: with the Adobe Acrobat plugin enabled, the page uses the plugin despite having chosen the external viewer, and with the plugin disabled, Firefox ''still'' does not use the external viewer. (Screen shots attached) The page uses the "embed" tag, which does not seem to trigger Firefox's download instincts, at least on your system and mine. I don't recall whether there is a way to override that.