X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox doesn't show text on certain websites.

Kuphostiwe

On several websites that I visit regularly (e.g. Autosport.com) Fiefox will not display text whilst other browsers do. This is very frustrating because I much prefer Firefox! I have screenshots of Firefox v IE but apparently I can't post them until I have a received a reply.

On several websites that I visit regularly (e.g. Autosport.com) Fiefox will not display text whilst other browsers do. This is very frustrating because I much prefer Firefox! I have screenshots of Firefox v IE but apparently I can't post them until I have a received a reply.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • GEPlugin
  • Google Update
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealDownloader Plugin
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealPlayer Download Plugin
  • 6.0.12.1578
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Unity Player 4.6.1f1
  • VLC media player Web Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0

Eminye Imininingwane

Umnikazi wombuzo

Screenshots below of Autosport/F1 web page. 1st one is Firefox, 2nd IE.

Screenshots below of Autosport/F1 web page. 1st one is Firefox, 2nd IE.
cor-el
  • Top 10 Contributor
  • Moderator
17477 izisombululo 157949 izimpendulo
Kuphostiwe

Does any text appear when you try to use the mouse to select something in that blank area?

Do you see the text in the Inspector if you select Inspect Element to open the Inspector.

This can be a problem with the font that is used to display the text.

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
Does any text appear when you try to use the mouse to select something in that blank area? Do you see the text in the Inspector if you select Inspect Element to open the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector This can be a problem with the font that is used to display the text. You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"
FredMcD
  • Top 10 Contributor
4246 izisombululo 59406 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?

Umnikazi wombuzo

Regretably, none of the above works - no matter how I open these web pages the problem remains. This condition has only existed for about the past six months or so (Firefox has been updated several times since then).For the record - another frequently used website is shown below;

Regretably, none of the above works - no matter how I open these web pages the problem remains. This condition has only existed for about the past six months or so (Firefox has been updated several times since then).For the record - another frequently used website is shown below;

Umnikazi wombuzo

And another example;

And another example;
cor-el
  • Top 10 Contributor
  • Moderator
17477 izisombululo 157949 izimpendulo
Kuphostiwe

You may have a problem with the Arial font.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You may have a problem with the Arial font. You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"

Umnikazi wombuzo

Clearer example of Autosport page - when using the mouse to select something in the blank area, the "hand" appears but no text.

Clearer example of Autosport page - when using the mouse to select something in the blank area, the "hand" appears but no text.
cor-el
  • Top 10 Contributor
  • Moderator
17477 izisombululo 157949 izimpendulo
Kuphostiwe

Did you try a different default font?

Did you try a different default font?

Umnikazi wombuzo

I've tried several and "Allow pages to choose their own fonts, instead of my selections above" is selected.

I've tried several and "Allow pages to choose their own fonts, instead of my selections above" is selected.

Umnikazi wombuzo

I've unticked the "Allow pages to choose their own fonts, instead of my selections above" and the pages now read correctly in whatever font I seem to select. Many thanks for your help!

I've unticked the "Allow pages to choose their own fonts, instead of my selections above" and the pages now read correctly in whatever font I seem to select. Many thanks for your help!
cor-el
  • Top 10 Contributor
  • Moderator
17477 izisombululo 157949 izimpendulo
Kuphostiwe

Note that disabling website fonts this way causes problems with web pages that use an icon font to display icons by using a font that is downloaded via an @font-face CSS rule (you may see little boxes with the hex code).

Did you check what font Firefox was using with the option enabled?

Note that disabling website fonts this way causes problems with web pages that use an icon font to display icons by using a font that is downloaded via an @font-face CSS rule (you may see little boxes with the hex code). Did you check what font Firefox was using with the option enabled?

Umnikazi wombuzo

With this option enabled Firefox appeared to be using Arial?

With this option enabled Firefox appeared to be using Arial?
cor-el
  • Top 10 Contributor
  • Moderator
17477 izisombululo 157949 izimpendulo
Kuphostiwe

Did you try to reinstall the Arial font like I suggested above.


You can use the System File Checker to check for missing and corrupted font files. The System File Checker needs to be run from an Elevated Command Prompt. Open a cmd.exe window as Administrator: Start, click Programs, click Accessories Right-click Command Prompt, and choose "Run as administrator" Click past the UAC Screen After the cmd.exe prompt, type: sfc.exe /scannow and press Enter

Did you try to reinstall the Arial font like I suggested above. ---- You can use the System File Checker to check for missing and corrupted font files. The System File Checker needs to be run from an Elevated Command Prompt. Open a cmd.exe window as Administrator: Start, click Programs, click Accessories Right-click Command Prompt, and choose "Run as administrator" Click past the UAC Screen After the cmd.exe prompt, type: sfc.exe /scannow and press Enter

Umnikazi wombuzo

I'm afraid you're getting a little too technical for me. I have selected Arial as the default font and with the option unticked all the websites I have tried seem to be working correctly.

I'm afraid you're getting a little too technical for me. I have selected Arial as the default font and with the option unticked all the websites I have tried seem to be working correctly.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71069 izimpendulo
Kuphostiwe

Sooner or later you'll probably find a page where there are tall boxes with 2 rows of 2 characters each. Then you'll know that the page wants to use characters in a downloadable font that Firefox can't match from what's on your system.

Meanwhile, the Autosport page lists its preferred fonts in this order:

  • Lucida Grande
  • Verdana
  • Arial
  • Helvetica
  • sans-serif

Generally speaking, Windows users do not have Lucida Grande unless they installed Safari for Windows several years ago, or picked it up from some other font package. In my case (screenshot - Windows 7), Firefox uses Verdana. Perhaps one of those two fonts on your system has a problem?

Sooner or later you'll probably find a page where there are tall boxes with 2 rows of 2 characters each. Then you'll know that the page wants to use characters in a downloadable font that Firefox can't match from what's on your system. Meanwhile, the Autosport page lists its preferred fonts in this order: * Lucida Grande * Verdana * Arial * Helvetica * sans-serif Generally speaking, Windows users do not have Lucida Grande unless they installed Safari for Windows several years ago, or picked it up from some other font package. In my case (screenshot - Windows 7), Firefox uses Verdana. Perhaps one of those two fonts on your system has a problem?
jscher2000
  • Top 10 Contributor
8695 izisombululo 71069 izimpendulo
Kuphostiwe

Apac:

  • Lucida Grande
  • arial
  • helvetica
  • verdana
  • sans-serif

KLM:

  • Lucida Grande
  • Lucida Sans Unicode
  • Helvetica Neue
  • Helvetica
  • verdana
  • arial
  • sans-serif

You may have a bad Lucida Grande in your Windows Fonts folder.

Apac: * Lucida Grande * arial * helvetica * verdana * sans-serif KLM: * Lucida Grande * Lucida Sans Unicode * Helvetica Neue * Helvetica * verdana * arial * sans-serif You may have a bad Lucida Grande in your Windows Fonts folder.

Umnikazi wombuzo

Thank you for taking the time and trouble to help. It certainly does look as if this could be the problem. I wonder why IE, Chrome and Opera don't pick up the same fault?

Thank you for taking the time and trouble to help. It certainly does look as if this could be the problem. I wonder why IE, Chrome and Opera don't pick up the same fault?

Umnikazi wombuzo

When I select Lucida as my default font, with the option box unchecked, I lose text on ALL websites. With the box checked just the "problem" sites don't display text. How safe is it to delete Lucida Grande from my Windows Fonts folder?

When I select Lucida as my default font, with the option box unchecked, I lose text on ALL websites. With the box checked just the "problem" sites don't display text. How safe is it to delete Lucida Grande from my Windows Fonts folder?
jscher2000
  • Top 10 Contributor
8695 izisombululo 71069 izimpendulo
Kuphostiwe

Impendulo Ewusizo

davidgoodlad said

How safe is it to delete Lucida Grande from my Windows Fonts folder?

I think it depends on how it got there. If it was dropped by Safari for Windows, which is no longer a product that Apple supports, I think it's safe to remove. If it belongs to some other software, then that software might object to losing the font. I'm not sure of the best way to determine that. I suppose you could hedge your bets by dragging it into a different folder so Windows just doesn't see it.

''davidgoodlad [[#answer-710139|said]]'' <blockquote> How safe is it to delete Lucida Grande from my Windows Fonts folder? </blockquote> I think it depends on how it got there. If it was dropped by Safari for Windows, which is no longer a product that Apple supports, I think it's safe to remove. If it belongs to some other software, then that software might object to losing the font. I'm not sure of the best way to determine that. I suppose you could hedge your bets by dragging it into a different folder so Windows just doesn't see it.

Umnikazi wombuzo

Many thanks jscher2000

Many thanks jscher2000