Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Is there a way to globally disable the Firefox cache?

  • 3 uphendule
  • 3 zinale nkinga
  • 369 views
  • Igcine ukuphendulwa ngu hofmeyer

more options

I'm running a computer lab with several linux PCs (Ubuntu 14.04 LTS / latest version of Firefox). The users homedirectories are located on a central fileserver and limited by a diskquota. Unfortunately Firefox takes up a large part (if not all) of this quota with it's cache. Is there a way to globally disable the cache?

EDIT: Adding the following lines to /etc/xul-ext/ubufox.js helped...

pref("browser.cache.disk.enable", false); pref("browser.cache.disk.smart_size.enabled", false); pref("browser.cache.disk.capacity", 0);

I'm running a computer lab with several linux PCs (Ubuntu 14.04 LTS / latest version of Firefox). The users homedirectories are located on a central fileserver and limited by a diskquota. Unfortunately Firefox takes up a large part (if not all) of this quota with it's cache. Is there a way to globally disable the cache? EDIT: Adding the following lines to /etc/xul-ext/ubufox.js helped... pref("browser.cache.disk.enable", false); pref("browser.cache.disk.smart_size.enabled", false); pref("browser.cache.disk.capacity", 0);

Okulungisiwe ngu hofmeyer

Isisombululo esikhethiwe

Adding the following lines to /etc/xul-ext/ubufox.js helped...

pref("browser.cache.disk.enable", false); pref("browser.cache.disk.smart_size.enabled", false); pref("browser.cache.disk.capacity", 0);

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (3)

more options

There is but there might be performance issues with doing so. I'm wondering is this really Firefox's cache taking up all that space? I've always seen Firefox save cache on the computer itself.

Ideas I've got:

  • Lower the maximum limit of the cache in the Options > Advanced > Network tab. Checkmark "Override automatic cache management" & set a limit there. Ex. Limit cache to 50 MB of space
  • Set Firefox to clear the cache at every shutdown using the "Clear history when Firefox closes" option. Click the Settings button for this option & checkmark "Cache" (Article link)
  • Place everyone's Firefox in permanent private browsing mode (no cache, history or passwords are saved in this mode) (Article link)
  • Disable Firefox cache with the browser.cache.disk.enable about:config setting and see how that goes (not recommended)

I said not recommended on the last option because you may see weird performance results and other side effects that you won't be able to determine if it was due to disabling that setting.

more options

You can use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values.

Place a local-settings.js file in the defaults\pref folder where also the channel-prefs.js file is located to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);

These functions can be used in the mozilla.cfg file:

defaultPref();	// set new default value
pref();		// set pref, allow changes in current session
lockPref();	// lock pref, disallow changes

See:

more options

Isisombululo Esikhethiwe

Adding the following lines to /etc/xul-ext/ubufox.js helped...

pref("browser.cache.disk.enable", false); pref("browser.cache.disk.smart_size.enabled", false); pref("browser.cache.disk.capacity", 0);