X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 37 Beta on Windows 8.1 has lag and stuttering when scrolling

Kuphostiwe

I just recently got a new laptop, and since the minute I've installed firefox on it there has been lag when scrolling webpages. It seems to start off not too badly, with there being some stuttering when I first open firefox, however it seems like the longer I'm browsing the worse it gets, to the point where sometimes I'll start scrolling and then a second later firefox will just jump to the bottom of the page. Internet Explorer and Chrome both have perfectly smooth scrolling.

I've tried numerous things to fix it already, this is some of the stuff I can remember trying: -Turning off hardware acceleration and smooth scrolling -Starting in safe mode -Complete reinstall with new profile -Updating graphics card and intel drivers

Specs of the new laptop: Core i7 GTX 970M 16Gb RAM

I just recently got a new laptop, and since the minute I've installed firefox on it there has been lag when scrolling webpages. It seems to start off not too badly, with there being some stuttering when I first open firefox, however it seems like the longer I'm browsing the worse it gets, to the point where sometimes I'll start scrolling and then a second later firefox will just jump to the bottom of the page. Internet Explorer and Chrome both have perfectly smooth scrolling. I've tried numerous things to fix it already, this is some of the stuff I can remember trying: -Turning off hardware acceleration and smooth scrolling -Starting in safe mode -Complete reinstall with new profile -Updating graphics card and intel drivers Specs of the new laptop: Core i7 GTX 970M 16Gb RAM

Isisombululo esikhethiwe

4 months later, and a clean install of Windows 10 seems to have fixed it. Was probably a bad Windows 8.1 install.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 5.1.30514.0

Isisebenziso

  • Firefox 37.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/37.0/WINNT/en-US/

Izandiso

  • Avast Online Security 10.2.0.187 (wrc@avast.com) (Akusebenzi)
  • Disable HTML5 Fullscreen Alert 0.1 (jid1-Duz06d3mQhPItw@jetpack) (Akusebenzi)
  • FlashDisable 1.0.0 (jid0-bbA9VAawX3LMWDu668aUDrpQVXU@jetpack) (Akusebenzi)
  • FoxyProxy Standard 4.5.1 (foxyproxy@eric.h.jung) (Akusebenzi)
  • Hostname in Titlebar 3.0.1 (bughunter2@hostnameintitlebar) (Akusebenzi)
  • HTTPS-Everywhere 4.0.3 (https-everywhere@eff.org) (Akusebenzi)
  • Ratings Preview for YouTube™ 4.1.2 (jid0-G6461UajDjhNAwSukoedlkhD0XA@jetpack) (Akusebenzi)
  • Reddit Enhancement Suite 4.5.4 (jid1-xUfzOsOFlzSOXg@jetpack) (Akusebenzi)
  • RSS Ticker 14 ({1f91cde0-c040-11da-a94d-0800200c9a66}) (Akusebenzi)
  • SoundCloud Downloader - Technowise 0.94 ({c8d3bc80-0810-4d21-a2c2-be5f2b2832ac}) (Akusebenzi)
  • Stylish 2.0.2 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8}) (Akusebenzi)
  • µBlock 0.8.8.2 ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: NVIDIA GeForce GTX 970M
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x13d8
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 3072
  • adapterSubsysID: 04168086
  • adapterSubsysID2: 674b1a58
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 3-3-2015
  • driverDate2: 2-5-2015
  • driverVersion: 10.18.14.4156
  • driverVersion2: 9.18.13.4752
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Yebo
FredMcD
  • Top 10 Contributor
4266 izisombululo 59814 izimpendulo
Kuphostiwe

Was the issue still there when you Start Firefox in Safe Mode {web link} ?

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Was the issue still there when you '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} ? Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Umnikazi wombuzo

Strangely enough while booting firefox into safe mode didn't seem to help, booting the actual computer into safe mode seems to have made an improvement. What could be the cause?

Strangely enough while booting firefox into safe mode didn't seem to help, booting the actual computer into safe mode seems to have made an improvement. What could be the cause?
FredMcD
  • Top 10 Contributor
4266 izisombululo 59814 izimpendulo
Kuphostiwe

That means one of the other programs on your computer is the cause.

Open the options on all of your protection programs, and tell them to leave the browses alone.

check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

• Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

That means one of the other programs on your computer is the cause. Open the options on all of your protection programs, and tell them to leave the browses alone. check the programs that are on your computer '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory. Go thru the list. If you find something that you don't know what it is, use a web search. '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Troubleshoot Firefox Issues Caused By Malware]''' {web link}

Umnikazi wombuzo

I think I made the mistake of thinking it worked because of safe mode, when instead it was scrolling better because I had plugged my laptop back in. When testing now while plugged in (not in safe mode) scrolling is smooth. When I unplug it starts lagging again. The laptop underclocks the CPU in order to save battery, does firefox require more processing power than is available? Why does IE still scroll smoothly despite this?

I think I made the mistake of thinking it worked because of safe mode, when instead it was scrolling better because I had plugged my laptop back in. When testing now while plugged in (not in safe mode) scrolling is smooth. When I unplug it starts lagging again. The laptop underclocks the CPU in order to save battery, does firefox require more processing power than is available? Why does IE still scroll smoothly despite this?
FredMcD
  • Top 10 Contributor
4266 izisombululo 59814 izimpendulo
Kuphostiwe

Let's start with the battery. There are many utility programs out there. Look for one that can check your battery. There could already be one installed by the manufacturer.

See if this helps;

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

loki149 said

Why does IE still scroll smoothly despite this?

You are talking about two different programs. Just a question, How many add-ons are running? What kinds? Each add-on draws a bit from the CPU. Some more than others.

Let's start with the battery. There are many utility programs out there. Look for one that can check your battery. There could already be one installed by the manufacturer. See if this helps; '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it ''loki149 [[#answer-707259|said]]'' <blockquote> Why does IE still scroll smoothly despite this? </blockquote> You are talking about two different programs. Just a question, How many add-ons are running? What kinds? Each add-on draws a bit from the CPU. Some more than others.

Umnikazi wombuzo

HWmonitor reports that my battery is not worn and can reach full capacity.

Among my current addons is FlashDisable, which as far as I can tell does the same thing as Flash block.

I also have installed: Disable HTML 5 Fullscreen Alert FoxyProxy Hostname in Titlebar HTTPS-Everywhere Ratings Preview for Youtube Reddit Enhancement Suite RSS Ticker Stylish uBlock

HWmonitor reports that my battery is not worn and can reach full capacity. Among my current addons is FlashDisable, which as far as I can tell does the same thing as Flash block. I also have installed: Disable HTML 5 Fullscreen Alert FoxyProxy Hostname in Titlebar HTTPS-Everywhere Ratings Preview for Youtube Reddit Enhancement Suite RSS Ticker Stylish uBlock
FredMcD
  • Top 10 Contributor
4266 izisombululo 59814 izimpendulo
Kuphostiwe

Please use both safe modes described here; https://support.mozilla.org/en-US/questions/1053099#answer-706970

Please use both safe modes described here; https://support.mozilla.org/en-US/questions/1053099#answer-706970

Umnikazi wombuzo

In Windows safe mode and Firefox safe mode the scrolling works well. However it seems like Windows safe mode doesn't apply any power plan settings, like allowing the CPU to go lower than the base 2.6GHz as it does normally.

I don't believe the addons are to blame as starting Firefox in safe mode when I'm experiencing the lag has no effect.

Could it be an instance of this bug? https://bugzilla.mozilla.org/show_bug.cgi?id=975912

In Windows safe mode and Firefox safe mode the scrolling works well. However it seems like Windows safe mode doesn't apply any power plan settings, like allowing the CPU to go lower than the base 2.6GHz as it does normally. I don't believe the addons are to blame as starting Firefox in safe mode when I'm experiencing the lag has no effect. Could it be an instance of this bug? https://bugzilla.mozilla.org/show_bug.cgi?id=975912
FredMcD
  • Top 10 Contributor
4266 izisombululo 59814 izimpendulo
Kuphostiwe

I took a look. Did you read the suggestion about the CPU setting?

If you have not done so, you can have any new postings sent to you as well.

I took a look. Did you read the suggestion about the CPU setting? If you have not done so, you can have any new postings sent to you as well.

Umnikazi wombuzo

I have, though I don't see any significant improvement until I set the minimum processor state all the way from 5% to 75%. At 100% scrolling is perfect.

I'm not sure I can justify increasing it all the way to 75%, as my battery life is sure to take a noticeable hit. Just as a comparison, at 5% the CPU will idle at 0.75GHz and at 75% it idles at 1.95GHz.

If this is what the problem is, will anything be done about it? The bug I linked hasn't been touched in about 5 months, and there doesn't seem to be any indication that its being worked on...

I have, though I don't see any significant improvement until I set the minimum processor state all the way from 5% to 75%. At 100% scrolling is perfect. I'm not sure I can justify increasing it all the way to 75%, as my battery life is sure to take a noticeable hit. Just as a comparison, at 5% the CPU will idle at 0.75GHz and at 75% it idles at 1.95GHz. If this is what the problem is, will anything be done about it? The bug I linked hasn't been touched in about 5 months, and there doesn't seem to be any indication that its being worked on...
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

This could be a problem with the graphics display drivers, so make sure that you have the latest version.

This could be a problem with the graphics display drivers, so make sure that you have the latest version. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Umnikazi wombuzo

When I first got the laptop and started experiencing this issue, that's one of the first things I did. I upgraded from 344.48 to 347.88 without any improvement. I've also tried updating the iGPU Intel HD drivers.

When I first got the laptop and started experiencing this issue, that's one of the first things I did. I upgraded from 344.48 to 347.88 without any improvement. I've also tried updating the iGPU Intel HD drivers.

Umnikazi wombuzo

When I was trying different versions of Firefox to see if they all had the scrolling problem, I made sure to try 36, 38, and even 31.5 ESL portable. They all have the scrolling problem when my laptop is unplugged. However, when I tried Tor just to see what would happen - bingo! Perfectly smooth scrolling once more. This is especially weird as Tor uses 31.5.3 ESL as a base...

This made me think that it could potentially be a plugin, as Tor doesn't have any plugins installed other than Flash. However, after first disabling, then manually removing, every plugin that was listed in about:plugins the problem continues to persist.

Any idea why Tor would work flawlessly while every other version of firefox suffers the scrolling issue? I couldn't seem to remove the OpenH264 Video Codec provided by Cisco Systems, plugin. Is it possible to remove it in order to see if it is causing the problem?

When I was trying different versions of Firefox to see if they all had the scrolling problem, I made sure to try 36, 38, and even 31.5 ESL portable. They all have the scrolling problem when my laptop is unplugged. However, when I tried Tor just to see what would happen - bingo! Perfectly smooth scrolling once more. This is especially weird as Tor uses 31.5.3 ESL as a base... This made me think that it could potentially be a plugin, as Tor doesn't have any plugins installed other than Flash. However, after first disabling, then manually removing, every plugin that was listed in about:plugins the problem continues to persist. Any idea why Tor would work flawlessly while every other version of firefox suffers the scrolling issue? I couldn't seem to remove the OpenH264 Video Codec provided by Cisco Systems, plugin. Is it possible to remove it in order to see if it is causing the problem?
FredMcD
  • Top 10 Contributor
4266 izisombululo 59814 izimpendulo
Kuphostiwe

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

'''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual.

Umnikazi wombuzo

Its not in there. If I understand correctly, it's bundled with firefox...

Its not in there. If I understand correctly, it's bundled with firefox...
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

You can set this pref to false on the about:config page.

  • media.gmp-gmpopenh264.provider.enabled = false
You can set this pref to false on the <b>about:config</b> page. *media.gmp-gmpopenh264.provider.enabled = false

Umnikazi wombuzo

I wasn't able to find that exact setting, but I was able to find media.gmp-gmpopenh264.enabled. Unfortunately setting this to false had no effect.

Any other thoughts about what could be causing this? I find it very strange that Tor somehow manages not to be affected.

I wasn't able to find that exact setting, but I was able to find media.gmp-gmpopenh264.enabled. Unfortunately setting this to false had no effect. Any other thoughts about what could be causing this? I find it very strange that Tor somehow manages not to be affected.
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

You can set all plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

You can set all plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page. Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Umnikazi wombuzo

Setting all plugins to "Ask to Activate", and even manually removing them didn't help.

Just tried a completely new firefox profile, and the problem persisted.

The problem doesn't happen in safe mode, as safe mode prevents power saving profiles. For example, the issue only happens when I am on battery power because the power profile sets the minimum CPU state to 5% to save battery, meaning the speed of my processor when idle or just web browsing hovers between 0.75 GHz and 0.9 GHz. In safe mode it remains at its default clock of 2.6GHz.

Note that Tor, Chrome, and IE all operate flawlessly even when the processor is running at 0.75 GHz.

Setting all plugins to "Ask to Activate", and even manually removing them didn't help. Just tried a completely new firefox profile, and the problem persisted. The problem doesn't happen in safe mode, as safe mode prevents power saving profiles. For example, the issue only happens when I am on battery power because the power profile sets the minimum CPU state to 5% to save battery, meaning the speed of my processor when idle or just web browsing hovers between 0.75 GHz and 0.9 GHz. In safe mode it remains at its default clock of 2.6GHz. Note that Tor, Chrome, and IE all operate flawlessly even when the processor is running at 0.75 GHz.
cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration