X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Webites only show in middle of wide screen monitor

Kuphostiwe

I have a 25 inch wide HP - HD LCD monitor , since installing it , Firefox AND Google Chrome only show the page in the center of the screen all scrunched up , there is nothing on either side of the screen but the blank color of the webpage i am on (including this page) , this only happens in Firefox and Google Chrome , Internet Explorer (which i cant stand) shows the image across the screen the same way it would on a normal 19 inch monitor

I tried Full Screen , and this does not fix the issue at all , all it does is take away the address and menu bar , and the image is still in the middle of the screen all scrunched up , the attached image shows what most all web pages look like (the image shown is the page i am currently on to post my issue , as i just took a screen shot) , about the only page that looks normal is every page in Internet Explorer , every page i visit in Firefox and Google Chrome , including eBay ,Craigslist , and any forum i go to , looks like the attached image , again , this only happens in Firefox and Google Chrome , i just (last night) did a complete reformat and fresh install of Windows 7 Professional 64 bit , and SP1 , this is the same issue i had before the reformat and clean install , this is Firefox Version 36.0.1 and it says its up to date , i have tried every setting , including zoom and zoom text , with it doing nothing to spread the image across the screen as it SHOULD be

Any help would be appreciated ... Thanks ... Jim

I have a 25 inch wide HP - HD LCD monitor , since installing it , Firefox AND Google Chrome only show the page in the center of the screen all scrunched up , there is nothing on either side of the screen but the blank color of the webpage i am on (including this page) , this only happens in Firefox and Google Chrome , Internet Explorer (which i cant stand) shows the image across the screen the same way it would on a normal 19 inch monitor I tried Full Screen , and this does not fix the issue at all , all it does is take away the address and menu bar , and the image is still in the middle of the screen all scrunched up , the attached image shows what most all web pages look like (the image shown is the page i am currently on to post my issue , as i just took a screen shot) , about the only page that looks normal is every page in Internet Explorer , every page i visit in Firefox and Google Chrome , including eBay ,Craigslist , and any forum i go to , looks like the attached image , again , this only happens in Firefox and Google Chrome , i just (last night) did a complete reformat and fresh install of Windows 7 Professional 64 bit , and SP1 , this is the same issue i had before the reformat and clean install , this is Firefox Version 36.0.1 and it says its up to date , i have tried every setting , including zoom and zoom text , with it doing nothing to spread the image across the screen as it SHOULD be Any help would be appreciated ... Thanks ... Jim
Ama-screenshot ananyekiwe

Okulungisiwe ngu JimDirt

Isisombululo esikhethiwe

Well for whatever reason , i just re-installed the video drivers again after the re-format i did a few days ago , and the pages seem to be looking more normal , when i click on images they are not distorted anymore , so i have no clue as to why the drivers did nothing before , but worked this time

Anyway , so far it seems to be working like it should and i have a more or less full view

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • GEPlugin
  • Google Update

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4248 izisombululo 59425 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Your zoom controls.

<Control> + (plus) enlarge <Control> - (minus) reduce <Control> 0 (zero) restore

Your zoom controls. <Control> '''+''' (plus) enlarge <Control> '''-''' (minus) reduce <Control> '''0''' (zero) restore

Umnikazi wombuzo

As i mentioned in my first post , i have already tried ZOOM and it does not do what i want or make the page look like it should

All that does is Zoom in , which includes making the font HUGE , it does not actually S T R E T C H the page side to side which is all i want , i do not want the font HUGE , i just want what is viewed to fill the screen as it should

As i mentioned in my first post , i have already tried ZOOM and it does not do what i want or make the page look like it should All that does is Zoom in , which includes making the font HUGE , it does not actually S T R E T C H the page side to side which is all i want , i do not want the font HUGE , i just want what is viewed to fill the screen as it should

Okulungisiwe ngu JimDirt

jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi Jim, zoom should proportionally enlarge the page: text, images, and width. If it doesn't do that, check to see whether you have Firefox set to zoom only the text.

To access that setting you can tap the Alt key to activate the classic menu bar, then:

View menu > Zoom > uncheck Zoom Text Only

Hi Jim, zoom should proportionally enlarge the page: text, images, and width. If it doesn't do that, check to see whether you have Firefox set to zoom only the text. To access that setting you can tap the Alt key to activate the classic menu bar, then: View menu > Zoom > ''uncheck'' Zoom Text Only

Umnikazi wombuzo

I have the classic menu bar and do not have the Zoom Font checked , it still makes it huge , its like looking thru a magnifying glass , it does nothing to stretch the page side to side ONLY , it makes EVERYTHING larger , which i do NOT want

Like i said , as much as i can't stand IE , it does not have any issue only stretching the image side to side without making everything huge

I have the classic menu bar and do not have the Zoom Font checked , it still makes it huge , its like looking thru a magnifying glass , it does nothing to stretch the page side to side ONLY , it makes EVERYTHING larger , which i do NOT want Like i said , as much as i can't stand IE , it does not have any issue only stretching the image side to side without making everything huge

Okulungisiwe ngu JimDirt

jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Zoom really should be proportional and allow you to expand the page to use the whole width. Yes, the font gets larger when you do that, but actually there is no other built-in feature to override the width specified in web pages.

Do you have any appearance-related extensions that could be affecting the width of pages? To assess whether one of your extensions is involved, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Zoom really should be proportional and allow you to expand the page to use the whole width. Yes, the font gets larger when you do that, but actually there is no other built-in feature to override the width specified in web pages. Do you have any appearance-related extensions that could be affecting the width of pages? To assess whether one of your extensions is involved, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?
jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Wait, I think your reply changed while I was posting.

Zoom works normally for you to fill the whole space but you want a different solution that doesn't enlarge the content.

Can you give an example of a page that lays out differently in IE and Firefox, where IE uses the whole space and Firefox uses a narrow part of it at the same font size?

Wait, I think your reply changed while I was posting. Zoom works normally for you to fill the whole space but you want a different solution that doesn't enlarge the content. Can you give an example of a page that lays out differently in IE and Firefox, where IE uses the whole space and Firefox uses a narrow part of it at the same font size?
cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 157978 izimpendulo
Kuphostiwe

This website sets a maximum to the width of the content and won't fill the entire width of the Firefox window (monitor screen). If you zoom the page using full page zoom then all content gets larger, but you already wrote that you do not want this.

Pages from the MozillaZine knowledge base should fill the entire screen estate.

This website sets a maximum to the width of the content and won't fill the entire width of the Firefox window (monitor screen). If you zoom the page using full page zoom then all content gets larger, but you already wrote that you do not want this. Pages from the MozillaZine knowledge base should fill the entire screen estate. *http://kb.mozillazine.org/Profile_folder_-_Firefox

Umnikazi wombuzo

Well now IE is doing it (it was not doing it before the reformat) , now it looks the same as this page , but i have not installed IE11 , as that is what it was before the reformat , its just 8 at the moment because i do not use it , unless i am testing something

and cor-el , that page looks the same in the sense that the font is still huge , it does fill the whole view BUT , the text is huge and i can't get it any smaller , so i have to scroll forever to read thru the page and every image is huge , it looks bad , if i was almost blind it would be great or could not see small print , but i can see without the need for font the size so large that i can read it from across the room , yet i am sitting less than 1 foot from the monitor , so its a strain on the eyes

I guess my point is , why have wide screen monitors if the web browsers do not make their setup compatible with them , its not like wide screens have just arrived , they have been around for years , yet everything is scrunched into the middle , it looks like crap , and is annoying to read when all the images are distorted to be narrow and tall , doesn't anyone test their browsers on wide screen monitors ?? , if they do and they like it , then Helen Keller must be the one testing

Well now IE is doing it (it was not doing it before the reformat) , now it looks the same as this page , but i have not installed IE11 , as that is what it was before the reformat , its just 8 at the moment because i do not use it , unless i am testing something and cor-el , that page looks the same in the sense that the font is still huge , it does fill the whole view BUT , the text is huge and i can't get it any smaller , so i have to scroll forever to read thru the page and every image is huge , it looks bad , if i was almost blind it would be great or could not see small print , but i can see without the need for font the size so large that i can read it from across the room , yet i am sitting less than 1 foot from the monitor , so its a strain on the eyes I guess my point is , why have wide screen monitors if the web browsers do not make their setup compatible with them , its not like wide screens have just arrived , they have been around for years , yet everything is scrunched into the middle , it looks like crap , and is annoying to read when all the images are distorted to be narrow and tall , doesn't anyone test their browsers on wide screen monitors ?? , if they do and they like it , then Helen Keller must be the one testing

Okulungisiwe ngu JimDirt

cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 157978 izimpendulo
Kuphostiwe

You did make sure that you aren't zooming pages?

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.


You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 You can adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

You can look at this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

You did make sure that you aren't zooming pages? You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems. *Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none) Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly. ----- You can set the <b>layout.css.devPixelsPerPx</b> pref on the <b>about:config</b> page to 1.0 You can adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config Use an extension to adjust the text size in the user interface and the page zoom in the browser window. You can look at this extension to adjust the font size for the user interface. *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/

Umnikazi wombuzo

The zoom font size , and all that is what you have posted , so all my setup is as you describe , , as for the About Config and all that , do i have to do this for each page i visit , or is this a global setting so anywhere i go it will be the same ?? (referring to Theme and Fond Changer) , if this will make it easier for me to change it , i dont want to spend a week changing everything every time i go to a page , i just want to see everything open up and fill the page like it would with a 19" monitor without the huge font and distorted images (this part i don't understand how this was acceptable , not one image looks normal , they are all scrunched up and distorted)

The zoom font size , and all that is what you have posted , so all my setup is as you describe , , as for the About Config and all that , do i have to do this for each page i visit , or is this a global setting so anywhere i go it will be the same ?? (referring to Theme and Fond Changer) , if this will make it easier for me to change it , i dont want to spend a week changing everything every time i go to a page , i just want to see everything open up and fill the page like it would with a 19" monitor without the huge font and distorted images (this part i don't understand how this was acceptable , not one image looks normal , they are all scrunched up and distorted)
jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Web developers believe that keeping the width of columns of text modest gives the best readability (e.g., http://baymard.com/blog/line-length-readability). But such advice is based on averages and isn't going to be true for everyone.

If the images are distorting, then Firefox may have having problems handling your display properly. Is it one of the newer "higher than HD" displays?

Web developers believe that keeping the width of columns of text modest gives the best readability (e.g., [http://baymard.com/blog/line-length-readability]). But such advice is based on averages and isn't going to be true for everyone. If the images are distorting, then Firefox may have having problems handling your display properly. Is it one of the newer "higher than HD" displays?

Umnikazi wombuzo

This is the monitor i have http://support.hp.com/us-en/product/HP-Value-25-inch-Displays/7274920/model/3999543/document/c01869172/

Okulungisiwe ngu JimDirt

jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Full HD monitor; Firefox should be able to handle that.

I am attaching two screen shots of that product page, one at my default zoom level and one where I've Ctrl+ enough time to eliminate the left margin. Does the monitor image on yours look similar or distorted?

Full HD monitor; Firefox should be able to handle that. I am attaching two screen shots of that product page, one at my default zoom level and one where I've Ctrl+ enough time to eliminate the left margin. Does the monitor image on yours look similar or distorted?

Umnikazi wombuzo

Neither of those look distorted , and both cover the entire screen (as it normally should look , in mine that would be taller and shorter/narrower , in other words , scrunched like in my post with the image attached) , with the exception of the 2nd one being zoomed in , but its not distorted , its just larger , but the font is also not oversize , so both to me are better than what i see on mine , so what does that mean ??

Neither of those look distorted , and both cover the entire screen (as it normally should look , in mine that would be taller and shorter/narrower , in other words , scrunched like in my post with the image attached) , with the exception of the 2nd one being zoomed in , but its not distorted , its just larger , but the font is also not oversize , so both to me are better than what i see on mine , so what does that mean ??

Okulungisiwe ngu JimDirt

jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Hi Jim, since the problem occurs in both Firefox and IE, this could be a Windows thing, but there is one other Firefox setting that comes to mind. Have you customized Firefox's font settings at all? In particular, setting a large "minimum" font size can cause pages to zoom in a distorted manner. If that's the problem, you can unset it in the Options dialog here:

"3-bar" menu button (or Tools menu) > Options > Content > "Advanced" button

There is a button at the top which usually says "Latin" or "Other Writing Systems". These two categories cover most pages.

If the number next to Minimum font size is higher than 9, please reduce it to 9 or None.

Then use the button at the top to view/edit the other main category. And then finally OK out of the dialogs.

Actually, cor-el already mentioned this, so you might have checked this already.

Hi Jim, since the problem occurs in both Firefox and IE, this could be a Windows thing, but there is one other Firefox setting that comes to mind. Have you customized Firefox's font settings at all? In particular, setting a large "minimum" font size can cause pages to zoom in a distorted manner. If that's the problem, you can unset it in the Options dialog here: "3-bar" menu button (or Tools menu) > Options > Content > "Advanced" button There is a button at the top which usually says "Latin" or "Other Writing Systems". These two categories cover most pages. If the number next to Minimum font size is higher than 9, please reduce it to 9 or None. Then use the button at the top to view/edit the other main category. And then finally OK out of the dialogs. ''Actually, cor-el already mentioned this, so you might have checked this already.''

Umnikazi wombuzo

Yes i have already checked that

Now with the images you posted show the page as all the way across the screen not crammed into the center , so what "settings" do you have (and is yours a larger monitor like mine ?) , and how would i set mine to this view ??

Yes i have already checked that Now with the images you posted show the page as all the way across the screen not crammed into the center , so what "settings" do you have (and is yours a larger monitor like mine ?) , and how would i set mine to this view ??
jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Hi Jim, I've been using Firefox for years so it occurred to me maybe I have a special setting or add-on influencing this. I created a new Firefox profile and grabbed the same screen shots. So I think the zoom behavior I see on the screen (a different model 25" Full HD monitor by HP) is "normal".

If you want to try the new profile test, which takes a few minutes, here's how:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. (You can import your bookmarks to it later.)

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Please don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like March2015, and skip the option to relocate the profile folder. Then start Firefox in the new profile you created.

Does it zoom normally?

Firefox will keep using this new profile until you switch. When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Hi Jim, I've been using Firefox for years so it occurred to me maybe I have a special setting or add-on influencing this. I created a new Firefox profile and grabbed the same screen shots. So I think the zoom behavior I see on the screen (a different model 25" Full HD monitor by HP) is "normal". If you want to try the new profile test, which takes a few minutes, here's how: '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. (You can import your bookmarks to it later.) Exit Firefox and start up in the Profile Manager using Start > search box (or Run): firefox.exe -P ''Please don't delete anything here.'' Any time you want to switch profiles, exit Firefox and return to this dialog. Click the Create Profile button, assign a name like March2015, and skip the option to relocate the profile folder. Then start Firefox in the new profile you created. Does it zoom normally? Firefox will keep using this new profile until you switch. When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Umnikazi wombuzo

Its slightly better , i did not zoom in , but its still in the middle , and images are still scrunched , so the image is distorted , say your looking at a motorcycle on Craigslist , you click on the add , and the image is there , well the bike (a dirt bike in this case) looks like its squeezed front to back so its like someone took a bike and squeezed it and it got shorter and taller (make sense ?) , this is how the images still look as well as everything (like this page as well as any other i go to) are still centered , but at least the text is not huge , but the image is still the same

So it helped but did not make anything full screen like it looks in your images

Its slightly better , i did not zoom in , but its still in the middle , and images are still scrunched , so the image is distorted , say your looking at a motorcycle on Craigslist , you click on the add , and the image is there , well the bike (a dirt bike in this case) looks like its squeezed front to back so its like someone took a bike and squeezed it and it got shorter and taller (make sense ?) , this is how the images still look as well as everything (like this page as well as any other i go to) are still centered , but at least the text is not huge , but the image is still the same So it helped but did not make anything full screen like it looks in your images

Isisombululo Esikhethiwe

Well for whatever reason , i just re-installed the video drivers again after the re-format i did a few days ago , and the pages seem to be looking more normal , when i click on images they are not distorted anymore , so i have no clue as to why the drivers did nothing before , but worked this time

Anyway , so far it seems to be working like it should and i have a more or less full view

Well for whatever reason , i just re-installed the video drivers again after the re-format i did a few days ago , and the pages seem to be looking more normal , when i click on images they are not distorted anymore , so i have no clue as to why the drivers did nothing before , but worked this time Anyway , so far it seems to be working like it should and i have a more or less full view
jscher2000
  • Top 10 Contributor
8699 izisombululo 71098 izimpendulo
Kuphostiwe

Thanks for reporting back. Your description from Friday sounds like a nonstandard resolution, but the fact that it only affect a couple applications was a complete mystery. So I'm glad you were able to solve it without me!

Thanks for reporting back. Your description from Friday sounds like a nonstandard resolution, but the fact that it only affect a couple applications was a complete mystery. So I'm glad you were able to solve it without me!