Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After updating, Firefox hangs and doesn't respond upon opening.

  • 4 uphendule
  • 2 zinale nkinga
  • 28 views
  • Igcine ukuphendulwa ngu FredMcD

more options

After updating Firefox in the most recent update it hangs upon opening. I would try the other fixes for hanging but Firefox is unresponsive and I can't access anything within it to fix it.

All Replies (4)

more options

Have you updated to v31.01?

Download Firefox Full Installer For All languages And Systems {web link}


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Tried re-downloading to make sure I have v31.01 and starting in safe mode but no luck. Still not responding.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Forgot to add;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}