X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why does Firefox 36.0 make UDP call outs to 239.255.255.250, port 1900?

Kuphostiwe

I just updated my copy of Firefox to version 36.0 on my XP SP3 computer. As soon as the program starts, my firewall alerts me the Firefox is making an outgoing UDP call to 239.255.255.250, port 1900. I deny it and it immediately pops up again. The second time I deny it, it stops for a while and then after about a minute or so, it repeats the process. I made a rule to block the calls. Does anybody know what's going on here? According to my research, 239.255.255.250, port 1900 is the IPv4 multicast address implemented through Universal Plug and Play. Why would Firefox now need to be calling that local address? Is there something I can disable in Options to stop Firefox from making those calls? I try to minimize the number of rules my firewall has to use whenever possible.

I just updated my copy of Firefox to version 36.0 on my XP SP3 computer. As soon as the program starts, my firewall alerts me the Firefox is making an outgoing UDP call to 239.255.255.250, port 1900. I deny it and it immediately pops up again. The second time I deny it, it stops for a while and then after about a minute or so, it repeats the process. I made a rule to block the calls. Does anybody know what's going on here? According to my research, 239.255.255.250, port 1900 is the IPv4 multicast address implemented through Universal Plug and Play. Why would Firefox now need to be calling that local address? Is there something I can disable in Options to stop Firefox from making those calls? I try to minimize the number of rules my firewall has to use whenever possible.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • PDF-XChange Viewer Netscape Gecko Plugin
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0

Eminye Imininingwane

philipp
  • Top 25 Contributor
  • Moderator
5306 izisombululo 23423 izimpendulo
Kuphostiwe

hello JohnCorliss, this is the feature in firefox 36 causing the pings: https://bugzilla.mozilla.org/show_bug.cgi?id=1054959

hello JohnCorliss, this is the feature in firefox 36 causing the pings: https://bugzilla.mozilla.org/show_bug.cgi?id=1054959

Umnikazi wombuzo

Thanks, but most of that is way over my head. I'm not a programmer, just a simple end user. I really want to disable this feature so that there are no more calls to UPnP and would like to know how I can go into about:config and make a change to do so, if that's possible. UPnP is something most people with any common sense have disabled due to security vulnerabilities anyway.

Thanks, but most of that is way over my head. I'm not a programmer, just a simple end user. I really want to disable this feature so that there are no more calls to UPnP and would like to know how I can go into about:config and make a change to do so, if that's possible. UPnP is something most people with any common sense have disabled due to security vulnerabilities anyway.
the-edmeister
  • Top 25 Contributor
  • Moderator
5398 izisombululo 40146 izimpendulo
Kuphostiwe

Just a wild-assed guess after reading the attachment linked in comment 55 in that Bug report, see if disabling device.sensors.enabled works to disable that "feature".

Type about:config in the URL bar and hit Enter.

Put device in the Search field at the top. Then right-click that preference and select Toggle. When you're done restart Firefox and see if that change stops those UDP callouts.

Just a wild-assed guess after reading the attachment linked in comment 55 in that Bug report, see if disabling '''device.sensors.enabled''' works to disable that "feature". Type '''about:config''' in the URL bar and hit Enter. Put '''device''' in the Search field at the top. Then right-click that preference and select '''Toggle'''. When you're done restart Firefox and see if that change stops those UDP callouts.

Umnikazi wombuzo

To the-edmeister, I tried that about:config setting like you said, removed the rule from my firewall and then restarted Firefox. Firefox kept making the UDP calls, so I re-implemented the firewall rule and toggled the about:config setting back to "True". Thanks, but it didn't work.

To the-edmeister, I tried that about:config setting like you said, removed the rule from my firewall and then restarted Firefox. Firefox kept making the UDP calls, so I re-implemented the firewall rule and toggled the about:config setting back to "True". Thanks, but it didn't work.
the-edmeister
  • Top 25 Contributor
  • Moderator
5398 izisombululo 40146 izimpendulo
Kuphostiwe

There's a thread over here - http://forums.mozillazine.org/viewtopic.php?p=14040227#p14040227 - which mentions this Bug.

https://bugzilla.mozilla.org/show_bug.cgi?id=1111967 - Add an option to disable SSDP in Firefox

There's a thread over here - http://forums.mozillazine.org/viewtopic.php?p=14040227#p14040227 - which mentions this Bug. https://bugzilla.mozilla.org/show_bug.cgi?id=1111967 - Add an option to disable SSDP in Firefox

Umnikazi wombuzo

To the-edmeister: Well, it's good to know what's going on and thank you for the links. In my opinion, this kind of thing is a perfect example of unnecessary bloat. I sure hope that the option to disable it gets implemented.

To the-edmeister: Well, it's good to know what's going on and thank you for the links. In my opinion, this kind of thing is a perfect example of unnecessary bloat. I sure hope that the option to disable it gets implemented.

Okulungisiwe ngu JohnCorliss

the-edmeister
  • Top 25 Contributor
  • Moderator
5398 izisombululo 40146 izimpendulo
Kuphostiwe

JohnCorliss,

I'm not a programmer either - fixed cars for a living (my own business) until I retired (early) about 20 years ago. But I have been "messing with" PC's since 1984 (IBM-XT) (for my business) and worked on aircraft electronics in the service 1967-1973. So I'm more of a "hardware guy", than a "software guy" and I am struggling to get a grasp on this.

Please vote for this Bug. (Register for Bugzilla if you don't already have an account there.) IMO, the user should have a method of disabling a "feature" like that if they don't use it. https://bugzilla.mozilla.org/show_bug.cgi?id=1111967


One thing I am curious about is if the loop.enabled pref in about:config is disabled, will those UDP calls stop?

I'm really "grasping at straws" here to try to figure this out. Sorry 'bout that.

JohnCorliss, I'm not a programmer either - fixed cars for a living ''(my own business)'' until I retired ''(early)'' about 20 years ago. But I have been "messing with" PC's since 1984 (IBM-XT) ''(for my business)'' and worked on aircraft electronics in the service 1967-1973. So I'm more of a "hardware guy", than a "software guy" and I am struggling to get a grasp on this. Please vote for this Bug. ''(Register for Bugzilla if you don't already have an account there.)'' IMO, the user should have a method of disabling a "feature" like that if they don't use it. https://bugzilla.mozilla.org/show_bug.cgi?id=1111967 ---------------------- One thing I am curious about is if the '''loop.enabled''' pref in '''about:config''' is disabled, will those UDP calls stop? ''I'm really "grasping at straws" here to try to figure this out. Sorry 'bout that.''

Umnikazi wombuzo

Well, I entered my "vote". Made a remark, hope that's what you mean by "vote".

As for whether or not your pref mod would work, I would say that it won't because apparently at some point in the past (before updating to FF 36), I set it to false and the UDP calls still occurred.

Well, I entered my "vote". Made a remark, hope that's what you mean by "vote". As for whether or not your pref mod would work, I would say that it won't because apparently at some point in the past (before updating to FF 36), I set it to false and the UDP calls still occurred.
cor-el
  • Top 10 Contributor
  • Moderator
17470 izisombululo 157903 izimpendulo
Kuphostiwe

Impendulo Ewusizo

No, that is not what is meant with voting for a bug. If you comment in a bug then you generate a lot of emails that is send to developers and is considered as bug spam. So Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html You can vote for a bug to show your interest, see:

No, that is not what is meant with voting for a bug. If you comment in a bug then you generate a lot of emails that is send to developers and is considered as bug spam. So Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html You can vote for a bug to show your interest, see: *https://bugzilla.mozilla.org/page.cgi?id=voting.html

Umnikazi wombuzo

cor-el, thanks for pointing that out. I placed my vote.

Daniel Veditz remarked in the bug comments: "New features should have come with a disabling pref, _especially_ new features that implement new network protocols."

I agree, but in an "at least" kind of way.

cor-el, thanks for pointing that out. I placed my vote. Daniel Veditz remarked in the bug comments: "New features should have come with a disabling pref, _especially_ new features that implement new network protocols." I agree, but in an "at least" kind of way.
Heleneb 0 izisombululo 2 izimpendulo
Kuphostiwe

JohnCorliss said

I just updated my copy of Firefox to version 36.0 on my XP SP3 computer. As soon as the program starts, my firewall alerts me the Firefox is making an outgoing UDP call to 239.255.255.250, port 1900. I deny it and it immediately pops up again. The second time I deny it, it stops for a while and then after about a minute or so, it repeats the process. I made a rule to block the calls. Does anybody know what's going on here? According to my research, 239.255.255.250, port 1900 is the IPv4 multicast address implemented through Universal Plug and Play. Why would Firefox now need to be calling that local address? Is there something I can disable in Options to stop Firefox from making those calls? I try to minimize the number of rules my firewall has to use whenever possible.

JohnCorliss said

I just updated my copy of Firefox to version 36.0 on my XP SP3 computer. As soon as the program starts, my firewall alerts me the Firefox is making an outgoing UDP call to 239.255.255.250, port 1900. I deny it and it immediately pops up again. The second time I deny it, it stops for a while and then after about a minute or so, it repeats the process. I made a rule to block the calls. Does anybody know what's going on here? According to my research, 239.255.255.250, port 1900 is the IPv4 multicast address implemented through Universal Plug and Play. Why would Firefox now need to be calling that local address? Is there something I can disable in Options to stop Firefox from making those calls? I try to minimize the number of rules my firewall has to use whenever possible.
''JohnCorliss [[#question-1048572|said]]'' <blockquote> I just updated my copy of Firefox to version 36.0 on my XP SP3 computer. As soon as the program starts, my firewall alerts me the Firefox is making an outgoing UDP call to 239.255.255.250, port 1900. I deny it and it immediately pops up again. The second time I deny it, it stops for a while and then after about a minute or so, it repeats the process. I made a rule to block the calls. Does anybody know what's going on here? According to my research, 239.255.255.250, port 1900 is the IPv4 multicast address implemented through Universal Plug and Play. Why would Firefox now need to be calling that local address? Is there something I can disable in Options to stop Firefox from making those calls? I try to minimize the number of rules my firewall has to use whenever possible. </blockquote> ''JohnCorliss [[#question-1048572|said]]'' <blockquote> I just updated my copy of Firefox to version 36.0 on my XP SP3 computer. As soon as the program starts, my firewall alerts me the Firefox is making an outgoing UDP call to 239.255.255.250, port 1900. I deny it and it immediately pops up again. The second time I deny it, it stops for a while and then after about a minute or so, it repeats the process. I made a rule to block the calls. Does anybody know what's going on here? According to my research, 239.255.255.250, port 1900 is the IPv4 multicast address implemented through Universal Plug and Play. Why would Firefox now need to be calling that local address? Is there something I can disable in Options to stop Firefox from making those calls? I try to minimize the number of rules my firewall has to use whenever possible. </blockquote>
Heleneb 0 izisombululo 2 izimpendulo
Kuphostiwe

I am having the same problem with 239.255.255.250. Worried that this may be a virus, etc.

I am having the same problem with 239.255.255.250. Worried that this may be a virus, etc.

Umnikazi wombuzo

Heleneb said

I am having the same problem with 239.255.255.250. Worried that this may be a virus, etc.

Heleneb, I recommend that you read this entire discussion if you haven't already. It's not a virus, is something which was just programmed into Firefox with version 36.

''Heleneb [[#answer-701761|said]]'' <blockquote> I am having the same problem with 239.255.255.250. Worried that this may be a virus, etc. </blockquote> Heleneb, I recommend that you read this entire discussion if you haven't already. It's not a virus, is something which was just programmed into Firefox with version 36.

Umnikazi wombuzo

I'm now using Firefox version 36.0.4 and the problem is STILL occurring! The bug (https://bugzilla.mozilla.org/show_bug.cgi?id=1111967) is still there. Firefox is still making frequent and unnecessary UDP calls to UPnP even though I have that service disabled and (like the majority of people) don't own a Roku. And I just noticed that somebody mentioned that the callouts check for a Chromecast also. And now we know why this is happening. Mozilla knows what side of their bread is buttered (STILL mostly funded by Google) and the master has ordered them to do this. How annoying!

I'm now using Firefox version 36.0.4 and the problem is STILL occurring! The bug (https://bugzilla.mozilla.org/show_bug.cgi?id=1111967) is still there. Firefox is still making frequent and unnecessary UDP calls to UPnP even though I have that service disabled and (like the majority of people) don't own a Roku. And I just noticed that somebody mentioned that the callouts check for a Chromecast also. And now we know why this is happening. Mozilla knows what side of their bread is buttered (STILL mostly funded by Google) and the master has ordered them to do this. How annoying!
the-edmeister
  • Top 25 Contributor
  • Moderator
5398 izisombululo 40146 izimpendulo
Kuphostiwe

That Bug report says it is "fixed" in Firefox 37, scheduled to be released on 03-31 .

That Bug report says it is "fixed" in Firefox 37, scheduled to be released on 03-31 .
philipp
  • Top 25 Contributor
  • Moderator
5306 izisombululo 23423 izimpendulo
Kuphostiwe

hello, if you go through the bug report you will see that this issue is going to be fixed in firefox 37 - mozilla is not (no longer) funded by google at all btw...

hello, if you go through the bug report you will see that this issue is going to be fixed in firefox 37 - mozilla is not (no longer) funded by google at all btw...
James
  • Moderator
1595 izisombululo 11242 izimpendulo
Kuphostiwe

JohnCorliss said

And now we know why this is happening. Mozilla knows what side of their bread is buttered (STILL mostly funded by Google) and the master has ordered them to do this. How annoying!

https://blog.mozilla.org/press/2014/11/yahoo-and-mozilla-form-strategic-partnership/ https://blog.mozilla.org/blog/2014/11/19/promoting-choice-and-innovation-on-the-web/

Even still Mozilla were not doing things because Google was paying to be default search engine for most of Firefox's existence then. (Browser has existed since Sept 2002)

''JohnCorliss [[#answer-707463|said]]'' <blockquote>And now we know why this is happening. Mozilla knows what side of their bread is buttered (STILL mostly funded by Google) and the master has ordered them to do this. How annoying! </blockquote> https://blog.mozilla.org/press/2014/11/yahoo-and-mozilla-form-strategic-partnership/ https://blog.mozilla.org/blog/2014/11/19/promoting-choice-and-innovation-on-the-web/ Even still Mozilla were not doing things because Google was paying to be default search engine for most of Firefox's existence then. (Browser has existed since Sept 2002)

Impendulo Ewusizo

I looked around and sure enough, Google has dropped out of the Mozilla funding picture. Either Google or Mozilla decided not to renew the option starting with 2015.

As for the UDP calling out to UPnP, also see this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1142521

I'm going to wait and see if version 37 fixes this issue. If it doesn't, along with the horrible Australis interface and FF starting wmiprvse.exe every time it runs, it's enough for me to start looking around for another browser.

I looked around and sure enough, Google has dropped out of the Mozilla funding picture. Either Google or Mozilla decided not to renew the option starting with 2015. As for the UDP calling out to UPnP, also see this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1142521 I'm going to wait and see if version 37 fixes this issue. If it doesn't, along with the horrible Australis interface and FF starting wmiprvse.exe every time it runs, it's enough for me to start looking around for another browser.