Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Several small clusters of white pixels overlay Firefox windows (not seen in other apps so far), just in last few days - why, and how to fix?

  • 15 uphendule
  • 1 inale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Problem noticed since last week: boxy areas of pixels less than 1" sq flicker rapidly or stay white in Firefox windows, in a horizontal row maybe 7 inches from top of the window, generally maintaining the same pattern. At first I thought my monitor was going bad, but (a) the clusters do not appear so far in any other application and (b) they move exactly in synch with the Firefox window, on either my laptop screen or the attached second monitor. (Hmm - as I write this I notice a couple of other patches flickering at the top of the Firefox window, over the leftmost tab; the lower problem areas now appear stable.)

They occur - so far as I can tell, which is difficult unless the window is mostly dark - during internet actions such as requesting or receiving a new page, sometimes just with mouse motion, or sometimes with no activity on my part, generally lasting only a second or so but soon recurring.

The attached screen capture ("Screen shot 2015-02-23 at 4.59.05 PM.png") shows 4 examples of this - to the left of the "Christ at Emmaus" caption, obscuring most of the "Ephraim Bonus..." thumbnail, a lighter area just a bit to the right of that thumbnail, and part of an even lighter specimen at the edge of the Firefox window. (So far the "uploaded images" box displays only a rotating work-in-progress circle, so I can't tell if that image will upload along with this message... this may be because I had the image open in Preview at the time I clicked the upload button, but I see no way to abort and restart the process.)

All Replies (15)

more options

You need to post the full address for the picture. Or;

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

Here's my 2nd attempt at uploading the screen capture:

more options

I need a better view. Please post the web address.

more options

I don't understand your request. The "web address" of the site I was browsing shows up in the screen capture: http://www.rembrandtonline.org/Diana-and-her-Nymphs-Bathing,-with-Actaeon-and-Callisto.html

The screen capture itself is not on the web except at this site. When I clicked it just now, the patches of "snow" seemed quite visible.

I returned to the rembrandtonline.org page just now to check that URL, and took another screen shot ("Screen shot excerpt 2015-02-24.png" - attached, I hope; parts cut out to remove private information) showing added patches of white pixels. Oddly enough, now the effect does not show up on that or a couple of other pages I just browsed.

more options

I saw your picture, but wanted to look at the page to check a few things.

Hmmm Nice paintings.

Look at my pic below. Compare it to your first pic above. Notice that there are no dots. It could be something about your system, or one of my add blockers.


Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox.

Now open that web page. Is the problem still there?

more options

The problem has not recurred in Safe Mode, though I've only just restarted and revisited that page. But as noted above, the snow evaporated the last time I looked, before the S Mode restart.

But I still doubt I've communicated this clearly: the problem occurred at multiple sites, not just rembrandtonline.org. I picked that as an example because it had mostly-dark content and margins, so the effect was most visible.

Mostly I go to text pages, so I can't say when I figured out that I was seeing a display problem of a scattering of white pixels over words I was mostly skimming: sending one of those as an example would have caused frustration all around. Once I ruled out LED problems and saw the problem happened only in Firefox, I brought the question here.

My current hypothesis points the finger at NoScript or another add-on blocking ~99% of a pop-up, and exposure to that pop-up ceasing just as I took the most recent screen cap.

more options

If they were triggered, the whole thing would have been blocked.

Check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

The flashing pixels came back - like a vertical column of 4 snowflakes, a bit less than an inch in total, on the outer edge of the blue handle in the scroll bar, pulsing at about the same rate as the insertion line in this message box. But my screen capture missed them, and now they've stopped again.

Software Update mentions nothing about graphics drivers (and hasn't for a long time).

I have Flash 16.0 for Mac - do the warnings about a much earlier version for Windows apply?

My Tools menu does not include an "Options" option. I found a "Use hardware acceleration" box in Preferences: Advanced, and turned it off. Will restart Firefox after posting this msg.

more options

Nearly 24 hours later, and the flickering has not recurred yet.

I can't be sure, but possibly the hardware acceleration did generate the display problem.

more options

From Mozilla help files;

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

more options

Note that such issues can be caused by overheating components on the graphics display card, so maybe use a utility to monitor that temperature.

more options

I once had an issue with overheating. It turned out the vents were clogged.

more options

I've downloaded a utility called "Temperature Monitor", and plan to install it and do some tests (mostly with turning graphics hardware acceleration on and off).

The only time I've previously had a problem with overheating came when I put a laptop on a blanket. Since then, I not only make sure it rests on a flat hard surface, I tuck a pen or something under at least one side to make sure the bottom has plenty of air circulation.

Thanks to all for so much clear and friendly help!

more options

Go to a store and buy one of those cans of compressed air. Place the nozzle in the vents and flush then well. Be careful as the air, and the can, will become VERY COLD ! !