Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable the outdated plugin nag bar

  • 7 uphendule
  • 3 zinale nkinga
  • 28 views
  • Igcine ukuphendulwa ngu cor-el

more options

I have Flashblock already installed to prevent malicious Flash. Firefox still insists that I manually Allow flash on every website I visit - this is really annoying. I found a flag that disables the nag bar in about:config (extensions.blocklist.enabled). It took weeks to find - what a pain in the... neck.

Also there is a control in the Add-on for the Flash plugin that appears to be redundant (Always Activate) as it is ignored. Currently Flash handling is a mess. Could you put all the controls in one place and no special handling with obscure flags?

OK so while I'm here ;) ... what's with no "Ask to Activate" for the IcedTea plugin? Isn't Java the No. 1 attack vector?? It makes a mockery of all the hoo-haa about Flash.

All Replies (7)

more options

Security Issue: Update your Flash Player v16.0.0.305
https://www.adobe.com/products/flashplayer/distribution3.html


There are two separate settings for the plugins. The first is thru the Add-ons Manager. The second is in the Permissions Manager.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

more options

I believe Adobe stopped supporting the ancient Flash 11.2 on Windows when they released 11.3 back in June 2012 so your version is rather vulnerable now.

Besides the 16.0.0.305 there is the Flash Player 13.0.0.269 Extended Support Release.

Okulungisiwe ngu James

more options

2460acc said

I have Flashblock already installed to prevent malicious Flash. Firefox still insists that I manually Allow flash on every website I visit - this is really annoying. I found a flag that disables the nag bar in about:config (extensions.blocklist.enabled). It took weeks to find - what a pain in the... neck. Also there is a control in the Add-on for the Flash plugin that appears to be redundant (Always Activate) as it is ignored. Currently Flash handling is a mess. Could you put all the controls in one place and no special handling with obscure flags? OK so while I'm here ;) ... what's with no "Ask to Activate" for the IcedTea plugin? Isn't Java the No. 1 attack vector?? It makes a mockery of all the hoo-haa about Flash.
more options

1. There is no "Ask to Activate" in my version of Firefox. There used to be but I haven't kept track of every change in FF. It is not there in my version of FF.

2. Adobe doesn't have a more recent Flash for Linux so it's pointless recommending upgrade.

3. FlashBlock addon is a perfect solution. I don't need any of Firefox's extra Flash handling so it is frustrating to have to dig deep to find extensions.blocklist.enabled in about:config.

4. Iced Tea plugin is either Always Active or Never Activate. Where is the Ask to Activate option? Trying to play pogo games is impossible on Firefox - try it and see, e.g. try to play pogo bridge or pogo scrabble. Every turn is blocked or gives an error. Sadly I have to install Chrome for my relatives so they can access their pogo accounts.

more options

2460acc said

1. There is no "Ask to Activate" in my version of Firefox
The selections should be; Always / Ask / Disable

2. Adobe doesn't have a more recent Flash for Linux

Your System Details says Windows 8.1 Which is correct?
more options

2460acc said

2. Adobe doesn't have a more recent Flash for Linux so it's pointless recommending upgrade.

Your useragent says you are using Windows 8.1 and not Linux as is this a fake UA in your system details on right of OP then?. User Agent: Mozilla/5.0 (Windows NT 6.3; rv:36.0) Gecko/20100101 Firefox/36.0

Though one could think you were really using Linux due to mention of the Iced Tea Plugin.

As for Flash on Linux, Adobe still supports Flash player 11.2 as they had a recent update 11.2.202.442 on Feb 4/5.

https://www.adobe.com/products/flashplayer/distribution3.html

https://helpx.adobe.com/security/products/flash-player/apsb15-04.html

https://addons.mozilla.org/en-us/firefox/blocked/ 11.2.202.441 and older is block for good reasons as in critical exploits.

more options

What is the value of the plugins.click_to_play pref?

If you do not have the "Ask To Activate" choice for plugin on the "Firefox > Add-ons Plugins" page then you can set the plugins.click_to_play pref to true on the about:config page.