Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox running slow to load Google.com home page

  • 3 uphendule
  • 78 zinale nkinga
  • 299 views
  • Igcine ukuphendulwa ngu johnnylange

more options

I'm running Firefox 35.0.1 on Windows 8.1 and when I start it up it takes a while to load my home page, Google.com. I've set the home page link to just google.com and with the default extensions it adds when the page loads.

I've changed the home page to github to see if that loads faster and it does. Also, I've checked google.com on Chrome just to make sure it wasn't Google's server. Other sites are running fine and Google will load quickly if I hit the home page after going to another site. I disabled extensions just to see it that was causing the issue as well.

Isisombululo esikhethiwe

Firefox seems to be back to normal. I restarted my computer after another program wasn't responding and that seems to fixed both. Whew!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (3)

more options

Hello there,

This may be caused by the large amount of visited sites and as a result this can slow down Firefox

Can you please try to clean your browsing history and cookies by doing the following:

1. Click the menu button, choose "History", and then "Clear Recent History" 2. Select how much history you want to clear ( Everything is recommended) 3. Finally, click the "Clear Now" button.

If none of the above work then I would suggest to reinstall Firefox and see if that solves the issue.

Keep us posted!

more options

Hi Machine Master,

I cleared all the history, then tried it again, but that didn't fix things. So I did a re-install and it's still lagging. Seems to happen when heading to mozilla.org too.

more options

Isisombululo Esikhethiwe

Firefox seems to be back to normal. I restarted my computer after another program wasn't responding and that seems to fixed both. Whew!