Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

trying to sign in on one web site, I get this message: Cancel OpenID

  • 12 uphendule
  • 1 inale nkinga
  • 38 views
  • Igcine ukuphendulwa ngu John99

more options

The web site is for my electric bill. I have to open Safari, and sign in from there. The message I get using Fireox when I put in my user name and password is: Cancel OpenID. The web site is EPB.NET, and they have checked everything on their end and have no suggestions other than it's a browser incompatibility.

Yes, I've deleted cookies, history, cache and such. Yes, I've disabled all extensions.

It has been a problem for months.

Should I just make Safari my default browser?

Thanks for any effective help!

All Replies (12)

more options

Are you able to sign in by manually entering your user name and password at https://epb.com/login ?

I note you have an extension apparently

  1. OpenID Login 0.3
    from https://addons.mozilla.org/firefox/addon/openid-login/
    Have you tried disabling that or if necessary uninstalling it ?
  2. Also try in Firefox's safemode
more options

Thanks for the response.

I am not able to sign in by manually entring my user name and password. The link to do that is: https://www.epb.net/sign-in/

I acquired the extension OpenID Login 0.3 in an effort to solve this problem. It did not solve it, and I subsequently disabled it.

I will try safe mode and see what happens. BTW, you say hold the shift key while starting Firefox, while Mozilla says "... start Firefox in Safe Mode by holding down the option key while starting Firefox." Going to try the option key first. I will report back with results.

more options

The problem is still present in safe mode, whether autofill is enabled or I manually type in my user name and password. BTW, the option key enabled me to start in safe mode.

more options

Try to clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

If you have extensions that deal with cookies then temporarily disable them as a test.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Cor-el, I have cleared the cache ( I clear it daily), removed all cookies (that makes a lot of work for me in the following days), and ALL my extensions are disabled. The appearance is Default 36.0, as it always is, and I did NOT click the Reset button on the Safe Mode start window. Problem still present.

more options

Sorry I forgot it was a Mac, that uses Option to start SafeMode.

Are you able to attach a screen shot of this message. (But take care not to include personal information)

more options

Screen shot of the error message:

more options

That is an error report apparently generated from their server.

Please try Firefox's safemode and clearing cache & cookies. This time please ensure you have no tabs open from your utility company when you clear the cache and the site cookies.

Also try to use the link I posted https://epb.com/login

There is a possibility if you use a bookmarked link that the link could itself be passing information that is outdated and part of the problem.

more options

Mexican standoff. Cleared cache and site cookies with no windows/tabs open (that's the way I always do it). Tried your link, which sent me to my link, which resulted in the same problem after entering user name and password. Tried typing in epb.com in the address bar, which sent me to their home page. Clicked on the "my account" button, which sent me to the sign in page. Entered my user name and password and hit the go button, ending up with the same error message. I appreciate you hanging with me on this.

more options

I can see the site uses https://epb.com/openid/server and if I attempt to sign in with arbitrary invalid information such as user me and password test I get as expected a simple red text error message saying Invalid username or password. Please try again.

Just out of curiosity what happens if you use the incorrect information when trying to login ? Do you get a similar message to me ? Presumably you have tried manually inputting the username and pasword, rather than relying on anything Firefox may have saved for you.

Have you any security related software that may be interfering with this ?

Luckily you do mention an alternative browser does work.

I am running out of ideas here, but no doubt cor-el will come up with further suggestions.

more options

So, I have one more final question: can I go back to v.35.0 and get out of the beta loop and all the daily (almost) updates? If I download 35.0, then trash all the components of the present version, will I have to start all over again with bookmarks and such?

more options

You can go back to the release, but need to consider the different options.

You may either run both versions, but they will need separate profiles. Or you may downgrade to the Release version. It would be relatively easy to copy bookmarks etc Whatever you do it is worth backing up the current profile first.

You will want to try to use at least some of those files. Put them somewhere safe outside Firefox profile or program paths. Your Desktop or My Documents would do.

Also if you only want to retain bookmarks the easiest method without messing with profile files is to use the backup option before you change over.


If you have both versions running with separate profiles it does have the advantage that you can take your time in migrating profile files. Here is the info on running multiple versions and profiles

Incidentally the Firefox version & channel previously known as Aurora and now know as Developer Edition now installs by default as an additional version and installs with its own separate profiles.


You could simply try installing Firefox 35.x over Firefox beta. It will probably work. But issues could occur with the profile. More generally problems will occasionally also occur with program files when downgrading.

It would be best to do a clean install (explained in article linked above) removing the program files; and also renaming the profile folder. After installing overwrite only some of the files such as places.sqlite