X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 35.0 not playing flash when set to activate

Kuphostiwe

Since upgrade Firefox to 35.0, some sites like plus.google.com and http://player.radio.com/listen/station/995-wycd/ will not give me the Allow to run "Adobe Flash"? at the top of the browser. Therefore cannot run Flash on thes sites. If I set to Flash to Always Active it will run.

Since upgrade Firefox to 35.0, some sites like plus.google.com and http://player.radio.com/listen/station/995-wycd/ will not give me the Allow to run "Adobe Flash"? at the top of the browser. Therefore cannot run Flash on thes sites. If I set to Flash to Always Active it will run.

Isisombululo esikhethiwe

I have found that changing the page from Default to Always Ask (which is the default) does not help. What I found is if on the page I click The Activate Adobe Flash it does nothing. But after doing that, I reload the page and click the Activate Adobe Flash, I get the allow now and it works. Chrome and Chromium do not have this problem, but both of those are using the flash that comes with Chrome.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.2 r202
  • Mime Type x-skype for Skype Buttons

Isisebenziso

  • Firefox 35.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/35.0/Linux/en-US/

Izandiso

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: X.Org -- Gallium 0.4 on AMD CAPE VERDE
  • adapterDeviceID: Gallium 0.4 on AMD CAPE VERDE
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 10.4.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: X.Org -- Gallium 0.4 on AMD CAPE VERDE
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Is there a place on the page that says "Activate Flash" on the page. Google plus does not ask me as well when I tested it. However, there are also permissions that you can change in the page info section.

  1. Right click on the icon in the url bar to the left of the address. (lock or globe)
  2. Click on More Information
  3. Click on Permissions
  4. Look at Activate plugins and move Adobe Flash to "Always Ask"

Restart Firefox, does this help?

Is there a place on the page that says "Activate Flash" on the page. Google plus does not ask me as well when I tested it. However, there are also permissions that you can change in the page info section. #Right click on the icon in the url bar to the left of the address. (lock or globe) # Click on More Information # Click on Permissions # Look at Activate plugins and move Adobe Flash to "Always Ask" Restart Firefox, does this help?

Umnikazi wombuzo

guigs2 said

Is there a place on the page that says "Activate Flash" on the page. Google plus does not ask me as well when I tested it. However, there are also permissions that you can change in the page info section.
  1. Right click on the icon in the url bar to the left of the address. (lock or globe)
  2. Click on More Information
  3. Click on Permissions
  4. Look at Activate plugins and move Adobe Flash to "Always Ask"
Restart Firefox, does this help?

The video has a link Activate Adobe Flash. Clicking it does nothing. Before it used to give the Allow to run "Adobe Flash"? at the top of the browser. There is no icon other than the ssl lock. There should be the plugin icon which is also missing. Right-Clicking on the lock only has the options Menu Bar, Bookmarks Toolbar and Customize... (no More Information).

''guigs2 [[#answer-679958|said]]'' <blockquote> Is there a place on the page that says "Activate Flash" on the page. Google plus does not ask me as well when I tested it. However, there are also permissions that you can change in the page info section. #Right click on the icon in the url bar to the left of the address. (lock or globe) # Click on More Information # Click on Permissions # Look at Activate plugins and move Adobe Flash to "Always Ask" Restart Firefox, does this help? </blockquote> The video has a link Activate Adobe Flash. Clicking it does nothing. Before it used to give the Allow to run "Adobe Flash"? at the top of the browser. There is no icon other than the ssl lock. There should be the plugin icon which is also missing. Right-Clicking on the lock only has the options Menu Bar, Bookmarks Toolbar and Customize... (no More Information).
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Just clicking on it would take you to a pop up that has a "More Information"

Just clicking on it would take you to a pop up that has a "More Information"

Umnikazi wombuzo

guigs2 said

Just clicking on it would take you to a pop up that has a "More Information"

Thank you. Doing this for plus.google.com alone did not fix the problem. But when I also did for www.youtube.com it fixed my problem.

''guigs2 [[#answer-680538|said]]'' <blockquote> Just clicking on it would take you to a pop up that has a "More Information" </blockquote> Thank you. Doing this for plus.google.com alone did not fix the problem. But when I also did for www.youtube.com it fixed my problem.

Umnikazi wombuzo

brianbrodsky said

guigs2 said
Just clicking on it would take you to a pop up that has a "More Information"

Thank you. Doing this for plus.google.com alone did not fix the problem. But when I also did for www.youtube.com it fixed my problem.

Guess, I was wrong. Went back in later and still have same problem. Settings are still ask on both sites.

''brianbrodsky [[#answer-680543|said]]'' <blockquote> ''guigs2 [[#answer-680538|said]]'' <blockquote> Just clicking on it would take you to a pop up that has a "More Information" </blockquote> Thank you. Doing this for plus.google.com alone did not fix the problem. But when I also did for www.youtube.com it fixed my problem. </blockquote> Guess, I was wrong. Went back in later and still have same problem. Settings are still ask on both sites.
AliceWyman
  • Moderator
240 izisombululo 2597 izimpendulo
Kuphostiwe

I don't have a solution but I also have a problem with "Ask to Activate" for Flash in Firefox 35 (this is on Windows 7 using the latest Flash version 16.0.0.296). I'm posting this to let you know you're not alone and to add information for others reading.

I mainly use SeaMonkey for browsing and setting Flash to "Ask to Activate" works just fine. All I have to do is click on "Activate Adobe Flash" and the video starts playing (SeaMonkey is based on Firefox).

I'm not sure when it stopped working in Firefox but others mentioned it in this ghacks article comments section.

When I set Flash to "Always Activate" in the Firefox Add-ons Manager Plugins list, it works fine. When I set it to "Ask to Activate", the "Activate Adobe Flash" prompt does nothing when I click it, if I haven't allowed it in the same session for that website. What works is to use the same solution given in this Java article: if clicking on the "Activate <snip> " message doesn't work, look for the plugin icon in the address bar. Click on it and, in the message panel that opens, choose Allow.... (If there IS no plugin icon in the address bar, I have to change Permissions for Adobe Flash to "Always Ask" in the Page Info window to get the plugin icon to appear.)

If I click the plugin icon in the address bar and allow Flash, the Flash video usually plays (sometimes I have to reload the page, though). If I find a solution I'll post back.

I don't have a solution but I also have a problem with "Ask to Activate" for Flash in Firefox 35 (this is on Windows 7 using the latest Flash version 16.0.0.296). I'm posting this to let you know you're not alone and to add information for others reading. I mainly use [http://www.seamonkey-project.org/ SeaMonkey] for browsing and setting Flash to "Ask to Activate" works just fine. All I have to do is click on "Activate Adobe Flash" and the video starts playing (SeaMonkey is based on Firefox). I'm not sure when it stopped working in Firefox but others mentioned it in [http://www.ghacks.net/2015/01/16/fix-add-ons-not-working-in-firefox-35/#comment-3126902 this ghacks article comments section]. When I set Flash to "Always Activate" in the Firefox Add-ons Manager Plugins list, it works fine. When I set it to "Ask to Activate", the "Activate Adobe Flash" prompt does nothing when I click it, if I haven't allowed it in the same session for that website. What works is to use the same solution given in [https://support.mozilla.org/en-US/kb/how-allow-java-trusted-sites#w_activate-java-once_2 this Java article]: ''if clicking on the "Activate <snip> " message doesn't work, look for the plugin icon in the address bar. Click on it and, in the message panel that opens, choose Allow...''. (If there IS no plugin icon in the address bar, I have to change Permissions for Adobe Flash to "Always Ask" in the [[Page Info window - View technical details about the page you are on|Page Info window]] to get the plugin icon to appear.) If I click the plugin icon in the address bar and allow Flash, the Flash video usually plays (sometimes I have to reload the page, though). If I find a solution I'll post back.

Isisombululo Esikhethiwe

I have found that changing the page from Default to Always Ask (which is the default) does not help. What I found is if on the page I click The Activate Adobe Flash it does nothing. But after doing that, I reload the page and click the Activate Adobe Flash, I get the allow now and it works. Chrome and Chromium do not have this problem, but both of those are using the flash that comes with Chrome.

I have found that changing the page from Default to Always Ask (which is the default) does not help. What I found is if on the page I click The Activate Adobe Flash it does nothing. But after doing that, I reload the page and click the Activate Adobe Flash, I get the allow now and it works. Chrome and Chromium do not have this problem, but both of those are using the flash that comes with Chrome.

Okulungisiwe ngu brianbrodsky

AliceWyman
  • Moderator
240 izisombululo 2597 izimpendulo
Kuphostiwe

brianbrodsky said

I have found that changing the page from Default to Always Ask (which is the default) does not help. What I found is if on the page I click The Activate Adobe Flash it does nothing. But after doing that, I reload the page and click the Activate Adobe Flash, I get the allow now and it works.

Thanks for posting that.

I tried it again and, for a foxnews video, the page Permissions was already set to "Always Ask" (since I had changed it to that) and there was still no plugin icon in the address bar. Just like you said: When clicking the "Activate Adobe Flash" link does nothing and there is no plugin in the address bar, reloading the page can make the plugin icon appear and then clicking the "Activate Adobe Flash" link would let me allow the video to play. It's quite buggy.

Possibly related to this bug fix? (See Bugzilla Etiquette before commenting in bugs) Bug 899347 - Make click-to-play work in e10s (Fixed in Firefox 35)

You did say,

I reload the page and click the Activate Adobe Flash, I get the allow now and it works.

I'm going to mark this thread "solved" based on that, even though it's a workaround. One reason being, "Solved" threads show up in search engine results. Another being, Flash works when "Always Activate" is selected in the Add-ons Manager and that's the default. You can change this question back to unsolved if you still need more help.

''brianbrodsky [[#answer-685090|said]]'' <blockquote> I have found that changing the page from Default to Always Ask (which is the default) does not help. What I found is if on the page I click The Activate Adobe Flash it does nothing. But after doing that, I reload the page and click the Activate Adobe Flash, I get the allow now and it works.</blockquote> Thanks for posting that. I tried it again and, for a foxnews video, the page Permissions was already set to "Always Ask" (since I had changed it to that) and there was still no plugin icon in the address bar. Just like you said: When clicking the "Activate Adobe Flash" link does nothing and there is no plugin in the address bar, reloading the page can make the plugin icon appear and then clicking the "Activate Adobe Flash" link would let me allow the video to play. It's quite buggy. Possibly related to this bug fix? (See [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] before commenting in bugs) ''[https://bugzilla.mozilla.org/show_bug.cgi?id=899347 Bug 899347] - Make click-to-play work in e10s'' (Fixed in Firefox 35) You did say, I reload the page and click the Activate Adobe Flash, I get the allow now and it works. I'm going to mark this thread "solved" based on that, even though it's a workaround. One reason being, "Solved" threads show up in search engine results. Another being, Flash works when "Always Activate" is selected in the Add-ons Manager and that's the default. You can change this question back to unsolved if you still need more help.

Umnikazi wombuzo

I just hope that this problem does not get ignored by marking it solved.

I just hope that this problem does not get ignored by marking it solved.
AliceWyman
  • Moderator
240 izisombululo 2597 izimpendulo
Kuphostiwe

Impendulo Ewusizo

brianbrodsky said

I just hope that this problem does not get ignored by marking it solved.

On the contrary, it might actually help get it solved! Only "solved" questions show up in search engine results and it would help others researching this problem if they can find this thread.

P.S. I tagged this question "escalate" to see if the helpdesk has any other suggestions.

''brianbrodsky [[#answer-685127|said]]'' <blockquote> I just hope that this problem does not get ignored by marking it solved. </blockquote> On the contrary, it might actually help get it solved! Only "solved" questions show up in search engine results and it would help others researching this problem if they can find this thread. P.S. I tagged this question "escalate" to see if the helpdesk has any other suggestions.

Okulungisiwe ngu AliceWyman

Impendulo Ewusizo

AliceWyman said

brianbrodsky said
I just hope that this problem does not get ignored by marking it solved.

On the contrary, it might actually help get it solved! Only "solved" questions show up in search results and it would help others researching this problem if they can find this thread.

Thank you for your help. The bug you sent link on I do not think is related. They marked as fixed in Firefox 35. I am now runing 35.0.1. Also my brower.tabs.remote.autostart is set to the default of false so as far as I know I am not running E10.

''AliceWyman [[#answer-685135|said]]'' <blockquote> ''brianbrodsky [[#answer-685127|said]]'' <blockquote> I just hope that this problem does not get ignored by marking it solved. </blockquote> On the contrary, it might actually help get it solved! Only "solved" questions show up in search results and it would help others researching this problem if they can find this thread. </blockquote> Thank you for your help. The bug you sent link on I do not think is related. They marked as fixed in Firefox 35. I am now runing 35.0.1. Also my brower.tabs.remote.autostart is set to the default of false so as far as I know I am not running E10.
AliceWyman
  • Moderator
240 izisombululo 2597 izimpendulo
Kuphostiwe

brianbrodsky said

Thank you for your help. The bug you sent link on I do not think is related. They marked as fixed in Firefox 35. I am now runing 35.0.1. Also my brower.tabs.remote.autostart is set to the default of false so as far as I know I am not running E10.

I was thinking that the bug fix caused a regression in Firefox 35, which is causing the issue you and I are seeing. It was just a thought.

''brianbrodsky [[#answer-685141|said]]'' <blockquote> Thank you for your help. The bug you sent link on I do not think is related. They marked as fixed in Firefox 35. I am now runing 35.0.1. Also my brower.tabs.remote.autostart is set to the default of false so as far as I know I am not running E10. </blockquote> I was thinking that the bug fix caused a regression in Firefox 35, which is causing the issue you and I are seeing. It was just a thought.

Okulungisiwe ngu AliceWyman