X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Tabbrowser.xml script errors

Kuphostiwe

Sometimes when I'm doing some casual browsing, Firefox will hang and about twenty seconds later I'll receive a popup message stating that Script: Chrome://browser/content/tabbrowser.xml:2088 [sometimes also entries: 2054 and 2077] have stopped responding. Occasionally, I'll see if the script will respond by selecting 'continue' but it always hangs until I stop the script.

The entries seem to always differ from the last on what has stopped responding. It's more often 2088 rather than the other two mentioned. The browser will not let me continue without the script because it will hang and send me another error until I choose to stop the script entirely.

I am unsure of what the script wants me to do in order to stop it from becoming unresponsive.

While it is not a major issue for me, it causes an annoyance in that whenever this occurs and I stop the script, the tabs will not close. Any tab I open becomes permanent until I restart Firefox.

Hopefully someone here can help me as I have not found any solution or mention of this issue (with solution) elsewhere.

Sometimes when I'm doing some casual browsing, Firefox will hang and about twenty seconds later I'll receive a popup message stating that Script: Chrome://browser/content/tabbrowser.xml:2088 [sometimes also entries: 2054 and 2077] have stopped responding. Occasionally, I'll see if the script will respond by selecting 'continue' but it always hangs until I stop the script. The entries seem to always differ from the last on what has stopped responding. It's more often 2088 rather than the other two mentioned. The browser will not let me continue without the script because it will hang and send me another error until I choose to stop the script entirely. I am unsure of what the script wants me to do in order to stop it from becoming unresponsive. While it is not a major issue for me, it causes an annoyance in that whenever this occurs and I stop the script, the tabs will not close. Any tab I open becomes permanent until I restart Firefox. Hopefully someone here can help me as I have not found any solution or mention of this issue (with solution) elsewhere.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.2.152
  • 5.1.31211.0
  • Unity Player 4.5.3f3

Isisebenziso

  • Firefox 35.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Izandiso

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • deviantAnywhere 1.2 (deviantAnywhere@cvds.ro)
  • Element Hiding Helper for Adblock Plus 1.3.1 (elemhidehelper@adblockplus.org)
  • The Addon Bar (restored) 3.2 (the-addon-bar@GeekInTraining-GiT)
  • XKit 7.4.5 (xkit@studioxenix.com)
  • Avast Online Security 10.0.2502.149 (wrc@avast.com) (Akusebenzi)
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: ATI Mobility Radeon HD 545v
  • adapterDescription2:
  • adapterDeviceID: 0x9553
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 aticfx64 atiu9pag aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 02be1028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-22-2010
  • driverDate2:
  • driverVersion: 8.692.1.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 545v Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi Painquake, This is the point in the code that when you try to move a tab left or right. However I am not sure why it would hang when moving a tab. My guess is that it is a memory issue where there are many tabs open.

I do not know why it would not close either, does this happen in Safe Mode, this will tell you if its an add on: Troubleshoot Firefox issues using Safe Mode

Hi Painquake, This is the point in the code that when you try to move a tab left or right. However I am not sure why it would hang when moving a tab. My guess is that it is a memory issue where there are many tabs open. I do not know why it would not close either, does this happen in Safe Mode, this will tell you if its an add on: [[Troubleshoot Firefox issues using Safe Mode]]
cor-el
  • Top 10 Contributor
  • Moderator
17465 izisombululo 157833 izimpendulo
Kuphostiwe

Are you trying to close a tab when this happens?

You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).


You can check for problems with the places.sqlite database file in the Firefox profile folder.

Are you trying to close a tab when this happens? You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Multiple_profile_files_created Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible). ---- You can check for problems with the <b>places.sqlite</b> database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *Places Maintenance: https://addons.mozilla.org/firefox/addon/places-maintenance/

Umnikazi wombuzo

guigs2 said

Hi Painquake, This is the point in the code that when you try to move a tab left or right. However I am not sure why it would hang when moving a tab. My guess is that it is a memory issue where there are many tabs open. I do not know why it would not close either, does this happen in Safe Mode, this will tell you if its an add on: Troubleshoot Firefox issues using Safe Mode

guigs2, I normally only have two or three tabs open at a time. I don't see how it should cause memory issues but it hangs when I accidentally open two of the same tabs (mainly opening a 'new tab' blank tab) and then attempt closing the accidental duplicate. I will monitor my memory usage tonight and check for spikes in memory usage around the time the issue occurs.

-- Edit: I ran Firefox in safe-mode for about four hours before it started hanging. It gave me the script error again [entry 2077]. I kept my resource monitor open to check for abnormalities and I noticed that there's a 20% spike in memory usage at the moment the program hangs.

''guigs2 [[#answer-678396|said]]'' <blockquote> Hi Painquake, This is the point in the code that when you try to move a tab left or right. However I am not sure why it would hang when moving a tab. My guess is that it is a memory issue where there are many tabs open. I do not know why it would not close either, does this happen in Safe Mode, this will tell you if its an add on: [[Troubleshoot Firefox issues using Safe Mode]] </blockquote> guigs2, I normally only have two or three tabs open at a time. I don't see how it should cause memory issues but it hangs when I accidentally open two of the same tabs (mainly opening a 'new tab' blank tab) and then attempt closing the accidental duplicate. I will monitor my memory usage tonight and check for spikes in memory usage around the time the issue occurs. -- '''Edit:''' I ran Firefox in safe-mode for about four hours before it started hanging. It gave me the script error again [entry 2077]. I kept my resource monitor open to check for abnormalities and I noticed that there's a 20% spike in memory usage at the moment the program hangs.

Okulungisiwe ngu Painquake

Umnikazi wombuzo

cor-el said

Are you trying to close a tab when this happens? You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible). [...]

cor-el, I have deleted the sessionstore.js and I'll keep using my browser to see if the issue persists. I will also, along with advice from another answer to monitor memory usage while using Firefox and checking if the issue follows into safe-mode.

''cor-el [[#answer-678427|said]]'' <blockquote> Are you trying to close a tab when this happens? You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Multiple_profile_files_created Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible). [...] </blockquote> cor-el, I have deleted the sessionstore.js and I'll keep using my browser to see if the issue persists. I will also, along with advice from another answer to monitor memory usage while using Firefox and checking if the issue follows into safe-mode.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Two changes I saw in previous solutions were to increase the session store interval and to disable hardware acceleration, but in this case may be OMTC?

Two changes I saw in previous solutions were to increase the session store interval and to disable hardware acceleration, but in this case may be OMTC?

Umnikazi wombuzo

guigs2 said

Two changes I saw in previous solutions were to increase the session store interval and to disable hardware acceleration, but in this case may be OMTC?

I'm not sure I understand entirely about OMTC, but I have recently disabled hardware acceleration and increased the session store interval.

''guigs2 [[#answer-680530|said]]'' <blockquote> Two changes I saw in previous solutions were to increase the session store interval and to disable hardware acceleration, but in this case may be OMTC? </blockquote> I'm not sure I understand entirely about OMTC, but I have recently disabled hardware acceleration and increased the session store interval.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Did you see any improvements with the changes that were made?

Did you see any improvements with the changes that were made?

Umnikazi wombuzo

I'm sorry, but the problem still persists. Usually when two 'new tab/about:blank' tabs are open simultaneously by accident. I attempt to close one of the two and that's when the tabbrowser.xml script becomes unresponsive. I should also mention that I'm using only three to four tabs when the issues occur. (two are pinned, one active, and a new, blank tab.)

I'm sorry, but the problem still persists. Usually when two 'new tab/about:blank' tabs are open simultaneously by accident. I attempt to close one of the two and that's when the tabbrowser.xml script becomes unresponsive. I should also mention that I'm using only three to four tabs when the issues occur. (two are pinned, one active, and a new, blank tab.)

Umnikazi wombuzo

Hello, I know everyone is busy and all, but has anyone figured out a solution (or even a temporary fix) for my problem? The above solutions aren't working for my problem.

It has been about a week since my last reply and the problem is becoming worse. I have to force-close the browser (via task manager) and restart it about every half-hour to have use of the tabs.

Hello, I know everyone is busy and all, but has anyone figured out a solution (or even a temporary fix) for my problem? The above solutions aren't working for my problem. It has been about a week since my last reply and the problem is becoming worse. I have to force-close the browser (via task manager) and restart it about every half-hour to have use of the tabs.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi Painquake, Thank you for posting back. So far we have tried safe mode and it hangs after a few hours. And so far we have not found a solution to this issue with the work arounds we know about.

We have tried to disable extensions, disabled add ons and hardware acceleration. We have increased the script dom load time and the interval, however its after a period of time.

What we should really try to confirm if it is an extension issue it to try a new profile. Profile Manager - Create, remove, or switch Firefox profiles

Have you updated your graphics card driver? Upgrade your graphics drivers to use hardware acceleration and WebGL This will confirm if it was an issue with acceleration, which is also disabled in safe mode.

Hi Painquake, Thank you for posting back. So far we have tried safe mode and it hangs after a few hours. And so far we have not found a solution to this issue with the work arounds we know about. We have tried to disable extensions, disabled add ons and hardware acceleration. We have increased the script dom load time and the interval, however its after a period of time. What we should really try to confirm if it is an extension issue it to try a new profile. [[Use the Profile Manager to create and remove Firefox profiles]] Have you updated your graphics card driver? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] This will confirm if it was an issue with acceleration, which is also disabled in safe mode.

Umnikazi wombuzo

guigs2 said

Hi Painquake, Thank you for posting back. So far we have tried safe mode and it hangs after a few hours. And so far we have not found a solution to this issue with the work arounds we know about. We have tried to disable extensions, disabled add ons and hardware acceleration. We have increased the script dom load time and the interval, however its after a period of time. What we should really try to confirm if it is an extension issue it to try a new profile. Profile Manager - Create, remove, or switch Firefox profiles Have you updated your graphics card driver? Upgrade your graphics drivers to use hardware acceleration and WebGL This will confirm if it was an issue with acceleration, which is also disabled in safe mode.

Thank you for your prompt reply.

My graphics drivers are as up to date as they can be for my specific card, according to device manager. (the card is an ATI Mobility Radeon HD 545v,) and I'm checking with AMD/ATI's website now to be entirely sure.

I am using a new profile (as directed to in your response) and I've noticed the same problem occurs in this profile as well as a few other things. Mainly, the memory usage spikes dangerously high (for the duration of the script hanging) and the system almost overheating (the keyboard is almost too hot to touch at this moment). The memory usage and the temperature both decrease upon stopping the tabbrowser.xml script once it starts to hang.

I'm certain this is very abnormal behaviour since I have not re-added my addons (but I have added my sync data and bookmarks back) and am using only one tab.

''guigs2 [[#answer-688883|said]]'' <blockquote> Hi Painquake, Thank you for posting back. So far we have tried safe mode and it hangs after a few hours. And so far we have not found a solution to this issue with the work arounds we know about. We have tried to disable extensions, disabled add ons and hardware acceleration. We have increased the script dom load time and the interval, however its after a period of time. What we should really try to confirm if it is an extension issue it to try a new profile. [[Use the Profile Manager to create and remove Firefox profiles]] Have you updated your graphics card driver? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] This will confirm if it was an issue with acceleration, which is also disabled in safe mode. </blockquote> Thank you for your prompt reply. My graphics drivers are as up to date as they can be for my specific card, according to device manager. (the card is an ATI Mobility Radeon HD 545v,) and I'm checking with AMD/ATI's website now to be entirely sure. I am using a new profile (as directed to in your response) and I've noticed the same problem occurs in this profile as well as a few other things. Mainly, the memory usage spikes dangerously high (for the duration of the script hanging) and the system almost overheating (the keyboard is almost too hot to touch at this moment). The memory usage and the temperature both decrease upon stopping the tabbrowser.xml script once it starts to hang. I'm certain this is very abnormal behaviour since I have not re-added my addons (but I have added my sync data and bookmarks back) and am using only one tab.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Indeed, but in the new profile were there any updates detected for the drivers? Upgrade your graphics drivers to use hardware acceleration and WebGL

Indeed, but in the new profile were there any updates detected for the drivers? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Umnikazi wombuzo

guigs2 said

Indeed, but in the new profile were there any updates detected for the drivers? Upgrade your graphics drivers to use hardware acceleration and WebGL

Using the new profile, windows update did find about 30 new updates that weren't detected previously, though unfortunately none were for drivers. I tried updating my graphics drivers manually but I am having trouble accessing AMD's website at this time.

''guigs2 [[#answer-689462|said]]'' <blockquote> Indeed, but in the new profile were there any updates detected for the drivers? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] </blockquote> Using the new profile, windows update did find about 30 new updates that weren't detected previously, though unfortunately none were for drivers. I tried updating my graphics drivers manually but I am having trouble accessing AMD's website at this time.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Is it possible to access if from another computer?

Is it possible to access if from another computer?

Umnikazi wombuzo

guigs2 said

Is it possible to access if from another computer?

Yes, I was able to access it and transfer the installation to this computer. (I also noticed that firefox on the second computer could not replicate this issue.) There was no change in firefox's behaviour after installing and updating the driver.

''guigs2 [[#answer-689516|said]]'' <blockquote> Is it possible to access if from another computer? </blockquote> Yes, I was able to access it and transfer the installation to this computer. (I also noticed that firefox on the second computer could not replicate this issue.) There was no change in firefox's behaviour after installing and updating the driver.