Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox freezes temporarily on certain websites and computer hangs

  • 38 uphendule
  • 15 zinale nkinga
  • 320 views
  • Igcine ukuphendulwa ngu Wizzlbang

more options

When loading certain websites, Firefox freezes for 10 to 30 seconds. When this occurs, the entire operating system is unresponsive. One website it almost always happens on is the Comcast TV schedule site I use: http://xfinitytv.comcast.net/tv-listings It happens with some regularity on facebook.com as well. Once the problem has occurred, it does not recur until the next session.

All Replies (20)

more options

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

more options

Hi Fred- I tried your suggestion, and both the sites I mention above loaded without issue. But I think hardware acceleration was already off: When I went into the advanced preferences in safe mode, hardware acceleration was unchecked, which, according to the FF guidance I saw on safe mode, is the default in that mode. When I then relaunched FF in normal mode, acceleration was still unchecked. So unless starting in safe mode turned off the acceleration and that setting carried over to normal mode, I'm assuming it wasn't on in the first place. Because the issue only occurs on a few sites, I'm assuming it is sloppy web design as opposed to a browser problem. I wonder if the issue could be related to the problem sites using Java or Flash, or some script that stymies Firefox, but I don't know how to check that. The thing that bothers me is that the browser causes the whole system to hang while it struggles with loading the site. I'm no expert, but I don't think that should happen in a four-core, 2.8 GHz system with 6 GB of RAM. --Eric

more options

Did you try to run Firefox in Safe Mode for a longer period of time?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Please give a list of the problem web sites. Some sites don't like Firefox. And something about some sites have given FF problems.

more options

Opps, Sorry, I found them.

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

more options

Hi Fred and cor-el, Thanks to both of you for your time and helpfulness. I have to admit that for the moment, I'm too lazy to do the exhaustive troubleshooting that you are suggesting, as the problem only occurs with the two websites I mentioned, and my first instinct is to blame those sites. From what I have observed of this issue, it would require a system restart at every step to re-create the conditions under which the websites cause FF to bog down. I wish there were a setting in FF to tell it not to hog computer resources when it is stymied by some element of a website. I have been using Firefox for many years, and I don't remember ever seeing it regularly freeze the computer like this before a few months ago.

more options

I've also experienced this issue on a low-spec PC running Windows 7 x64, mostly commonly on my first visit to imgur.com during a session.

The entire OS freezes and any keyboard or mouse input seems during that time will be carried out 20-30 seconds later when everything goes back to normal. Hardware acceleration is off.

more options

charonn0 Wow, you are angry. Just look at that face.  :-)

Follow the instructions above. Any good come out of it?

more options

I've disabled all plugins and addons, but it's hard to say whether it makes any difference since I don't know what triggers it. I will keep them disabled for a while and see what happens.

The freeze is seemingly random, it might happen as soon as I launch Firefox and visit a website or it might happen 6 hours later when I visit that same website again. The only constant is that it only seems to happen once per boot cycle, usually when opening a link in a new tab via middle clicking (but I do that a lot anyway so it might not be relevant.)

more options

charonn0, I'd be curious to know if you encounter your issue on either of the sites I mention in the top post. I have a login on the Comcast site; not sure if that would enter into the equation. As for Facebook, all I notice is that during the freeze-up, the little indicator pop-up in the lower left of the browser window, which for most sites just briefly displays info relating to loading the site, will display the following for a while: waiting for / transferring data from fbstatic-a.akamaihd.net --Eric

more options

Question owner - a standout in your System Details is LogMeIn Rescue Technician Console. Make sure that is not active,

more options

Thanks, Alan. I forgot I'd installed that--is it known to cause problems? Removing it did not help with my issue, but if it's prone to meddling, I'm glad to be rid of it. --Eric

more options

If de-activating didn't help with your problem, by all means keep it if you use it. It just seemed a possibility to me.

more options

FYI, this site just temporarily paralyzed my computer: https://chroniclevitae.com/job_search --Eric

more options

Hmm, no problem with that site.

EricUniqueUsername

Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox. Is the problem still there?

more options

Hi Fred- As I mentioned above, I tried a few things in safe mode when you first suggested it. Just now I did a couple more tests: Restarted in safe mode, tried all three sites

All three loaded reasonably quickly. I think it was the first time today I'd gone to either Facebook or the Comcast schedule, but I wanted to double check, so I restarted the computer, then l launched FF in safe mode (note: holding Shift key on my Win7 machine while clicking launch button did not start it in safe mode). The Comcast site took at least twenty seconds to load; FB and Vitae loaded normally. So I'm assuming that rules out the problem stemming from an add-on, at least for the Comcast site. Thanks again for your help. --Eric

more options

http://xfinitytv.comcast.net/tv-listings?cmpid=xf_dash_tvl#

The main page displayed in two seconds, and finished in 5 - 7 seconds.


I do not have an account on Face Book.


https://chroniclevitae.com/job_search

This took about 7 - 10 seconds to display

more options

EricUniqueUsername said

(note: holding Shift key on my Win7 machine while clicking launch button did not start it in safe mode)

Did you get some kind of error message? What happen?

more options

No, no error message. FF started in normal mode. Do you have to continue holding the key down for a while after it first starts to launch? Congratulations on not having wasted your time with Facebook...

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox.

Once you triggered Firefox to start, it should start.

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

  1. 1
  2. 2