X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Windows 8.1 Mozilla works for some users but not all

Kuphostiwe

Hi,

I have 3 users on my laptop. Admin, user and kids account. Mozilla worksl flawlessly on all the accounts except the kids. I try to access yahoo.com or google.com and the page will not load. The family settings on the kids account is set to allow all web sites.

I get this error An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

any ideas?

Hi, I have 3 users on my laptop. Admin, user and kids account. Mozilla worksl flawlessly on all the accounts except the kids. I try to access yahoo.com or google.com and the page will not load. The family settings on the kids account is set to allow all web sites. I get this error An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) any ideas?

Isisombululo esikhethiwe

Ah finally found it: https://support.microsoft.com/kb/2965.../en-us It is because the Family Safety uses its own cert. "new Family Safety security certificate "

You should see an untrusted certificate error, specifically "This Connection is Untrusted” warning. Those instructions in the Microsoft article are accurate for adding a certificate.

That should do it.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • NPWLPG
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • iTunes Detector Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi wings9798, Thank you for your question, on that account where there any changes to the ssl version accepted in the browser?

You can check the connection settings.

Or you can try a malware scan for just that account: Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Hi wings9798, Thank you for your question, on that account where there any changes to the ssl version accepted in the browser? You can check the connection settings. * Tools > Options > Advanced > Network : Connection > Settings * https://support.mozilla.org/kb/Options+window+-+Advanced+panel Or you can try a malware scan for just that account: Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/viruses/disinfection/5350 Anti-Rootkit Utility - TDSSKiller] * [http://general-changelog-team.fr/en/downloads/viewdownload/20-outils-de-xplode/2-adwcleaner AdwCleaner] (for more info, see this [http://www.bleepingcomputer.com/download/adwcleaner/ alternate AdwCleaner download page]) * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!
deadsquid 0 izisombululo 7 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Google and Yahoo also use certificate pinning, which can be affected by some third party software, notably Kaspersky, that introduces a feature to scan encrypted content. Are you using any parental control and/or AV software on this computer?

Google and Yahoo also use certificate pinning, which can be affected by some third party software, notably Kaspersky, that introduces a feature to scan encrypted content. Are you using any parental control and/or AV software on this computer?
FredMcD
  • Top 10 Contributor
4225 izisombululo 58988 izimpendulo
Kuphostiwe

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.'''

Umnikazi wombuzo

wings9798 said

Hi, I have 3 users on my laptop. Admin, user and kids account. Mozilla worksl flawlessly on all the accounts except the kids. I try to access yahoo.com or google.com and the page will not load. The family settings on the kids account is set to allow all web sites. I get this error An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) any ideas?

Thank you everybody for your responses Here are my responses.

I use AVAST for my virus protection I checked I do not have any add-ons, there is an AVAST one there but it is disabled. I do have parental controls enabled for the account that I'm having problems with. It is set to allow all web sites. I haven't restricted any. I ran a scan with Malbytes and there was a non malware item I quarantined. The setting for connection is the default setting to use the system setting.

Mozilla works flawlessly on the other 2 accounts on the PC, just the kids one I can't get google.com or Yahoo.com to open.

Thanks

''wings9798 [[#question-1040279|said]]'' <blockquote> Hi, I have 3 users on my laptop. Admin, user and kids account. Mozilla worksl flawlessly on all the accounts except the kids. I try to access yahoo.com or google.com and the page will not load. The family settings on the kids account is set to allow all web sites. I get this error An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) any ideas? </blockquote> Thank you everybody for your responses Here are my responses. I use AVAST for my virus protection I checked I do not have any add-ons, there is an AVAST one there but it is disabled. I do have parental controls enabled for the account that I'm having problems with. It is set to allow all web sites. I haven't restricted any. I ran a scan with Malbytes and there was a non malware item I quarantined. The setting for connection is the default setting to use the system setting. Mozilla works flawlessly on the other 2 accounts on the PC, just the kids one I can't get google.com or Yahoo.com to open. Thanks
FredMcD
  • Top 10 Contributor
4225 izisombululo 58988 izimpendulo
Kuphostiwe

Try setting up a new profile for the kids. Do you have the same problem?

Try setting up a new profile for the kids. Do you have the same problem?
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

In web filtering, are there any specific websites that are blocked? It can also be achieved with the addon mentioned here:https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-...

In web filtering, are there any specific websites that are blocked? It can also be achieved with the addon mentioned here:[https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef#firefox:win8:fx35]

Umnikazi wombuzo

I just set up a brand new user. No email child account. www.google.com and www.yahoo.com do not come up. Same error. www.bing.com and www.safekidssearch.com comes up fine. cnn.com and other sites as well. Since I have not blocked any sites on the web filtering that shouldn't be the case either.

On the same account IE works fine. I haven't tried Chrome. I really like FF but if google and the yahoo sites can't get by the child filter on 8.1 I may just have to use IE.

I appreciate everyone's help but if there are any more ideas I will try them.

I just set up a brand new user. No email child account. www.google.com and www.yahoo.com do not come up. Same error. www.bing.com and www.safekidssearch.com comes up fine. cnn.com and other sites as well. Since I have not blocked any sites on the web filtering that shouldn't be the case either. On the same account IE works fine. I haven't tried Chrome. I really like FF but if google and the yahoo sites can't get by the child filter on 8.1 I may just have to use IE. I appreciate everyone's help but if there are any more ideas I will try them.
FredMcD
  • Top 10 Contributor
4225 izisombululo 58988 izimpendulo
Kuphostiwe

Is there anything different about the accounts? Settings, Add-ons? Permissions?

Is there anything different about the accounts? Settings, Add-ons? Permissions?

Umnikazi wombuzo

No everything is the same except it is a child account vs a normal account. I tried again and set up a new adult account and a new child account. yahoo and google work fine on the adult account nothing for the child account.

No everything is the same except it is a child account vs a normal account. I tried again and set up a new adult account and a new child account. yahoo and google work fine on the adult account nothing for the child account.
FredMcD
  • Top 10 Contributor
4225 izisombululo 58988 izimpendulo
Kuphostiwe

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Umnikazi wombuzo

Thanks for the help.

Thanks for the help.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

I tested this with a new user, when I set up the user I added them as a child. However when I opened the account, opened Firefox I selected as the Default, and it then asked me if I wanted to change the default for http. (I selected Firefox. )

This link for google: https://www.google.com/?gws_rd=ssl This link for yahoo: https://www.yahoo.com/

Does this happen when you change the way Firefox connects to the internet to "No proxy" if not, then its not a proxy issue.

Is port 443 open on the filter and what is the default program for https and http.

I tested this with a new user, when I set up the user I added them as a child. However when I opened the account, opened Firefox I selected as the Default, and it then asked me if I wanted to change the default for http. (I selected Firefox. ) This link for google: [https://www.google.com/?gws_rd=ssl] This link for yahoo: [https://www.yahoo.com/] Does this happen when you change the way Firefox connects to the internet to "No proxy" if not, then its not a proxy issue. Is port 443 open on the filter and what is the default program for https and http.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Ah finally found it: https://support.microsoft.com/kb/2965.../en-us It is because the Family Safety uses its own cert. "new Family Safety security certificate "

You should see an untrusted certificate error, specifically "This Connection is Untrusted” warning. Those instructions in the Microsoft article are accurate for adding a certificate.

That should do it.

Ah finally found it: [https://support.microsoft.com/kb/2965142/en-us] It is because the Family Safety uses its own cert. "new Family Safety security certificate " You should see an untrusted certificate error, specifically "This Connection is Untrusted” warning. Those instructions in the Microsoft article are accurate for adding a certificate. That should do it.

Impendulo Ewusizo

Sorry for the delay in my response. Finally found time to do as the article stated. Seemed to work. After I moved the certificate to the desktop and then installed into FireFox I went to google.com. It said I had to authorize the site which I stepped through to do and it worked.

Again thank you for your help.

Sorry for the delay in my response. Finally found time to do as the article stated. Seemed to work. After I moved the certificate to the desktop and then installed into FireFox I went to google.com. It said I had to authorize the site which I stepped through to do and it worked. Again thank you for your help.