X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Triple click doesn't select all when autocomplete appears.

Kuphostiwe

I recently updated to Firefox 34.0.5 (on Windows 7) and it seems like every time I get an issue sorted out, I discover another one. Today, I have realized that triple-clicking within a form or text field does not select all of the text if the autocomplete appears. This has never been an issue for me with previous Firefox versions. This is quickly become a nuisance for me and I would like to get it resolved ASAP. I have tried looking around for solutions, but all I've really been able to find is this bug report: https://bugzilla.mozilla.org/show_bug.cgi?id=307776

I've read through that and related reports, but I didn't see a resolution anywhere. Is there anything I can do to fix this?

Note: "browser.triple_click_selects_paragraph" is set to true and it works as expected, but NOT if the autocomplete dropdown appears.

EDIT: I have also just discovered that I can no longer delete autocomplete entries by highlighting them and pressing Delete. Were these changes actually intentional or is there just a problem on my end?

I recently updated to Firefox 34.0.5 (on Windows 7) and it seems like every time I get an issue sorted out, I discover another one. Today, I have realized that triple-clicking within a form or text field does not select all of the text if the autocomplete appears. This has never been an issue for me with previous Firefox versions. This is quickly become a nuisance for me and I would like to get it resolved ASAP. I have tried looking around for solutions, but all I've really been able to find is this bug report: https://bugzilla.mozilla.org/show_bug.cgi?id=307776 I've read through that and related reports, but I didn't see a resolution anywhere. Is there anything I can do to fix this? Note: "browser.triple_click_selects_paragraph" is set to true and it works as expected, but NOT if the autocomplete dropdown appears. EDIT: I have also just discovered that I can no longer delete autocomplete entries by highlighting them and pressing Delete. Were these changes actually intentional or is there just a problem on my end?

Okulungisiwe ngu ZombieToast

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Amazon MP3 Downloader Plugin 1.0.17
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Coupons, Inc. Coupon Printer Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • PlayStation(R)Network Downloader Check Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • Square Enix Secure Launcher
  • Unity Player 4.3.7f1
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG
  • iTunes Detector Plug-in

Isisebenziso

  • Firefox 34.0.5
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

Izandiso

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • Back/forward dropmarker 1.0 ({d618933b-9eb4-1c04-949d-0f9b1a39ebb9})
  • Classic Theme Restorer 1.2.8.2 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Classic Toolbar Buttons 1.4.5 (CSTBB@NArisT2_Noia4dev)
  • Classicish Add-on Manager 0.8.5 (classicishaddonmanager@dagger2-addons.mozilla.org)
  • Download Manager (S3) 3.08 (s3download@statusbar)
  • Flash and Video Download 1.64 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Ghostery 5.4.1 (firefox@ghostery.com)
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Honey 2.0.5.3 (jid1-93CWPmRbVPjRQA@jetpack)
  • Menu Editor 1.2.7 ({EDA7B1D7-F793-4e03-B074-E6F303317FB0})
  • NoScript 2.6.9.10 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Old Default Image Style 3.0.6 (olddefaultimagestyle@dagger2-addons.mozilla.org)
  • Old Google Image Search Beta4.rev53.1 (jid0-hVK3JChToUWBtJHMEmFM9ELeInk@jetpack)
  • Pilfer 1.29 ({3a7f36a0-c6ec-11dd-ad8b-0800200c9a66})
  • Reddit-upvote-display 1.0 (vgonsalv@cs.purdue.edu)
  • RightToClick 2.9.5 ({cd617375-6743-4ee8-bac4-fbf10f35729e})
  • Saved Password Editor 2.8.1 (savedpasswordeditor@daniel.dawson)
  • Search By Image (by Google) 1.1.2 ({ce7e73df-6a44-4028-8079-5927a588c948})
  • Session Manager 0.8.1.6 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Status-4-Evar 2014.07.06.05 (status4evar@caligonstudios.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Akusebenzi)
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}) (Akusebenzi)
  • F.B. Purity - Cleans Up Facebook 9.6.0 (fbp@fbpurity.com) (Akusebenzi)
  • Reddit Enhancement Suite 4.5.4 (jid1-xUfzOsOFlzSOXg@jetpack) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: NVIDIA GeForce GTX 550 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1244
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 089c196e
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1800 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-13-2014
  • driverDate2:
  • driverVersion: 9.18.13.4411
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 550 Ti Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.history_expire_days.mirror: 180
  • browser.newtab.url: about:blank
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.search.context.loadInBackground: True
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.animate: False
  • browser.tabs.drawInTitlebar: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.urlbar.autoFill: False
  • browser.urlbar.trimURLs: False
  • dom.max_chrome_script_run_time: 60
  • dom.max_script_run_time: 40
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0.5
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • media.gmp-gmpopenh264.lastUpdate: 1420284248
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1420435148
  • media.windows-media-foundation.enabled: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1420456321
  • places.history.expiration.transient_current_max_pages: 104858
  • places.last_vacuum: 1376378055
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np32dsw: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.extensions-sessionmanager: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.enable_java: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1418972461

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
FredMcD
  • Top 10 Contributor
4307 izisombululo 60475 izimpendulo
Kuphostiwe

Is the crash report yours?

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Is the crash report yours? '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems?
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Another user posted about this for Firefox 31 (the ESR version, so could have been even earlier) (Double click select all does not work in web site's search area after going back.) (it really should reference triple-click, I think).

The corresponding new bug report is: 1094041 – Double click select all does not work after form history shows up (it really should reference triple-click, I think). That doesn't seem to have gone anywhere as the cause of the change was not obvious.

Have you tested in Firefox's Safe Mode to rule out one or more of your extensions as possible culprits? That's a standard diagnostic tool as you probably know. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Another user posted about this for Firefox 31 (the ESR version, so could have been even earlier) ([https://support.mozilla.org/questions/1027748 Double click select all does not work in web site's search area after going back.]) (it really should reference triple-click, I think). The corresponding new bug report is: [https://bugzilla.mozilla.org/show_bug.cgi?id=1094041 1094041 – Double click select all does not work after form history shows up] (it really should reference triple-click, I think). That doesn't seem to have gone anywhere as the cause of the change was not obvious. Have you tested in Firefox's Safe Mode to rule out one or more of your extensions as possible culprits? That's a standard diagnostic tool as you probably know. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?

Umnikazi wombuzo

Thank you both for the responses. I have tried using Firefox in Safe Mode (doing so now, in fact) and it doesn't make a difference; the problem still persists.

Also, FredMcD, that report was not mine; I was just linking to it for the sake of reference. I did as you said, but hardware acceleration was already disabled.

After midnight, my bandwidth restriction is lifted and I will be able to download whatever I want. Should I try installing a beta of a newer version of Firefox or perhaps a slightly older version? Also, I am running a 64-bit version of Windows 7; is there a 64-bit Firefox that might potentially run better on my machine?

Thank you both for the responses. I have tried using Firefox in Safe Mode (doing so now, in fact) and it doesn't make a difference; the problem still persists. Also, '''FredMcD''', that report was not mine; I was just linking to it for the sake of reference. I did as you said, but hardware acceleration was already disabled. After midnight, my bandwidth restriction is lifted and I will be able to download whatever I want. Should I try installing a beta of a newer version of Firefox or perhaps a slightly older version? Also, I am running a 64-bit version of Windows 7; is there a 64-bit Firefox that might potentially run better on my machine?
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

I have no idea whether this issue exists in Firefox 35/beta or later versions.

There is no official 64-bit version other than the bleeding edge "Nightly" testing version which is likely to be glitchy.

As a short-term workaround, what do you think about using Select All? It can be invoked using either:

  • click in the field and press Ctrl+a
  • right-click the field > Select All
  • right-click the field, then press a on the keyboard

You also can register on the Bugzilla site and "vote" for the newer bug to be fixed. See:

I have no idea whether this issue exists in Firefox 35/beta or later versions. There is no official 64-bit version other than the bleeding edge "Nightly" testing version which is likely to be glitchy. As a short-term workaround, what do you think about using Select All? It can be invoked using either: * click in the field and press Ctrl+a * right-click the field > Select All * right-click the field, then press a on the keyboard You also can register on the Bugzilla site and "vote" for the newer bug to be fixed. See: * [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] * [https://bugzilla.mozilla.org/page.cgi?id=voting.html Voting]
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

By the way, down arrow selection followed by pressing the Delete key should still work to remove entries.

By the way, down arrow selection followed by pressing the Delete key should still work to remove entries.

Umnikazi wombuzo

I've tried repeatedly to delete autocomplete entries that way, but it isn't working in this newer version of Firefox. When I press Delete, it appears to remove the entry, but it will reappear if I press the down arrow again.

As for my main problem, I guess I'll just have to resort to the keyboard shortcut for now, unless I can get another update to work properly. And I'll be sure to vote on Bugzilla. Thanks for the suggestion.

I've tried repeatedly to delete autocomplete entries that way, but it isn't working in this newer version of Firefox. When I press Delete, it appears to remove the entry, but it will reappear if I press the down arrow again. As for my main problem, I guess I'll just have to resort to the keyboard shortcut for now, unless I can get another update to work properly. And I'll be sure to vote on Bugzilla. Thanks for the suggestion.
cor-el
  • Top 10 Contributor
  • Moderator
17681 izisombululo 159964 izimpendulo
Kuphostiwe

Is this in the location/address bar drop-down list or with autocomplete data of a form on a web page?

Using Delete on a web page should work, but deleting an autocomplete entry from the location bar in case of an item that you typed (i.e not a bookmark or history item) may not work.

Is this in the location/address bar drop-down list or with autocomplete data of a form on a web page? Using Delete on a web page should work, but deleting an autocomplete entry from the location bar in case of an item that you typed (i.e not a bookmark or history item) may not work.