Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google should always open when i open a new tab

  • 6 uphendule
  • 29 zinale nkinga
  • 27356 views
  • Igcine ukuphendulwa ngu buzzook

more options

I have set a particular email site on the first tab. I know how to set or change it. Now here is my query- I wish that whenever I open a new (second and subsequent too) tab, it should always open Google to facilitate my search. If I want to change it, I will do it manually. I have also set Google as my search engine, still it does not show up automatically on opening a new tab. Pl guide.

Isisombululo esikhethiwe

Here's how to specify the page to display in a new tab:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Note: Google will always redirect to the secure version, so save a step by pasting in the full URL: https://www.google.com/

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Some gotchas:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions

If the change works during your session, but reverts to the previous setting at the next startup: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save. Or you might have software like Advanced SystemCare that blocks/reverts browser settings changes.

Any luck?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 29

All Replies (6)

more options

Isisombululo Esikhethiwe

Here's how to specify the page to display in a new tab:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Note: Google will always redirect to the secure version, so save a step by pasting in the full URL: https://www.google.com/

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Some gotchas:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions

If the change works during your session, but reverts to the previous setting at the next startup: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save. Or you might have software like Advanced SystemCare that blocks/reverts browser settings changes.

Any luck?

more options

I have a similar related problem.

Followed the instructions above to set Google.com.au as NewTab preference in about:config, but when I do this, and open a NewTab, the cursor/focus is lost and does not appear in either the Titlebar or the Google Search Box.

I want it to appear automatically in the Google search box.

Need advice.

more options

Hi buzzook, if you set browser.newtab.url to the full URL https://www.google.com.au/ then Firefox should show the page with the full URL selected in the address bar. This is basically the normal behavior for a new tab, to always focus the address bar.

It is a little strange when you do not use the full URL because Google tells Firefox to redirect and then instead of the URL being selected, the selection collapses to the end of the URL.

To force Firefox to move the selection into the search box most likely will require an add-on. According to a recent review, this one will do what you want and move the cursor into the search box: https://addons.mozilla.org/firefox/addon/custom-new-tab/

more options

jscher - thanks.

Ed's Add-on solved the problem.

I've been trying to figure out how to do it without an add-on, but it's clear that FF won't allow the cursor focus to appear in Google's search box without the add-on.

This is probably FF attempting to take over the universe by stealth, and force people to use FF 'tiles' page as 'home' instead of Google.

I get why FF would want this but I don't, and from the queries on the web I'm not alone.

You can't force people to go where they don't want to go.

I have literally thousands of catalogued bookmarks in drop down lists, which continues to work for me. On a touch-screen tablet I could see the logic of tiles, but not on the PC using mouse and keyboard.

The whole 'tiles' thing is just so much 'make work' IMHO.

But thanks for finding me a solution that works. :)

more options

Hi buzzook, this fluctuated for several versions of Firefox, with the cursor going into the page, not going into the page, going unexpectedly into the page... Since the starting point for the new tab page was a blank page with the address bar focused and ready to receive an address or search (until the new tab page debuted around Firefox 13), ultimately it was decided to keep the address bar focused for consistency. There have been several add-ons over the years to modify that, so it's unlikely to become a built-in option as long as the need for alternate behavior is satisfied.

more options

Thanks for the clarification! Understand the need for consistency, and why having the focus in the title bar is 'more useful' than not.

I have no isse with the focus in the title bar, provided there is a plug-in to enable the focus to be located in the search field on the page, as you've now pointed out there is.

Ed's plug-in works for me and should for anyone else with this somewhat annoying issue.