Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FIREFOX 34 WILL NOT ALLOW ME TO ACCESS A SITE I NEED TO. HOW CAN I

  • 1 baphendule
  • 16 zinale nkinga
  • 3631 views
  • Igcine ukuphendulwa ngu Topher

more options

GETTING ERROR MESSAGE SSLv3 error. New with installation of FIREFOX 34. Can I be allowed access for this site, if so, how? Or do I need to reinstall Firefox 30?

Isisombululo esikhethiwe

Hello REEVREDNAV, SSLv3 encrypted connections can be no longer considered secure since an attack vector against them ("POODLE") has become known. Contact the webmaster in charge of the site and urge them to update their encryption to something contemporary. https://blog.mozilla.org/security/2014/10/14/the-poodle-attack-and-the-end-of-ssl-3-0/

If you want to re-enable ssl 3.0 in firefox you can do that - however keep the consequences in mind, that you will become vulnerable to the attack mentioned above: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.tls.version.min. double-click it, change its value to 0 and restart the browser.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (1)

more options

Isisombululo Esikhethiwe

Hello REEVREDNAV, SSLv3 encrypted connections can be no longer considered secure since an attack vector against them ("POODLE") has become known. Contact the webmaster in charge of the site and urge them to update their encryption to something contemporary. https://blog.mozilla.org/security/2014/10/14/the-poodle-attack-and-the-end-of-ssl-3-0/

If you want to re-enable ssl 3.0 in firefox you can do that - however keep the consequences in mind, that you will become vulnerable to the attack mentioned above: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.tls.version.min. double-click it, change its value to 0 and restart the browser.