Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox crashes: Plugin-Container Issue

  • 7 uphendule
  • 17 zinale nkinga
  • 227 views
  • Igcine ukuphendulwa ngu FredMcD

more options

After the second-to-last update, I started noticing an increase in browser crashes. The issue is always that the Plugin-Container has stopped working. I understand that the plugin container's function is to prevent such problems, but it does not appear to be working. I have the latest version of Firefox, updates, etc, but that doesn't seem to be helping. Crash reports have been sent to Mozilla, but the problem is ongoing. I use my browser heavily in both standard and incognito mode for business. I've used Firefox for a long time, but if I keep losing information mid-process, I'm going to have to consider other options. If anyone has any experience with the problem or suggestions on a possible solution, that would be greatly appreciated.

Thanks, Nomenica

All Replies (7)

more options

Sorry to hear about the crashes, and thank you for submitting reports. To connect forum volunteers with your reports, you can post the crash IDs here. Please check the last section of the support article "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" for steps to get those crash IDs.

Assuming that the crashes reflect problems with the Flash plugin, this is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) You can try disabling hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here (takes effect when you exit and start Firefox up again):

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable the protected mode feature. That feature has security benefits, but seems to have compatibility issues on some systems. You can do this by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

more options

Thanks, Jscher2000.

The latest crash report is here.

more options

Unfortunately, nothing pops out as me as an immediate solution based on that crash report. System memory use was recorded as 79% so possibly Firefox ran out of memory (although it wasn't marked as such). It doesn't seem to be plugin related.

There is a bug report on file related to the crash "signature" which indicates it can happen on image-heavy pages. Since you have 3 different Pinterest-related extensions which might go into motion on an image-heavy page, could you try disabling those for a day and see whether it makes any difference?

More generally, you might want to disable all nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if you can live without them for 24 hours, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

If you have additional reports that might shed more light on the problem, please feel free to post those links as well.

more options

I removed unnecessary plugins and disabled the rest. I upgraded to the newest version of FF. I had only one image heavy page open this time and no Pinterest add-on/extensions. The last crash was about ten minutes ago.

This is the lastest report: https://crash-stats.mozilla.com/report/index/853847d9-83be-4153-ae35-b44672141205

I'll include a few other reports, randomly chosen from the vast selection, in case they're of any help:

https://crash-stats.mozilla.com/report/index/0671d932-1faa-4e24-b61e-e50302141205 https://crash-stats.mozilla.com/report/index/85af1f3b-beb2-4522-bcec-216312141205 https://crash-stats.mozilla.com/report/index/3a10abcf-e62b-4a2a-b7b0-77c922141205 https://crash-stats.mozilla.com/report/index/a43ab4f2-d8a5-4a2b-a68e-5e4c42141110 https://crash-stats.mozilla.com/report/index/2c7f17db-546d-41a1-a4de-630f32141110

Thank you very much for your assistance with this issue. I greatly appreciate it.

more options

Of those six:

  • out of memory - small
  • Flash crash (looks like protected mode crash)
  • [empty - Firefox unable to capture data]
  • Flash hang
  • out of memory - large
  • Flash hang

The out-of-memory crashes are hard to solve because in some cases it is just a capacity issue with the page, i.e., the page involves more content than Firefox can properly handle. Is it a page you could give a link to (so we can crash our own Firefoxes)?

more options

Tumblr.com. The way the site is set up, I don't believe it shuts down images, etc, once you've loaded and passed them. It's endless scrolling, so that could potentially be a lot of loaded data.

more options

Update your Flash Player v15.0.0.239 http://get.adobe.com/flashplayer/

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also: