X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Any website I open has little square boxes rather than displaying the correct text.

Kuphostiwe

When I open websites all text appears as little square boxes. I un-installed Firefox 33.1 and restarted my laptop. I re-installed Firefox and again re-started my laptop. The issue is the same. I read an article that stated to adjust the zoom to see if the font size would rectify the situation. That did not work for me. Another article said to be sure that each website can select its' own fonts/sizes. That was all set also.

When I open websites all text appears as little square boxes. I un-installed Firefox 33.1 and restarted my laptop. I re-installed Firefox and again re-started my laptop. The issue is the same. I read an article that stated to adjust the zoom to see if the font size would rectify the situation. That did not work for me. Another article said to be sure that each website can select its' own fonts/sizes. That was all set also.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is running, you can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

(Not all add-ons are disabled: Flash and other plugins still run)

If Firefox is not running, you can start Firefox in its Safe Mode by holding down the Shift key when starting Firefox.

A small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is running,'' you can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled (Not all add-ons are disabled: Flash and other plugins still run) ''If Firefox is not running,'' you can start Firefox in its Safe Mode by holding down the Shift key when starting Firefox. A small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?

Umnikazi wombuzo

I tried using Safe Mode but am still seeing square boxes rather than text. I am planning to uninstall Firefox again and go back to an earlier version of the program. Thanks though, for your reply.

I tried using Safe Mode but am still seeing square boxes rather than text. I am planning to uninstall Firefox again and go back to an earlier version of the program. Thanks though, for your reply.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Using an insecure version of Firefox really isn't a solution...

The Safe Mode test ruled out two possible causes: incompatibility with your graphics card driver and behavior caused by an extension.

When you are ready to resume working on this problem, we'll want to investigate whether you are overriding websites' font choices and whether that is causing the problem. You can check for that here:

"3-bar" menu button (or Tools menu) > Options > Content > "Advanced" button

Here you need to "Allow pages to choose their own fonts"

Any difference?

Using an insecure version of Firefox really isn't a solution... The Safe Mode test ruled out two possible causes: incompatibility with your graphics card driver and behavior caused by an extension. When you are ready to resume working on this problem, we'll want to investigate whether you are overriding websites' font choices and whether that is causing the problem. You can check for that here: "3-bar" menu button (or Tools menu) > Options > Content > "Advanced" button Here you need to "Allow pages to choose their own fonts" Any difference?
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

A couple other general things you might not have tried, which address possible corruption in settings files (your profile folder), and possible problems in your Firefox program folder.

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also will have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > Run (hold Windows key an press R):

firefox.exe -P

Don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Go ahead and click the Create Profile button, give it a name like Nov8, and skip the option to change the folder location. Then start Firefox in the new profile you created.

Until you go back to the Profile Manager and start up in your regular profile, your desktop shortcut should fire up the new profile.

Fonts look any better?

Note: When returning to the Profile Manager, you might be tempted to use the Delete Profile button on your new test profile. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.


You can replace Firefox's program files without disturbing your settings using this Clean Reinstall procedure:

(1) Download a fresh installer for Firefox 33 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) If applicable, exit out of Firefox or make sure it is fully terminated in Task Manager.

(3) Rename the folder (32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement in your fonts?

Note: Some recently installed plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • C:\Program Files\OldFirefox\Plugins
  • C:\Program Files\OldFirefox\browser\plugins
A couple other general things you might not have tried, which address possible corruption in settings files (your profile folder), and possible problems in your Firefox program folder. '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also will have completely fresh settings databases and a fresh cache folder. Exit Firefox and start up in the Profile Manager using Start > Run (hold Windows key an press R): firefox.exe -P ''Don't delete anything here.'' Any time you want to switch profiles, exit Firefox and return to this dialog. Go ahead and click the Create Profile button, give it a name like Nov8, and skip the option to change the folder location. Then start Firefox in the new profile you created. ''Until you go back to the Profile Manager and start up in your regular profile, your desktop shortcut should fire up the new profile.'' Fonts look any better? Note: When returning to the Profile Manager, you might be tempted to use the Delete Profile button on your new test profile. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong. ---- You can replace Firefox's program files without disturbing your settings using this '''Clean Reinstall''' procedure: (1) Download a fresh installer for Firefox 33 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) If applicable, exit out of Firefox or make sure it is fully terminated in Task Manager. (3) Rename the folder ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement in your fonts? Note: Some recently installed plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * C:\Program Files\OldFirefox\Plugins * C:\Program Files\OldFirefox\browser\plugins
FredMcD
  • Top 10 Contributor
4246 izisombululo 59404 izimpendulo
Kuphostiwe

Type about:preferences#content<Enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn onAllow Web Sites To Choose Their Own.

Type '''about:preferences#content'''<Enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on'''Allow Web Sites To Choose Their Own.'''
cor-el
  • Top 10 Contributor
  • Moderator
17475 izisombululo 157940 izimpendulo
Kuphostiwe

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB

Umnikazi wombuzo

The settings for allowing web sites to choose their own fonts was already checked. Thanks for the suggestion.

The settings for allowing web sites to choose their own fonts was already checked. Thanks for the suggestion.

Umnikazi wombuzo

Here's a screenshot of what I see when I open a site such as The Chicago Tribune.

Here's a screenshot of what I see when I open a site such as The Chicago Tribune.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59404 izimpendulo
Kuphostiwe

Is this the only site you have the problem?

Check out; http://www.tvguide.com/Listings/

Is this the only site you have the problem? Check out; '''http://www.tvguide.com/Listings/'''
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

For this page: http://affiliate.zap2it.com/tvlistings/ZCGrid.do?aid=chi

The header bar text uses Arial or sans-serif and the body uses Helvetica, Arial or sans-serif (the standard sans-serif font would be the one defined in the Fonts dialog, under "Western" or possibly "Other Languages").

To see which font your Firefox is applying, you can right-click the set of boxes, and choose Inspect Element (Q). An Inspector panel will open up with some HTML source code selected. On the right side, look for the row of subheadings Rules, Computed, Fonts, Box Model and click Fonts. (Screen shot example attached.) Does this reveal anything unusual, i.e., anything other than Arial or Arial Bold?

For this page: http://affiliate.zap2it.com/tvlistings/ZCGrid.do?aid=chi The header bar text uses Arial or sans-serif and the body uses Helvetica, Arial or sans-serif (the standard sans-serif font would be the one defined in the Fonts dialog, under "Western" or possibly "Other Languages"). To see which font your Firefox is applying, you can right-click the set of boxes, and choose Inspect Element (Q). An Inspector panel will open up with some HTML source code selected. On the right side, look for the row of subheadings Rules, Computed, Fonts, Box Model and click Fonts. (Screen shot example attached.) Does this reveal anything unusual, i.e., anything other than Arial or Arial Bold?