Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The start page on Firefox on my laptop (Windows 7) appears to have been hijacked. Phony logo w/ cartoon character appears w/ "check me." Anyone seeing this ?

  • 4 uphendule
  • 3 zinale nkinga
  • 198 views
  • Igcine ukuphendulwa ngu Philson

more options

When opening a new session with Firefox, the standard Firefox logo appears briefly, then the screen changes to a very distorted version of the same logo, with a small cartoon character saying "click me". Anyone seeing this ? This just started on my laptop in the last day or so. Thanks for any suggestions to get rid of this junk !

Isisombululo esikhethiwe

That Click Me game is part of the Humble Mozilla Bundle promotion on the default Home Page [about:home], that loads from the Mozilla servers in the "Brand Logo" (DIV) section of about:home. A feature that was first used in Firefox 29 [IIRC] just prior to the start of the Olympic Games.

Also, part of that promotion is addressed in the "Snippet" below the Search Container on the about:home page.


If you want to block the "Brand Logo" section (and the "snippet" below the Search container) from ever being seen again, you can install Stylish and this UserStyle. https://userstyles.org/styles/104673/about-home-hide-snippets-and-hide-brand-logo

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

Isisombululo Esikhethiwe

That Click Me game is part of the Humble Mozilla Bundle promotion on the default Home Page [about:home], that loads from the Mozilla servers in the "Brand Logo" (DIV) section of about:home. A feature that was first used in Firefox 29 [IIRC] just prior to the start of the Olympic Games.

Also, part of that promotion is addressed in the "Snippet" below the Search Container on the about:home page.


If you want to block the "Brand Logo" section (and the "snippet" below the Search container) from ever being seen again, you can install Stylish and this UserStyle. https://userstyles.org/styles/104673/about-home-hide-snippets-and-hide-brand-logo

more options

Thank you for solving what turned out to be more of a nuisance than an actual problem ! I'm not sure what purpose the Mozilla Humble Bundle served, but I would have expected someway to block or delete it from the Firefox start-up page...wishful thinking, I guess. I installed Stylish and the recommended UserStye and that fixed the problem. I'll do the same to my desktop. Thanks again !

more options

If you prefer not to see the snippets on the about:home page or otherwise experience problems with a snippet then you can set the browser.aboutHomeSnippets.updateUrl pref to an empty string on the about:config page. Delete the storage\persistent\moz-safe-about+home folder in the Firefox profile folder with Firefox closed ("3-bar" Firefox menu button > Exit/Quit) to remove snippets stored in IndexedDB and make Firefox use a default snippet set. You can reset the browser.aboutHomeSnippets.updateUrl pref via the right-click context menu to the default value to re-enable the snippets and make Firefox recreate the moz-safe-about+home folder. You need to close and restart Firefox after changing the value of the browser.aboutHomeSnippets.updateUrl pref.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thank you for the additional suggestions. As noted above, I installed Stylish and am now good to go. I very much appreciate you taking the time to respond to my inquiry.