Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When open Mozilla it displays only an a blank screen,the only visual is the minimise and close buttons

  • 5 uphendule
  • 15 zinale nkinga
  • 3847 views
  • Igcine ukuphendulwa ngu YavorNanev

more options

Operating system:Windows 7 64.b Ram 2gb: This bug is generated every time i try to open Mozilla ,it looks like its open a window but everything is black or with some.Everything is invisible except the closing and minimise button at the top-right corner!Its just like a big blank window with three buttons!

Isisombululo esikhethiwe

as described above, you will get into safemode when you press the shift-key while firefox is launching... have you tried the route through the graphics driver update yet?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

hello YavorNanev, did you post your troubleshooting information from the affected computer or from a different device? other users with this problem all had an embedded intel hd3000 graphics card with an old driver present. in case this also applies to you, here would be a link to update the driver, which in turn should also address the black firefox problem: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23764 (for win7 64 bit)

in case this doesn't solve the issue or does not apply to your system, start firefox into safemode by pressing the shift key while the application is launching & disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Hi Philip The thing is that i don't have access to any option of the mozilla,safe mode also doesn't work.They haven't been any updates on the computer just start behave that way

more options

Also not getting any crash or bug report!

more options

Isisombululo Esikhethiwe

as described above, you will get into safemode when you press the shift-key while firefox is launching... have you tried the route through the graphics driver update yet?

more options

safemode didnt make any diffrent,But changing the graphics driver did the job.Problem solve !!Thanks Phil!!