Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Initial input focus with NoScript is broken

  • 4 uphendule
  • 2 zinale nkinga
  • 101 views
  • Igcine ukuphendulwa ngu jscher2000

more options

I have no Firefox add-ons except NoScript. Flash is not installed on Firefox. I use Firefox for safe surfing. When I want to watch video, I use IE11. My PCs are W-7 64-bit.

For quite a few Firefox releases, the focus behavior was correct: when Firefox was started or when the home button was clicked (my home is a search engine), I would see my search engine with the input focus, i.e. the cursor was present in the search box. However, a few releases ago the cursor focus was lost. This current behavior is different than all other browsers.

I do not know if this is a Firefox bug or a NoScript bug, but I suspect that NoScript is in the top-five most popular add-ons so the Mozilla community should care. Please fix this bug in the next release. It is annoying to start Firefox and start typing something into the search box only to then realize that the typing is being sent to the bit bucket instead.

Isisombululo esikhethiwe

In order to place the focus in a form control, a web page uses JavaScript. Otherwise, Firefox's focus is on the page body as a whole which, as you point out, can't accept any input.

If you are already allowing scripts for the search engine site, then check the NoScript button to see whether the search engine also pulls in scripts from a content distribution network or other secondary domain and test whether allowing scripts from that host resolves the issue.

If you do not want to allow the site's scripts, you may need a workaround such as a Greasemonkey userscript which can set the focus where you want it after the page loads.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

You might want to ask about that issue in the NoScript support forum. http://forums.informaction.com/viewforum.php?f=3

more options

Isisombululo Esikhethiwe

In order to place the focus in a form control, a web page uses JavaScript. Otherwise, Firefox's focus is on the page body as a whole which, as you point out, can't accept any input.

If you are already allowing scripts for the search engine site, then check the NoScript button to see whether the search engine also pulls in scripts from a content distribution network or other secondary domain and test whether allowing scripts from that host resolves the issue.

If you do not want to allow the site's scripts, you may need a workaround such as a Greasemonkey userscript which can set the focus where you want it after the page loads.

more options

Thanks, I did that.

more options

For reference: https://forums.informaction.com/viewtopic.php?f=7&t=20184

Also, baroque-quest, Giorgio is waiting for the URL of the search engine site for further testing.