Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox opens at startup on my iMac. It is not in startup items and not checked to open at login.

  • 11 uphendule
  • 6 zinale nkinga
  • 5389 views
  • Igcine ukuphendulwa ngu sohonlaw

more options

There aren't really any more details to add. I have checked everything I can think of in the Library folder and thrown out anything I thought might affect it. Firefox is not set as my default browser.

I have read many threads of people having this problem both here and on the Apple Support site. Most seem to be solved by unchecking "Open at Login" in the Dock icon or removing Firefox from the Startup Items in the System Preferences. Neither applies here. HELP!!! I like Firefox and use it from time to time but it seems the only way to stop this behavior is to remove it from my computer, which I will do if a solution can't be found.

Thanks for your efforts.

Isisombululo esikhethiwe

Hello did you check also in System Preferences > Users & Groups > your account > Login Items ?

thank you

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (11)

more options

Isisombululo Esikhethiwe

Hello did you check also in System Preferences > Users & Groups > your account > Login Items ?

thank you

more options

Yes. I checked all of the places I could think of and those mentioned in the threads I read. Login items is what I was referring to when I said, "removing Firefox from the Startup Items in the System Preferences".

This is a nefarious problem!

more options

Can you uninstall the Bitdefender extension you have ?

Also can you stop Bitdefender for a while and check it again ?

see : https://support.mozilla.org/en-US/questions/955935#answer-427835

thanks

Okulungisiwe ngu ideato

more options

Did you check the Doc icon?

  • Control-click on the Firefox Dock icon and uncheck 'Open at Login'
more options

Did you read my post?

more options

Update: yesterday I went through the System Folder and deleted anything that said Forefox, from Application Support to Profile. Anything I could find. The BitDefender Extension is not installed.

I turned off my computer (2009 iMac) and went home for the night.

This morning I turned on the computer and Firefox started during the boot process. If this can't be fixed reasonably soon I will simply delete it from my machine for good. Firefox is not that important to me but I would really like to solve this!

more options

OK, is anyone out there able to make sense of the Log File in Console (Mac OSX Mavericks). I can give you a copy of the boot log file as it pertains to Firefox if that will help

more options

Does this also happen if Firefox is not the default browser?

Safari > Preferences > General > Default Web Browser > "Default web browser"

more options

Firefox is not, was not and will not be the default browser

more options

Try to uninstall Firefox (drag to the Trash) and reinstall Firefox.

You can find the full version of the current Firefox 32.0.3 release in all languages and for all Operating Systems here:

more options

I tried that before I posted here. I'm not a novice but I don't know how to read the boot log, which is where I suspect the answer lies. I can send it to someone who does know how to make sense of it but that's about all.