Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox opens with blank page

  • 5 uphendule
  • 10 zinale nkinga
  • 11979 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Firefox is set to open to my home page (Mozilla Firefox Start Page) which shows the search page with the Bing search engine set. However, every time it opens TWO PAGES...the home page and with a blank "NEW TAB" page on top that offers to assist me with a pop-up message that says "Click on the + button and add your favorite sites". This is also happening EVERY time that a new window is supposed to open...my new information is displayed on the first tab, but the second tab (as stated above) opens on top. I have verified that there is no extra information set in the properties link.. it shows "C:\Program Files (x86)\Mozilla Firefox\firefox.exe". I have also verified that no other toolbars are installed or opening. I have verified that the "Tools/Options/General Tab is set to "Show My Home Page" and that the Home Page is set to "Mozilla Firefox Start Page". This is a brand newly built machine with Win 7 Home Premium Serv Pack 1, 64 bit operating system installed. Please help me shut off the blank page...all I want to see when I click on Firefox or open a second window is the main start page with my search engine option. Thank you.

Isisombululo esikhethiwe

I tried that, and was not successful. So, I went into the safe mode again, and I clicked on the reset button. Yes, it did remove my themes and reset things from scratch, but my bookmarks were still there. I also had to reset my preferences. But, it fixed the problem quickly and I am back up and running. Thank you.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I started it in safe mode with the add ons disabled. It did not give me the 2nd blank tab...just the home tab I had set. I further went to the appearance and reset it to default. It came right back.

more options

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

more options

Isisombululo Esikhethiwe

I tried that, and was not successful. So, I went into the safe mode again, and I clicked on the reset button. Yes, it did remove my themes and reset things from scratch, but my bookmarks were still there. I also had to reset my preferences. But, it fixed the problem quickly and I am back up and running. Thank you.

more options

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences