Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When installing, get "Error! Can't initialize plug-ins directory"

  • 6 uphendule
  • 10 zinale nkinga
  • 24634 views
  • Igcine ukuphendulwa ngu williamcraig5

more options

Began having problems when opening Firefox and trying to make Firefox the default browser. Windows 7 updated, AVG up-to-date and virus scans clean, MalwareBytes up-to-date and scans clean. Troubleshooting finally caused me to uninstall and try for clean install ... normal Windows 7 uninstall process successful. Made sure Firefox folder in "Program Files" was deleted. Downloaded "DownloadApp_1_7_5_198_Setup" (29,442 KB) from Mozilla website and run ... get "Error! Can't initialize plug-ins directory. Please try again later."

Isisombululo esikhethiwe

http://www.bleepingcomputer.com/forum.../error-cant-initialize-plug-ins-directory-please-try-again-later/ What are the permissions on your Temp folder?

Looking to see if there are a few cases on this, brb.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

hello, the file name you have referenced is no genuine download from mozilla. please only download firefox from the official location at mozilla.org!

more options

I went back to Mozilla and downloaded both the stub and the full version .... now I get "can not create temp folder archive". I have cleared out the temp folder and run the install as the administrator. Any other ideas for me?

more options

According to this forum thread this could be a problem with the NSIS installer and could indicate a problem with the temp folder

Error! Can't initialize plug-ins directory. - Winamp Forums:

The plug-ins directory is a temporary directory for the installer.

Try to delete the Windows temp folder (%TMP% or %TEMP%)

more options

Deleted \Windows\Temp and rebooted. Same result. Windows recreates the temp file on reboot so I deleted folder and retried. Same result. Then I tried unchecking the "read only" attribute and retried install. Same result. Also tried to do same with \Users\Bill\AppData\Temp with same results.

more options

Isisombululo Esikhethiwe

http://www.bleepingcomputer.com/forum.../error-cant-initialize-plug-ins-directory-please-try-again-later/ What are the permissions on your Temp folder?

Looking to see if there are a few cases on this, brb.

more options

Thank you guig2! Followed your bleepingcomputer.com link above and found the problem was my permissions on C:\Users\Bill\AppData\Local/Temp. It was not "Full Control" for my User or Administrator. Updated the two lines to permit full control for folder, subfolder and files. Ran perfect.