Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I open .dll files automatically with Adobe Reader through Firefox?

  • 12 uphendule
  • 4 zinale nkinga
  • 3382 views
  • Igcine ukuphendulwa ngu everon9

more options

Hi,

When I print eBay labels through Firefox, a .dll file is downloaded. This used to open automatically in Adobe Reader, but now it opens as a text document in TextEdit, so I have to manually open Adobe Reader, change options to show "all files", and then locate the .dll file and open it.

When I try to change the default application in Firefox preferences, I can't find anything with the content type "dll".

Is there a way to have Firefox automatically open .dll files with Adobe Reader?

Any help would be much appreciated, thanks!

Steve

Isisombululo esikhethiwe

Sorry for the delay, but yes, just quit out of Firefox so that the mimeTypes.rdf file is released.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (12)

more options

Normally a DLL is not a document but a program code file.

If you rename the downloaded file to a .pdf extension, will it open correctly?

more options

Hi, thanks for the reply.

The thing is: I am able to open the .dll file correctly in Adobe Reader (even with a .dll extension). It's just that when the file is downloaded through Firefox it, by default, opens in TextEdit, and this means I have to go through several extra steps to open it in Adobe Reader. So I wanted to find out if there was a way to have the file open automatically in Adobe Reader when I downloaded it.

If this info is any help - I did try changing the extension to ".pdf" and it changed the icon to a PDF file, and then the changed file also opened correctly in Adobe Reader.

If the .dll file is a program code, could it contain the PDF in it? And if so, is there a way to get Firefox to recognize it as that and open it accordingly (in Adobe Reader)?

Please let me know if you have any further advice, thanks.

more options

Regarding the name, it could be that the script on the server pushing the PDF to Firefox has a .dll extension and the server is not sending a better filename in a format Firefox can understand.

But the bigger problem is that Firefox does not judge the nature of a download from the file extension, but from the "content type" indicated by the server. If you set Firefox to "Ask me every time" for where you save downloads, Firefox should display information about the content type the server is sending. You could make that change temporarily using the Preferences dialog. See: Startup, home page, tabs, and download settings.

Okulungisiwe ngu jscher2000

more options

Hi,

OK so I changed my Firefox download preferences to "Ask me every time", and then went back to the webpage where I click to download the file and downloaded it.

The same thing happened though - it downloaded the file and then opened automatically through TextEdit. No dialogue box came up asking me where I wanted to save the file.

Maybe it isn't treating it as a download for some reason? Although that would be strange because the file is going directly to my "download" folder.

Steve

more options

In the dialog with the Open/Save/Cancel choices, how does Firefox describe the file?

more options

There was no dialog box that opened up.

It just saved the file in my downloads and opened it through TextEdit automatically.

more options

After you set Firefox to ask you where to save downloads, you normally should see a dialog with Open/Save/Cancel as options. If that does not appear, Firefox might be set to "Save File" in the Preferences dialog, Applications section. I think that will bypass the dialog.

Is this happening on a site where you could post a link to the page where you're downloading, or is an account required?

more options

There is no dialog with Open/Save/Cancel that comes up after I change the General Preference to "Always ask me where to save files".

I checked the Preferences, Application section (which is where I started off trying to fix the problem), and changed anything that had "save file" to "always ask", but it still just downloaded the file automatically.

Here's the link to page (below), but it is something you have to sign into (eBay account).

http://shiptrack.ebay.com/ws/eBayISAPI.dll?BulkShippingLabelConfirm&bulkGrpId=9519739502

I could take a screenshot but don't think that would help?

more options

Hmm, that's strange. Firefox's settings file for download actions might have become corrupted. You can rename the file and have Firefox build a new one from scratch. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show in Finder" button

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > "power" button
  • menu bar: I'm not sure what this is on Mac

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again.

If you still get the same behavior, I think you are stuck renaming the file with a .pdf extension for now.

more options

I got the first part done just fine.

However, when you say:

" Leaving that window open, switch back to Firefox and Quit, either:

   "3-bar" menu button > "power" button
   menu bar: I'm not sure what this is on Mac 

"

do you just mean to quit Firefox (as in Firefox > Quit Firefox)? Or to also do something else first?

more options

Isisombululo Esikhethiwe

Sorry for the delay, but yes, just quit out of Firefox so that the mimeTypes.rdf file is released.

more options

That worked, thank you!

I quit out of Firefox, renamed the file like you said, restarted my computer, and restarted Firefox.

When I went to download a label, Firefox asked me which application to use, and I picked Adobe Reader. I also checked the box to make that the default. This automatically opened the file in AR, and then when I did it the next time it worked perfectly.

Again, thank you so much for your help with this - although it's just a bit of time here and there saved it really adds up!

Take care!

-Steve