Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Frequently get error "Firefox is already running" when using desktop shortcuts to web sites

  • 29 uphendule
  • 5 zinale nkinga
  • 235 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I love Firefox and don't want to use another browser. I frequently get the error "Firefox is already running". I even created a batch file to kill the process so I can re-launch it. There has to be a real solution.

The key to my issue is... I use shortcuts to web sites from my desktop. This is what seems to trigger the error (but not every time). Please don't tell me to stop using shortcuts; that isn't a solution.

I am using Windows 8.1 64 bit Firefox 32.0.1 (had this same problem with all prior versions too)

Any help is appreciated!

All Replies (9)

more options

I created a new profile. The error occurred only minutes later.

It seems the only "solution" is to not use desktop shortcuts to web sites.

That's not much of a solution.

more options

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences<Enter> in the address bar

Select Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

I am still getting this error constantly. None of the suggestions have helped. Anything else I can do?

more options

From what I have been reading from other posts on this forum, the issue may be caused by the clear history settings. It was suppose to have been fixed in v30.

Type about:preferences#privacy <Enter> in the address bar.

The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

This is not a cure but will make it easier if Firefox locks up in Windows. https://support.mozilla.org/questions/997866 {web link}

more options

Is the workaround of keeping a Firefox window open at all times not working any more?

more options

The issue seems to be resolved with the latest FF update 33.1! Not holding my breath, but it hasn't happened since.

more options

Hey there, my computer still does that same exact thing with Firefox. Now I'm using the new firefox light & it still pops up saying firefox is still running. I'll tell you that the only thing that works for me is restarting windows 8.1 all over each time! That is the only way I've found to resolve it. One more thing I can tell you to try,I just thought of;is to go on windows website and find win. support & ask them a question. Just think up a way to put the issue into a question! Like,why is windows telling me my browser is already running?

 Ok, that's all I can tell ya! Good luck with that.
more options

Hi Mrdiversified52, by the way, "Firefox Light" is not an official Mozilla product.

When you get the error, does firefox.exe still appear in the Windows Task Manager? You can display it by pressing Ctrl+Shift+Esc. I believe in Windows 8 the relevant tab is now called "Details" (and the Processes tab is similar to the Applications tab in earlier versions of Windows). There you should be able to terminate firefox.exe if necessary to be able to restart it without restarting the entire OS.

more options

This is not a cure but will make it easier if Firefox locks up in Windows. https://support.mozilla.org/questions/997866 {web link}

  1. 1
  2. 2