Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Frequently get error "Firefox is already running" when using desktop shortcuts to web sites

  • 29 uphendule
  • 5 zinale nkinga
  • 235 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I love Firefox and don't want to use another browser. I frequently get the error "Firefox is already running". I even created a batch file to kill the process so I can re-launch it. There has to be a real solution.

The key to my issue is... I use shortcuts to web sites from my desktop. This is what seems to trigger the error (but not every time). Please don't tell me to stop using shortcuts; that isn't a solution.

I am using Windows 8.1 64 bit Firefox 32.0.1 (had this same problem with all prior versions too)

Any help is appreciated!

All Replies (20)

more options

Separate issue;

Your System Details shows;

Installed Plug-ins

Shockwave Flash 15.0 r0 Shockwave Flash 14.0 r0

Having more than one version of a program may cause issues.

Flash is notorious for not cleaning out the older version as part of an update. Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac Then reinstall the latest version.

Shockwave Flash v15.0.0.152 http://get.adobe.com/flashplayer/



fixed last link as it incorrectly was for shockwave player instead of the proper flash player. If it has shockwave in a adobe link then that is not Flash.

Okulungisiwe ngu James

more options

From what I have been reading from other posts on this forum, the issue may be caused by the clear history settings. It was suppose to have been fixed in v30.

Type about:preferences in the address bar and press Enter.

Select Privacy.

The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

Is there anything special about the way you start Firefox? For example, are you using any command-line arguments to select a particular profile or to run multiple instances of Firefox, or are you using a sandboxing program?

more options

Thanks for the replies.

FredMcD: I removed/reinstalled flash, and configured my clear history. Will report back by the end of day.

jscher2000: no, nothing out of the ordinary

more options

FredMcD: in the clear history settings, it doesn't remember checkmarks "Turn on ONLY Cache and Form And Search History leaving the others off". It reverts to all checked and then I have to retype logins/password every time I restart the browser.

more options
more options

FredMcD: I reset my FF, but the problem persists. It doesn't remember those checkboxes. In fact, if I uncheck them, click Ok and immediately re-open that screen, they're all checked again!

UPDATE: I did it from the main GUI, and it worked. Will let you know if it helps the original issue.

Okulungisiwe ngu danenglish2

more options

Did you delete the localstore.rdf file?

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

more options

Fred: Ok I just deleted it. Let's see how it goes now.

UPDATE: So far, so good. The localstore thing might have solved it!

Okulungisiwe ngu danenglish2

more options

Fred: Your solution seems to be working. This will save me from endless frustration. Thank you. I owe you a beer.

more options

Glad to hear. Sometimes the biggest problems need a little fix, but finding the fix is a bigger problem.

more options

Update: The error has popped up again a couple of times, but much less often.

more options

Well, its a start.

From what I have been reading from other posts on this forum, the issue may be caused by the clear history settings. It was suppose to have been fixed in v30.

Type about:preferences<Enter> in the address bar.

Select Privacy.

The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

This is not a cure but will make it easier if Firefox locks up in Windows. https://support.mozilla.org/questions/997866 {web link}

more options

My Clear History settings are what you suggest. This has helped quite a bit. The error only occurs 2-3 times/day instead of 10+ now.

more options

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Note that using "Clear history when Firefox closes" to clear the disk cache will disable the disk cache and this section is no longer present on the about:cache page.

Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

You can check for issues caused by plugins and set all plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page (plugins are not affected by Firefox Safe Mode)

more options

I had to undo the solution. I am getting this error frequently again.

Any other suggestions?

more options

Does this problem occur when Firefox appears to be fully closed, or when Firefox has at least one window open? Or both?

more options

@jscher2000 it always appears to be fully closed. still occurs with zero plugins enabled.

more options

So Firefox apparently is not shutting down cleanly. This could be due to something stalling or hanging during the settings file cleanup process, or perhaps an interaction with another program. Possibly something in this article might help: Firefox hangs or is not responding - How to fix.

As a temporary workaround, can you keep a Firefox window open (minimized) rather than closing the program each time?

more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

  1. 1
  2. 2