Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

No 5.1 surround sound (he-aac with html5)

  • 8 uphendule
  • 10 zinale nkinga
  • 375 views
  • Igcine ukuphendulwa ngu guigs

more options

We produced 5.1 he-aac files http://www.kulturradio.de/_testfolder_fuer_alle/5-1.html

In Firefox only a stereo-downmix is to carry. IE, Chrome and Safari on Mac do the right - transfering the 5.1 signal to the sound card.

Any Ideas? Is this a known FF bug?

I currently use FF 33 but has never really performed at pevious versions.

Thanks for your help Sebastian

All Replies (8)

more options

I just tested it in version 35 Nightly, something changed :-)

https://nightly.mozilla.org/

more options

It seems to work but the sound is awfull at my notebook. It sounds blurred. Maybe the decoder is 5.1 but buggy now?

more options

Hi Sebastian_Fisahn, There was a new Web Audio too that was added to the Web Console in this new version. But the website you are referring to is using JW player.

I also tried to research the JW support and it seems it only on Windows? http://support.jwplayer.com/customer/.../search?q=surround+sound+firefox

IF you download the audio and play it on a local computer, does the sound quality change?

more options

I do not know if this is a current bug, there is no harm in filling one however.

Please see [bugzilla.mozilla.com] and their link for how to file a good first bug.

more options

I played our native channel-test-file via download here: http://www.kulturradio.de/programm/feature/5punkt1/willkommen.html

(the file: http://media.rbb-online.de/kul/5punkt1/5_1_Mehrkanal_Test.mp4)

The new audio-console is "Waiting for an audio-context to be created".

I'm afraid FF don't like he-aac covered in mp4??

Then I have tested with "aac" or "m4a" file-endings also with no success. http://media.rbb-online.de/kul/test/gut_aac_multichannel-5_1.m4a http://media.rbb-online.de/kul/test/gut_aac_multichannel-5_1.aac

Best Sebastian

more options

Sebastian, I am seeing the same in the audio console. I will follow up on this. See https://bugzilla.mozilla.org/show_bug.cgi?id=1074308 may need to investigate this more.

For the he-acc, this may be related https://bugzilla.mozilla.org/show_bug.cgi?id=875644

It does look like it is an issue in FF, and the bugs will be able to further investigate a fix. In the meantime, however are there other formats of the audio that could be offered for Firefox users?

more options

I also tested 5.1 ogg/vorbis without any success. I'm sure that i googled, thats a already known FF bug.

Best Sebastian

more options

I believe I have misinterpreted the expected behavior of the Web Audio console.