X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox using much CPU; how to find the offending tab/URL?

Kuphostiwe

My Firefox 32 .0 is using lots of CPU, and it frequently goes into "not responding" state. I restarted in safe mode, and the same condition happened. Is there any way for me to determine what tab(s)/URL(s) are causing the problem? I really do not want to start closing each of my many tabs and windows one-by-one to see which one(s) might be causing the problem. I am running Windows 7 Professional 32-bit. Thanks.

--Barry Finkel

My Firefox 32 .0 is using lots of CPU, and it frequently goes into "not responding" state. I restarted in safe mode, and the same condition happened. Is there any way for me to determine what tab(s)/URL(s) are causing the problem? I really do not want to start closing each of my many tabs and windows one-by-one to see which one(s) might be causing the problem. I am running Windows 7 Professional 32-bit. Thanks. --Barry Finkel

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; Tablet PC 2.0; rv:11.0) like Gecko

Eminye Imininingwane

HaShTaG 0 izisombululo 1 izimpendulo
Kuphostiwe

Hello bsfinkel, Maybe it will help you Firefox uses too many CPU resources - How to fix

Hello bsfinkel, Maybe it will help you [https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix Firefox uses too many CPU resources - How to fix]

Umnikazi wombuzo

That URL did not help. Let me explain my situation. I have many tabs in eight or nine windows. Some of these tabs have been open in the past, but I have not re-opened them since the last restart. I have told FF not to go to every tab URL when it restarts. This morning at 8:30 I updated to 32.0.2 (from 32.0.1), and I restarted om safe mode. When FF restarted, it was using about 40% of the CPU, and it frequently went into "not responding" state. It was in this state when I left the house at 10AM to go to a meeting. When I returned at 3PM, FF was running normally, using around 15% of the CPU. I believe that there is one (or maybe more) web site that is causing the problem, and I would like to know how to diagnose what is happening when FF is using 40% of the CPU. I really do not want to close tabs, one-by-one, and restart FF to see if that tab was causing the problem.

--Barry Finkel

That URL did not help. Let me explain my situation. I have many tabs in eight or nine windows. Some of these tabs have been open in the past, but I have not re-opened them since the last restart. I have told FF not to go to every tab URL when it restarts. This morning at 8:30 I updated to 32.0.2 (from 32.0.1), and I restarted om safe mode. When FF restarted, it was using about 40% of the CPU, and it frequently went into "not responding" state. It was in this state when I left the house at 10AM to go to a meeting. When I returned at 3PM, FF was running normally, using around 15% of the CPU. I believe that there is one (or maybe more) web site that is causing the problem, and I would like to know how to diagnose what is happening when FF is using 40% of the CPU. I really do not want to close tabs, one-by-one, and restart FF to see if that tab was causing the problem. --Barry Finkel
finitarry 251 izisombululo 3421 izimpendulo
Kuphostiwe

If you bookmark the tabs in each window in their own folder, you can then test each one by closing it, and still be able to get those collections of tabs back again easily.

If you bookmark the tabs in each window in their own folder, you can then test each one by closing it, and still be able to get those collections of tabs back again easily.
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

Type about:preferences in the address bar and press enter. Select General. Under Tabs, turn on Don’t load tabs until selected.

Type '''about:preferences''' in the address bar and press enter. Select '''General.''' Under '''Tabs,''' turn on '''Don’t load tabs until selected.'''
finitarry 251 izisombululo 3421 izimpendulo
Kuphostiwe

The OP would still have to shut down tabs initially before loading again. After bookmarking all the tab collections, if a window was closed with no appreciable drop in CPU load, then that one was not the problem, so keep trying that until the CPU load decreases markedly. Launch a new window and open the bookmarks in that folder again and activate them one by one.

The OP would still have to shut down tabs initially before loading again. After bookmarking all the tab collections, if a window was closed with no appreciable drop in CPU load, then that one was not the problem, so keep trying that until the CPU load decreases markedly. Launch a new window and open the bookmarks in that folder again and activate them one by one.

Umnikazi wombuzo

As to FredMcD's reply, I already have that set. Only ONE tab is loaded in wach window after a restart.

This afternoon at 16;46 my computer experienced a BSOD with a reboot. After the reboot, I left the computer to watch the news and then "60 Minutes". When I came back to the machine at 17:00, Firefox was running normally.

Then at 20:10 I had another BSOD (again, I was trying to run some updated software I had downloaded earlier in the afternoon). When Firefox started, it again was using 50% of the CPU and was, for the most part, "not responding" (whatever that means in Microsoft terms). This makes it very hard to close tabs, as when FF becomes responsive, it is responsive only for a few seconds. Between 20:30 and 21:06, I closed one tab each in eight windows. Nothing changed. At 21:17 I tried to close the entire one-tab window that contained the URL

http://www.samsung.com/us/support/SupportOwnersFAQPopup.do?faq_id=FAQ00000180&fm_seq=89794

and the window would not disappear. When FF became responsive, I tried to change that URL to www.google.com, but nothing would change. At 21:30 I again clicked to close that window, and nothing happened. At 21:36 I checked, and FF had gone into its normal state, using 2 to 16% of the CPU.

What do I do next to diagnose this problem?

As to FredMcD's reply, I already have that set. Only ONE tab is loaded in wach window after a restart. This afternoon at 16;46 my computer experienced a BSOD with a reboot. After the reboot, I left the computer to watch the news and then "60 Minutes". When I came back to the machine at 17:00, Firefox was running normally. Then at 20:10 I had another BSOD (again, I was trying to run some updated software I had downloaded earlier in the afternoon). When Firefox started, it again was using 50% of the CPU and was, for the most part, "not responding" (whatever that means in Microsoft terms). This makes it very hard to close tabs, as when FF becomes responsive, it is responsive only for a few seconds. Between 20:30 and 21:06, I closed one tab each in eight windows. Nothing changed. At 21:17 I tried to close the entire one-tab window that contained the URL http://www.samsung.com/us/support/SupportOwnersFAQPopup.do?faq_id=FAQ00000180&fm_seq=89794 and the window would not disappear. When FF became responsive, I tried to change that URL to www.google.com, but nothing would change. At 21:30 I again clicked to close that window, and nothing happened. At 21:36 I checked, and FF had gone into its normal state, using 2 to 16% of the CPU. What do I do next to diagnose this problem?
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

I went to; http://www.samsung.com/us/support/SupportOwnersFAQPopup.do?faq_id=FAQ00000180&fm_seq=89794

Black and White Laser Printers: Can I Recycle Old Toner Cartridges?

Page loaded no problem. It looks like a normal page, no graphics.

Have you tried; Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

I went to; '''http://www.samsung.com/us/support/SupportOwnersFAQPopup.do?faq_id=FAQ00000180&fm_seq=89794''' ''Black and White Laser Printers: Can I Recycle Old Toner Cartridges?'' Page loaded no problem. It looks like a normal page, no graphics. Have you tried; '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

When is the last time you checked for mal-ware on your system?

Troubleshoot Firefox Issues Caused By Malware {web link}

When is the last time you checked for mal-ware on your system? '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Troubleshoot Firefox Issues Caused By Malware]''' {web link}

Impendulo Ewusizo

I run MSE as my basic anti-malware. I also run WebRoot Security Anyware (WRSA) and Spyiit Search & Destroy. None of them has found any malware. Yesterday I ran MalwareBytes Anti-Malware (MBAM), and it did not find anything. I ran RogueKiller, but before it finished and gave me results, it told me that there was a new version available. I downloaded it and it caused a BSOD when I started it. That was the BSOD before I watched "60 Minutes" last night. I tried it again, and the second BSOD "allowed" me to do the debugging I did last night.

I do not want to disable flash, as the weather.gov radar image I have open needs flash to display the radar loop images.

--Barry Finkel

I run MSE as my basic anti-malware. I also run WebRoot Security Anyware (WRSA) and Spyiit Search & Destroy. None of them has found any malware. Yesterday I ran MalwareBytes Anti-Malware (MBAM), and it did not find anything. I ran RogueKiller, but before it finished and gave me results, it told me that there was a new version available. I downloaded it and it caused a BSOD when I started it. That was the BSOD before I watched "60 Minutes" last night. I tried it again, and the second BSOD "allowed" me to do the debugging I did last night. I do not want to disable flash, as the weather.gov radar image I have open needs flash to display the radar loop images. --Barry Finkel
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

Turn flash off for a little while. Is there still a problem?

Turn flash off for a little while. Is there still a problem?

Umnikazi wombuzo

A status update since my last post 09/22 09:04AM:

09/23 14:28 Firefox crashed; crash report sent.

            bp-9197d45e-750b-479e-a050-41a612140924 9/23/2014 10:39 PM

09/23 22:39 Restart Firefox when I returned home. 09/24 06:14 Firefox crashed; crash rport sent. 09/24 08:05 Restart Firefoc when I got to the machine.

            bp-32fcaaa1-288c-48d2-b918-93cbb2140924 9/24/2014  8:10 AM

09/24 08:30 Entire system is running slowly; many tasks (including

                Firefox) using lots of CPU; I have no idea why.

09/24 13:09 System is still slow ==> reboot.

            After reboot, Firefox using lots of CPU

09/24 15:10 When I returned to the computer, FF was behaving OK. 09/24 16:00 I left my computer for a few days 09/24 21:35 Firefox crashed; crash report sent (when I returned).

            bp-31f5f3d3-5d00-480d-b339-81c232140928 9/27/2014  9:09 PM

09/27 21:09 I got back to my computer, sent the crash report, and

                 restarted Firefox.  I got the "this is embarrasing"
                 screen.

09/27 22:17 Firefox using 16-45% CPU 09/28 03:59 Firefox crashed; crash report sent.

            bp-46a485d8-a7c5-4954-96aa-eaf9d2140928 9/28/2014  7:29 AM

09/28 07:29 Send crash report and resart Firefox ==> "Embarrasing" 09/38 07:33 Upgrade Firefox from 32.0.2 to 32.0.3 09/28 08:05 Firefox using 16-45% CPU 09/28 09:27 Firefox behaving normally 09/28 14:08 Firefox crashed; crash report sent.

            bp-414f9829-9bbc-443f-9589-a2efb2140929 9/28/2014  8:04 PM

09/28 20:04 Send crash report & restart Firefox ==> "Embarrasing" 09/28 20:27 Firefox using 50% CPU; window "about:crashes" not responding 09/28 21:42 Firefox still unresponsive and using 44% CPU 09/28 21:45 Firefox seems to be responsive again.

How do I tell what is causing Firefox to use all the CPU? Is there any tracing I can run while Firefox is in its CPU-consuming state?

I have not yet looked at any of the crash reports

A status update since my last post 09/22 09:04AM: 09/23 14:28 Firefox crashed; crash report sent. bp-9197d45e-750b-479e-a050-41a612140924 9/23/2014 10:39 PM 09/23 22:39 Restart Firefox when I returned home. 09/24 06:14 Firefox crashed; crash rport sent. 09/24 08:05 Restart Firefoc when I got to the machine. bp-32fcaaa1-288c-48d2-b918-93cbb2140924 9/24/2014 8:10 AM 09/24 08:30 Entire system is running slowly; many tasks (including Firefox) using lots of CPU; I have no idea why. 09/24 13:09 System is still slow ==> reboot. After reboot, Firefox using lots of CPU 09/24 15:10 When I returned to the computer, FF was behaving OK. 09/24 16:00 I left my computer for a few days 09/24 21:35 Firefox crashed; crash report sent (when I returned). bp-31f5f3d3-5d00-480d-b339-81c232140928 9/27/2014 9:09 PM 09/27 21:09 I got back to my computer, sent the crash report, and restarted Firefox. I got the "this is embarrasing" screen. 09/27 22:17 Firefox using 16-45% CPU 09/28 03:59 Firefox crashed; crash report sent. bp-46a485d8-a7c5-4954-96aa-eaf9d2140928 9/28/2014 7:29 AM 09/28 07:29 Send crash report and resart Firefox ==> "Embarrasing" 09/38 07:33 Upgrade Firefox from 32.0.2 to 32.0.3 09/28 08:05 Firefox using 16-45% CPU 09/28 09:27 Firefox behaving normally 09/28 14:08 Firefox crashed; crash report sent. bp-414f9829-9bbc-443f-9589-a2efb2140929 9/28/2014 8:04 PM 09/28 20:04 Send crash report & restart Firefox ==> "Embarrasing" 09/28 20:27 Firefox using 50% CPU; window "about:crashes" not responding 09/28 21:42 Firefox still unresponsive and using 44% CPU 09/28 21:45 Firefox seems to be responsive again. How do I tell what is causing Firefox to use all the CPU? Is there any tracing I can run while Firefox is in its CPU-consuming state? I have not yet looked at any of the crash reports
cor-el
  • Top 10 Contributor
  • Moderator
17346 izisombululo 156791 izimpendulo
Kuphostiwe

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

Signature OOM | small (Out Of Memory)

Firefox uses too much memory (RAM) - How to fix This article describes how to make Firefox use less memory to make it run faster and prevent crashes.

Signature OOM | small (Out Of Memory) '''[https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram Firefox uses too much memory (RAM) - How to fix]''' This article describes how to make Firefox use less memory to make it run faster and prevent crashes.
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.'''

Umnikazi wombuzo

As for add-ons - I did run for a while in safe mode, and the problem still existed. I would run in safe mode if I could guarantee that depressing the Shift key while starting Firefox would start in safe mode. I have done this a number of times, and most of the time Firefox does NOT start in safe mode. When FF starts in regular mode, I do not want to restart it in safe mode via the Help menu because at that time I want to use Firefox and not spend all of my time debugging the problem.

--Barry FInkel

As for add-ons - I did run for a while in safe mode, and the problem still existed. I would run in safe mode if I could guarantee that depressing the Shift key while starting Firefox would start in safe mode. I have done this a number of times, and most of the time Firefox does NOT start in safe mode. When FF starts in regular mode, I do not want to restart it in safe mode via the Help menu because at that time I want to use Firefox and not spend all of my time debugging the problem. --Barry FInkel

Umnikazi wombuzo

This is what I did earlier today:

09/29 11:16 uncheck "use hardware acceleration": 09/29 11:25 Using "Help" menu, restart in safe mode. 09/29 11:37 Firefox still running; I/O Other Bytes count increasing;

                        I/O Read Bytes and I/O Write Bytes unchanging

09/29 11:39 Cancel Firefox via taskmgr

                     Restart with the "Shift" key ==> "Embarrassing screen" &
                        NOT in safe mode
                     Using "Help" menu, restart in safe mode ==>"Embarrassing"
                     Firefox seemed to be running normally with occasional
                     50% CPU spikes.

09/29 14:00 Firefox seems to be running normally with occasional 17%

                     CPU spikes.

These tests violated my rule - only make one change at a time. I made that rule when I was a systems programmer working with IBM mainframe operating systems for 25+ years. The next time I restart Firefox, I will do so in regular mode.

--Barry Finkel

This is what I did earlier today: 09/29 11:16 uncheck "use hardware acceleration": 09/29 11:25 Using "Help" menu, restart in safe mode. 09/29 11:37 Firefox still running; I/O Other Bytes count increasing; I/O Read Bytes and I/O Write Bytes unchanging 09/29 11:39 Cancel Firefox via taskmgr Restart with the "Shift" key ==> "Embarrassing screen" & NOT in safe mode Using "Help" menu, restart in safe mode ==>"Embarrassing" Firefox seemed to be running normally with occasional 50% CPU spikes. 09/29 14:00 Firefox seems to be running normally with occasional 17% CPU spikes. These tests violated my rule - only make one change at a time. I made that rule when I was a systems programmer working with IBM mainframe operating systems for 25+ years. The next time I restart Firefox, I will do so in regular mode. --Barry Finkel
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/viruses/disinfection/5350 Anti-Rootkit Utility - TDSSKiller] * [http://general-changelog-team.fr/en/downloads/viewdownload/20-outils-de-xplode/2-adwcleaner AdwCleaner] (for more info, see this [http://www.bleepingcomputer.com/download/adwcleaner/ alternate AdwCleaner download page]) * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!

Umnikazi wombuzo

The article "Firefox uses too much memory (RAM) - How to fix" did not give me anything else to do. I have no "appearances" outside of the default theme 32.0.3. I have turned off hardware acceleration. And I am running in safe mode. I will let Firefox run to see if it runs out of memory. Now (9/29 14:16) Process Explorer says that Firefox is using 532.2 Mb Private storage.

--Barry Finkel

The article "Firefox uses too much memory (RAM) - How to fix" did not give me anything else to do. I have no "appearances" outside of the default theme 32.0.3. I have turned off hardware acceleration. And I am running in safe mode. I will let Firefox run to see if it runs out of memory. Now (9/29 14:16) Process Explorer says that Firefox is using 532.2 Mb Private storage. --Barry Finkel
FredMcD
  • Top 10 Contributor
4194 izisombululo 58530 izimpendulo
Kuphostiwe

After you use the scanners (above) try; Start your Computer in safe mode. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;

If running, turn your computer off. Remove any disks and thumb drives that are in your hard drives or ports. Now start your computer but also;

Windows; Press the <F8> key repeatedly. Mac: Hold down the Shift key. Linux; Using the command line, Linux/Unix computers can be booted into various run levels that determine which resources are loaded. For example, "runlevel 1" is typically the equivalent to Windows and Mac safe modes.

When the Boot menu is displayed, release the key you were pressing. You must now choose what mode you want. The most used are;

  • Safe Mode; The computer runs with only a minimum set of programs.
  • Safe Mode With Networking; Same as above, but with internet access.
After you use the scanners (above) try; Start your '''Computer''' in safe mode. Then start Firefox. Try '''Safe''' web sites. Starting The Computer In Safe Mode; If running, turn your computer off. Remove any disks and thumb drives that are in your hard drives or ports. Now start your computer but also; '''Windows; '''Press the <F8> key repeatedly. '''Mac: '''Hold down the Shift key. '''Linux; '''Using the command line, Linux/Unix computers can be booted into various run levels that determine which resources are loaded. For example, "runlevel 1" is typically the equivalent to Windows and Mac safe modes. * Source; '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Safe Mode; Free Online Encyclopedia]''' When the '''Boot''' menu is displayed, release the key you were pressing. You must now choose what mode you want. The most used are; * Safe Mode; The computer runs with only a minimum set of programs. * Safe Mode '''With '''Networking; Same as above, but with internet access.

Umnikazi wombuzo

A Status Update - I was letting FF run until either I needed to reboot or it crashed. Today FF crashed.

19058ca6-b01f-462a-9325-1a83450bfa78

FF will not open that crash report; it sites with the spinning circle. I assume that the crash was due to out-of-memory, as the private storage usage had increased from 960 Mb in 10/01 to 1.4 Gb 25 minutes before the crash.

FF restarted NOT in safe mode, and it was not using a lot of CPU, as it had been in the past. And I had not closed a lot of tabs. The last restart of FF had two changes - uncheck "use hardware acceleration" and safe mode. I conclude that the high CPU usage at restart was due to "use hardware acceleration". I am not sure what that setting does, so I cannot say much about how it would cause lots of CPU usage for 1.5 hours after restart. I do run PC Wizard, which displays core temperatures and core usage on my screen. It shows the temperature of the GFX (graphics) card, but its display of "GFX Load" is always 0%.

Note that I have not installed and tried all of the anti-malware software referenced in a previous reply because I believed that the FF CPU usage was not due to malware on my computer.

I will monitor FF private storage usage, and when it gets large, I will close some tabs that I no longer need.

--Barry Finkel

A Status Update - I was letting FF run until either I needed to reboot or it crashed. Today FF crashed. 19058ca6-b01f-462a-9325-1a83450bfa78 FF will not open that crash report; it sites with the spinning circle. I assume that the crash was due to out-of-memory, as the private storage usage had increased from 960 Mb in 10/01 to 1.4 Gb 25 minutes before the crash. FF restarted NOT in safe mode, and it was not using a lot of CPU, as it had been in the past. And I had not closed a lot of tabs. The last restart of FF had two changes - uncheck "use hardware acceleration" and safe mode. I conclude that the high CPU usage at restart was due to "use hardware acceleration". I am not sure what that setting does, so I cannot say much about how it would cause lots of CPU usage for 1.5 hours after restart. I do run PC Wizard, which displays core temperatures and core usage on my screen. It shows the temperature of the GFX (graphics) card, but its display of "GFX Load" is always 0%. Note that I have not installed and tried all of the anti-malware software referenced in a previous reply because I believed that the FF CPU usage was not due to malware on my computer. I will monitor FF private storage usage, and when it gets large, I will close some tabs that I no longer need. --Barry Finkel