X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I avoid the proxy credentials popup?

Kuphostiwe

Lately, the proxy authentication dialog keeps popping up every now and then. This is incredibly annoying: even though my credentials are remembered, I still have to click OK, sometimes a few times before I can proceed viewing the website. Sometime the dialog from a website on a different (background) tab pops up and disturbs me while viewing another website.

My setup is as follows: Currently, I'm using Firefox 31.0 on openSUSE 13.1 I have a cntlm proxy set up and set as my system's proxy (http_proxy and KDE's proxy settings) at http://localhost:3128 which works correctly in other applications. I tried using two settings in FF: 'Use system proxy settings' and 'Manual proxy configuration'. I tried both, checking and unchecking 'Do not prompt for authentication if password is saved' I tried a suggestion from the web, setting signon.autologin.proxy to true. I tried some proxy addon which promised to solve the issue.

None of these worked in preventing that incredibly annoying proxy authentication dialog from poppin g up (although, at times it *seemed* that I didn't get if for a longer time (that was after making the about:config modification mentioned above)).

I remember times on this machine when that did not happen, but I can't remember what I've changed that it's broken now (probably it was some FF update?).

Please, help me! I'm lost and it makes my FF very uncomfortable to use. I need some suggestions on how to configure FF in a way that *should* work, i.e. which combinations of the settings I mentioned above, or other ones I haven't considered yet.

Lately, the proxy authentication dialog keeps popping up every now and then. This is incredibly annoying: even though my credentials are remembered, I still have to click OK, sometimes a few times before I can proceed viewing the website. Sometime the dialog from a website on a different (background) tab pops up and disturbs me while viewing another website. My setup is as follows: Currently, I'm using Firefox 31.0 on openSUSE 13.1 I have a cntlm proxy set up and set as my system's proxy (http_proxy and KDE's proxy settings) at http://localhost:3128 which works correctly in other applications. I tried using two settings in FF: 'Use system proxy settings' and 'Manual proxy configuration'. I tried both, checking and unchecking 'Do not prompt for authentication if password is saved' I tried a suggestion from the web, setting signon.autologin.proxy to true. I tried some proxy addon which promised to solve the issue. None of these worked in preventing that incredibly annoying proxy authentication dialog from poppin g up (although, at times it *seemed* that I didn't get if for a longer time (that was after making the about:config modification mentioned above)). I remember times on this machine when that did not happen, but I can't remember what I've changed that it's broken now (probably it was some FF update?). Please, help me! I'm lost and it makes my FF very uncomfortable to use. I need some suggestions on how to configure FF in a way that *should* work, i.e. which combinations of the settings I mentioned above, or other ones I haven't considered yet.

Isisombululo esikhethiwe

localhost is in my no proxies list and it has been there for some time during which I didn't see that issue.

However, I finally seem to have gotten rid of that problem - yay!

Out of sheer desperation, I tried the option 'Auto-detect proxy settings for this network' (which I *think* I had tried in the past but it did not work then) and I checked 'Do not prompt for authentication if password is saved' with the result of no more being annoyed with (seemingly random) popping up of proxy authentication dialogs!

I don't know why the Manual proxy and the Use system proxy do show that behavior, but I'm happy that I can use Firefox again undisturbed now.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.
  • Mime Type x-skype for Skype Buttons
  • Plugin for Installing Applications (new)

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

When available, please update to version 32. I am pretty sure there was something about cookies, but that would be a typical support response so forget that.

Some initial thoughts:

  • Did you remove the localhost from network.proxy.no_proxies_on
  • Do you have a certificate associated with the proxy that has an expiration?
  • These were the security updates for version 32: https://www.mozilla.org/security/know.../firefox.html
  • Is there a specific time interval that this happens?

Did that fix anything?

When available, please update to version 32. I am pretty sure there was something about cookies, but that would be a typical support response so forget that. Some initial thoughts: * Did you remove the localhost from network.proxy.no_proxies_on * Do you have a certificate associated with the proxy that has an expiration? * These were the security updates for version 32: [https://www.mozilla.org/security/known-vulnerabilities/firefox.html] * Is there a specific time interval that this happens? Did that fix anything?

Isisombululo Esikhethiwe

localhost is in my no proxies list and it has been there for some time during which I didn't see that issue.

However, I finally seem to have gotten rid of that problem - yay!

Out of sheer desperation, I tried the option 'Auto-detect proxy settings for this network' (which I *think* I had tried in the past but it did not work then) and I checked 'Do not prompt for authentication if password is saved' with the result of no more being annoyed with (seemingly random) popping up of proxy authentication dialogs!

I don't know why the Manual proxy and the Use system proxy do show that behavior, but I'm happy that I can use Firefox again undisturbed now.

localhost is in my no proxies list and it has been there for some time during which I didn't see that issue. However, I finally seem to have gotten rid of that problem - yay! Out of sheer desperation, I tried the option 'Auto-detect proxy settings for this network' (which I *think* I had tried in the past but it did not work then) and I checked 'Do not prompt for authentication if password is saved' with the result of no more being annoyed with (seemingly random) popping up of proxy authentication dialogs! I don't know why the Manual proxy and the Use system proxy do show that behavior, but I'm happy that I can use Firefox again undisturbed now.
DigiKeyJohn14 0 izisombululo 1 izimpendulo
Kuphostiwe

If you are using FF35 Try entering just your domain name under ntlm trusted uris http://insidepages.mysite.com would be .mysite.com

If you are using FF35 Try entering just your domain name under ntlm trusted uris http://insidepages.mysite.com would be .mysite.com

Okulungisiwe ngu DigiKeyJohn14