Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When I close the Firefox window I get the warning that I'm closing multiple tabs. The tabs come back on restart.

  • 10 uphendule
  • 1 inale nkinga
  • 457 views
  • Igcine ukuphendulwa ngu tpayton1

more options

When I have more than on tab open and I use the x in the window to close the browser I get the warning that I'm closing x number of tabs. If I click continue it closes the window. This was always all I had to do to end the session and close everything. Now when I restart Firefox all of the tabs that were closed in the previous session appear on the new page. If this is expected why do I get the warning. This just started happening. Version is 32.

Isisombululo esikhethiwe

Did you remove the user.js file because that file is the main cause of the problem?

With the extensions.autoDisableScopes pref you can control from what locations extensions can be installed. This is one of the built-in files that set the default values of preferences (you can inspect such files via the location bar).

  • resource:///defaults/preferences/firefox.js
// Disable add-ons that are not installed by the user in all scopes by default.
// See the SCOPE constants in AddonManager.jsm for values to use here.
pref("extensions.autoDisableScopes", 15);
  • resource://gre/modules/AddonManager.jsm
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (10)

more options

It May Have Been Accidently Made Your Homepage And May Need Changing! If Need Help With That Reply Back!

From Mitch Happy Firefoxing!

more options

Home Page is Firefox Start Page default.

more options

Thee problem you're facing is due to change in the settings. Follow the below steps to get rid of the problem you mentioned:

Go to Tools, click on Options

Under the General panel, there is an option that says When Firefox starts, check if you have selected it as Show my windows and tabs from last time

If so, then change it to either

 i. Show my home page or 

ii. Show blankpage

Voila ! there is your solution.

Okulungisiwe ngu neosp

more options

It is set to show my home page. Home page is Mozilla Firefox Start Page.

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

user_pref("extensions.autoDisableScopes",14);user_pref("browser.sessionstore.resume_session_once", true);

If this is the cause of the problem, how should I correct it?

more options

Yes that second user_pref line is the cause of the problem.

user_pref("browser.sessionstore.resume_session_once", true);

You can delete the user.js file and possibly reset the other pref extensions.autoDisableScopes on the about:config page.

more options

I renamed the pref files, still no change.

What is this telling me? extensions.autoDisableScopes;14

more options

Isisombululo Esikhethiwe

Did you remove the user.js file because that file is the main cause of the problem?

With the extensions.autoDisableScopes pref you can control from what locations extensions can be installed. This is one of the built-in files that set the default values of preferences (you can inspect such files via the location bar).

  • resource:///defaults/preferences/firefox.js
// Disable add-ons that are not installed by the user in all scopes by default.
// See the SCOPE constants in AddonManager.jsm for values to use here.
pref("extensions.autoDisableScopes", 15);
  • resource://gre/modules/AddonManager.jsm
more options

I renamed user.js, that fixed the problem. Thank you.