Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox always behaves as if it has crashed

  • 1 baphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu FredMcD

more options

Whenever I start Firefox it behaves as though it has crashed in the previous session, showing me the session restore screen. This happens if I close Firefox by clicking on the 'x' button, and also if I go to the menu and click 'Exit Firefox'.

I want my previous tabs to be restored (especially because I have some tab groups opened), and my options are configured accordingly. However, the session should be restored normally, not as if Firefox had crashed.

What could be the problem?

Whenever I start Firefox it behaves as though it has crashed in the previous session, showing me the session restore screen. This happens if I close Firefox by clicking on the 'x' button, and also if I go to the menu and click 'Exit Firefox'. I want my previous tabs to be restored (especially because I have some tab groups opened), and my options are configured accordingly. However, the session should be restored normally, not as if Firefox had crashed. What could be the problem?

Isisombululo esikhethiwe

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.