X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

New Firefox (31.0 on Mac), not askign for password

Kuphostiwe

If i log into our Corporate SharePoint server, i get 401 Unauthorized. The reason why is because when i go to the URL (local FQDN), this version of firefox does not ask me for a username/password. It just goes right to 401 Unauthorized.

I need to make firefox ask me for a user/pass.

I have searched the forums and cannot find anything. I have tried to changed the privacy settings under preferences for the History, and when i change it to "Use Custom Settings for History", when i restart firefox, its changed back to "Remember History"

This has caused our company a lot of grief when they all updated to this latest version and now no one can login. We have told them to use a different browser for now.

This use to work in all previous versions of FireFox.

Please help.

Thanks

If i log into our Corporate SharePoint server, i get 401 Unauthorized. The reason why is because when i go to the URL (local FQDN), this version of firefox does not ask me for a username/password. It just goes right to 401 Unauthorized. I need to make firefox ask me for a user/pass. I have searched the forums and cannot find anything. I have tried to changed the privacy settings under preferences for the History, and when i change it to "Use Custom Settings for History", when i restart firefox, its changed back to "Remember History" This has caused our company a lot of grief when they all updated to this latest version and now no one can login. We have told them to use a different browser for now. This use to work in all previous versions of FireFox. Please help. Thanks

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Shockwave Flash 14.0 r0
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Version 5.4.2.18903
  • Microsoft Lync 2010 Meeting Join Plug-in
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.30514.0
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.07
  • Web based SlingPlayer for streaming from Slingbox
  • 15.8.0.0
  • LogMeIn remote control components
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi dpetree, Thank you for your question I understand that after the update there are large number of users that have the settings for history changed as well as an issue connecting to a sharepoint server. 401 unauthorized:

  1. Do you have a certificate that enables authorization to the FQDN?
  2. Have you configured alternate mappings in central administration of SharePoint? and have you tried the FQDN with a port number?
  3. Please clear the cache of the site by going to "about:permissions" and looking for the FQDN and click "forget this site"

On the Firefox ESR version there are some methods for forcing all of the installations on a sub network to change a preference. More info on this can be seen here.

Fix problems connecting to websites after updating Firefox is also a helpful set of troubleshooting for further help.

Hi dpetree, Thank you for your question I understand that after the update there are large number of users that have the settings for history changed as well as an issue connecting to a sharepoint server. 401 unauthorized: #Do you have a certificate that enables authorization to the FQDN? #Have you configured alternate mappings in central administration of SharePoint? and have you tried the FQDN with a port number? # Please clear the cache of the site by going to "about:permissions" and looking for the FQDN and click "forget this site" On the Firefox ESR version there are some methods for forcing all of the installations on a sub network to change a preference. More info on this can be seen [https://www.mozilla.org/en-US/firefox/organizations/faq/ here]. [[Fix problems connecting to websites after updating Firefox]] is also a helpful set of troubleshooting for further help.

Umnikazi wombuzo

Thank You for your reply

So, all users are able to get in with any other browser. They use to be able to get in with Firefox. But, it seems that only the Mac version, it will not ask for a password. Because it does not ask for a password, i get the 401 unauthorized.

now, if i roll back to an older version, it will pop up and ask me for a password. Its only with 31 does it not ask me.

Im not sure if its something with the Mac or this version on the Mac. Just looking for some guidance on where to start troubleshooting.

Thank You for your reply So, all users are able to get in with any other browser. They use to be able to get in with Firefox. But, it seems that only the Mac version, it will not ask for a password. Because it does not ask for a password, i get the 401 unauthorized. now, if i roll back to an older version, it will pop up and ask me for a password. Its only with 31 does it not ask me. Im not sure if its something with the Mac or this version on the Mac. Just looking for some guidance on where to start troubleshooting.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Troubleshooting thoughts:

  1. Are pop ups enabled for the site on the Mac? (3bar menu > preferences > Content > Exceptions... )
  2. And what were the results of troubleshoot step #3?
  3. Possibly checking about:config to check to see if any pop up preferences are changed there.
  4. Also default is a new profile to make sure it is not something there: Profile Manager - Create, remove, or switch Firefox profiles
Troubleshooting thoughts: # Are pop ups enabled for the site on the Mac? (3bar menu > preferences > Content > Exceptions... ) # And what were the results of troubleshoot step #3? # Possibly checking about:config to check to see if any pop up preferences are changed there. # Also default is a new profile to make sure it is not something there: [[Use the Profile Manager to create and remove Firefox profiles]]

Umnikazi wombuzo

Thank You for your suggestions.

I went and created a new FireFox profile, but i have the same results


Also, Block Popups are off on my mac. Pop Ups are allowed. I have no other Popup Blocker on my Mac.

Thank You for your suggestions. I went and created a new FireFox profile, but i have the same results Also, Block Popups are off on my mac. Pop Ups are allowed. I have no other Popup Blocker on my Mac.

Okulungisiwe ngu dpetree

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi dpetree, With exhausted basic troubleshooting steps I would recommend providing an example of the fqdn. The certs_override.txt file stores the preferences for certificates that are stored in the browser. It is possible to rename that file and restart Firefox in the new profile visit the site again.

Is it possible to provide an example link to where this is happening?

Is it an encryption type? HTTPS Everywhere may do the trick?

Hi dpetree, With exhausted basic troubleshooting steps I would recommend providing an example of the fqdn. The certs_override.txt file stores the preferences for certificates that are stored in the browser. It is possible to rename that file and restart Firefox in the new profile visit the site again. Is it possible to provide an example link to where this is happening? Is it an encryption type? HTTPS Everywhere may do the trick?

Okulungisiwe ngu guigs