Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Preferences Settings keep reseting! Tried everything - Multiple Windows User Accts.

  • 22 uphendule
  • 4 zinale nkinga
  • 234 views
  • Igcine ukuphendulwa ngu okayhelplease

more options

I do not understand - I have read the 'preferences not saved' knowledge base. I have several Windows user accounts, preferences will switch back to default including default tabs. This happens when I log off or restart windows. Prefs will be saved if closing out browser and restarting but if logging off/restarting they reset. Have deleted all mozilla folders in a user account (not the admin acct), reinstalled fresh and still happens. I am thinking I must also have to uninstall/reinstall FF by logging into the Windows administrator account??

Okulungisiwe ngu okayhelplease

All Replies (20)

more options

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


Okulungisiwe ngu cor-el

more options

Your instructions confuse me a little because you said to first delete the firefox program then reinstall firefox but first to delete the firefox program before reinstalling. Which is it? And do I need to perform this in the windows administrator account? If so, will this fix the problem with all my other seperate windows user accounts? I cannot afford to mix flash cookies.

If I follow through right this is the order per your instructions - Please alert me if I am off I'm performing this now, Thank-you.

  • I will log into the ADMIN USER account in Windows.
  • Next I will DELETE the firefox program? This is where another part I am lost at. There are many different directories firefox is located, which do I delete? You have C:/programs86/mozilla, C:/users/appdata/local/mozilla, C:/users/appdata/roaming/mozilla... and so on..

I understand that I need to fresh reinstall - I have already COPIED over each windows user account profile folder to a flash drive so to keep cookies as long as flash cookies do not mix with other user profiles or delete. Just lost on the correct procedure/steps. SORRY.

By the way - I do have AdvanceSystemCare but never used the surfing protection. Only used the network browser optimization feature. Restored these modifications. Nothing.

Also, before your reply, I did a fresh install after uninstalling while logged under a windows user account and did not fix problem. I logged off and then logged into admin account and their is no firefox. I have created a mess for myself. Mozilla still exist within other windows user accounts. I do have Waterfox installed, by the way, if this makes any matter.

Okulungisiwe ngu okayhelplease

more options

Sorry, that should have been deleting the Firefox program folder to remove possible leftover files.

more options

I don't follow through but I'm going reinstall in admin windows account without touching any other user account profiles. when software is installed or uninstalled it will usually create seperate installs for all the other user accounts in windows.

?

lolol after uninstalling inside the windows admin account and then reinstalling, same problem. I did NOT delete anything, though. I then uninstalled again through the windows control panel. I then logged off and logged into a seperate windows user acct. and I still have firefox installed there. I thought it would be uninstalled throughout all user accounts. I am glad it didn't - since the purpose is to keep everything seperate from each user account. Settings just will not save. I can operate windows fine. Never learned code or dos commands or help develop anything mozilla so 123 steps would help me outta the mess and into teh fix=)

Okulungisiwe ngu okayhelplease

more options

Advanced SystemCare has a feature to zap your Firefox settings when you reboot Windows. It is separate from the Surfing Protection add-on, but I don't know the name. See: https://support.mozilla.org/questions/1007917?page=2

more options

jscher2000 - yesterday I used their uninstaller for uninstalling firefox. I just did NOT feel safe with following through fully with their 'DEEP SCAN' option to "SCAN FOR AND DELETE LEFT OVER FILES", I only checked the 1st box "mozilla files" but did not check the box for the deletion of the registry left over files.

I was afraid of it deleting each users cookies file. Also, it seemed to only effect the admin account, none of the other user accounts where this problem I am having is still alive.

Any settings changed inside advance system care under the main windows admin account does nothing for other user accounts. I logged off the admin, logged into a seperate user account and the settings that I unchecked were still checked off! Also, cannot make any changes inside ASCare if not logged into the admin account. wow.

Okulungisiwe ngu okayhelplease

more options

Okay now this is becoming out of control. deleted ALL mozilla folders/directories in the windows ADMIN account and the other windows user account that I need to use and CANNOT MUST NOT LOSE flash cookies in!

I have cleaned, in both user accounts, using CCleaner. I have reinstalled fresh copy of firefox 31 only in the user (non admin acct.) and STILL the same problem. When I changed some preferences inside firefox for a test, exit firefox, restarted the computer, opened/started firefox, it opened to a blank page like it did remember the prefs I modified, one of them being 'open a blank page at startup', and it did open a blank page for about a second and then BAM the other tab appears next to it and both are loading the default. Opened settings and everything is reset! wtf

What is causing this? So now I gotta try to uninstall advance system care, huh? why? But I'm going to now - ill update real soon.

Okulungisiwe ngu okayhelplease

more options

Advanced System Care and CCleaner are both known to cause a variety of problems with Firefox. Keep them disabled until you can learn how to use each of them without them interfering with Firefox normal operations. Or don't use either of them at all.

more options

the-edmeister - I just uninstalled advanced system care pro 7.2. Did NOT make a difference. Still failed to save my prefs. What now?

In the meantime I am going to look in the folders for <n>.js files and also RESET firefox.

Okulungisiwe ngu okayhelplease

more options

Hi okayhelplease, you wrote:

When I changed some preferences inside firefox for a test, exit firefox, restarted the computer, opened/started firefox, it opened to a blank page like it did remember the prefs I modified, one of them being 'open a blank page at startup', and it did open a blank page for about a second and then BAM the other tab appears next to it and both are loading the default. Opened settings and everything is reset! wtf

What's in that other tab? Sometimes the content helps point to the culprit.

more options

Welp sorry to break this to most here - Uninstalling both ASC and CCleaner (very well known good software, which hasn't created any problem for me, except for their driver booster and anti-malware difficulties in the past. I know how to use both to the part where I know I never EVER would change or elect to even try out the browser protection crap or any malware crap. Thats not what I use them tools for. I am the one to stay in control of my computer and browser, not a software. I don't use virus software, either. But I know how and do perform checks here n there like with SUPErantispyware and through windows.

I have RESET firefox and this problem is STILL happening. Here's the extra bonus; Before I said I would log-off or do a computer restart, come back open firefox and prefs would be reset/problem still existing. Well I don't even have to do that. I can change some prefs, close out the browser, open it and settings/prefs will be remembered. But if I close out the browser a second time, back to default prefs/default homepage. Without rebooting the laptop.


ANy other suggestions?

more options

I take that back below when I said prefs are saved until the 2nd time I reopen firefox. Now prefs are forgotten/back to default on the 1st close/reopen.

more options

And here are the contents of profile folder..

more options

Scanned my whole computer=pass.

Rebooted, logged onto the main ADMIN windows account, opened up firefox and the preferences were finally saved, yay!! Blank home page, and all.

Then...

Closed out firefox, opened it again to make sure. NOPE. Back to default everything!

Does anyone have a for sure solution???

I must keep flash cookies per each user's windows acct.

Okulungisiwe ngu okayhelplease

more options

I have wasted several hours, deleted most my software as well as all the firefox folders to the point where my windows user profiles got corrupted and saved them with a system restore.

Why on earth would settings preferences not be saved?? Worse, why is it still happening after uninstalling the software and installing a fresh copy?? I don't recall this happening with any other software unless keys are involved.

This is a joke! So this is looking like my only choice is to reinstall Windows? And lose ALL my important accounts and, my job, even? Because now I am in danger of losing flash cookies!

Please if anyone of the many people who can help, please do. I am waiting.

more options

Hi There, If I am not wrong then the flash cookies would have been saved here: Assuming windows is installed in C Drive C:\Users\%USER_ACCOUNT%\AppData\Roaming\Macromedia\Flash Player\macromedia.com\support\flashplayer\sys backup all folders/files from here. [- Flash Cookies]

I think its safe then to uninstall Firefox and delete its folders along with registry key/entries.

The following registry path is where Mozilla Firefox info is contained: HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla Firefox

more options

Don't forget to backup your user profiles: [Restore & Restore user profiles for firefox]

Okulungisiwe ngu Mohsin A.

more options

Mohsin A.-

Thank-you much for the help! I located and backed-up.

After detecting problems with a browser hijacker 'go.speedbit', I cleaned the computer with adwcleaner, malwarebytes and, hitman pro using the admin account. One of those cleaned the firefox reg. keys and well been at this nonstop it's 5am now the tiredness has diminished my memory..can't remember at what point I reinstalled firefox but, anyways It seems firefox is now remembering preferences only in the windows admin account.

The problem still exists at the other user accounts - firefox will not remember any prefs. My internet explorer and chrome seem corrupted. Both browser STILL hijacked with the speedbit search after using the above cleaners!! Because I deleted the profile folders in one user account, the one which still cannot save preferences, it gave a error of: 'firefox profile is either missing or corrupted', and couldn't start the firefox browser. But when I executed the firefox.exe file in the C:\program folder, firefox started right up. I guess it created a new profile. So I tried to change settings in firefox, closed it and restarted it, again, same problem.

Logged-off that account, logged-onto main admin account to check if firefox is still able to remember its prefs there. All is okay.

Since I was able to at least get the admin account to somehow remember prefs there - and the problem still exist in the other user account (have more accounts haven't checked those yet) I'm confident someone has really knows whats going on, hopefully.

What happens if I make another windows user account and copy over the flash cookies folder and firefox cookies to the new profile? Will I be good to go?

(below screenshot is 'speedbit' search provider hijacking IE, still)

Okulungisiwe ngu okayhelplease

more options

I am not familiar with switching between different user accounts. Are you exiting out of Firefox in between switching, or does Windows isolate the two running instances of Firefox?

Also, do you lose any other data, such as new bookmarks, when you exit Firefox and start it again?


When you are in the profile that isn't working correctly, could you check that the prefs.js file actually is getting updated? To open a window to check on that, you can use either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch Windows Explorer window listing the files and folder in your currently active Firefox profile.

While you're here, please glance at the address bar to make sure it is under the User you're currently using, and not under a different user.

If you set the view to Details you should be able to see the modified date and time for prefs.js. Most settings you change in Firefox will be written to this file fairly soon after you make the change.

For example, you could open Options and change a checkbox on the Tabs preferences, OK that, then watch for the file to get updated. Anything?

more options

jscher2000 -

For a while everything were working just fine - now I checked if the file were being written and it is not. Earlier the last 2 days all good, now it's back to the problem.

Weird...the prefs.file will get written to 1 time then it won't get written to if I close-out ff, start/restart ff. This is when I tried another master reset right now. Another thing I noticed many times and, while in main Admin account, was that the prefs.file properties will show that the file isn't shared although I'm authorized to make changes (something like that), then after another close-restart of ff, I looked at the properties of the prefs.file and now it shows it's fully shared with the other windows user accounts. I don't know if this is normal, I keep seeing many files/folders are shared with other users and, after choosing to share with 'nobody' option - changes right back. Some folders are hidden and not shared like, C:program data.. Oh and cookies.sqlite.wal and the other cookies.files are showing shared to some users and, 'everyone' with full control.

Um ..lol.. I've been had for the longest time now been using a registry entry file named, 'GrantAdminFullControl.reg' , Use it often but, NOT anywhere even near folders that are not to be mixed! Use it in other windows user accounts like with a microsoft game..

Checking the profile owner in firefox shows correct for each user, by theway. I also deleted something within the ff profile folders that caused my win.user accounts to be corrupt, failing to open - System restore fixed it but now if I create a new standard windows user account or turn on the guest account, says "user profile can't be opened..."

Okulungisiwe ngu okayhelplease

  1. 1
  2. 2