Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Yahoo does not display properly in firefox 31.0 but will show correctly in IE. How do I get this fixed?

  • 26 uphendule
  • 5 zinale nkinga
  • 552 views
  • Igcine ukuphendulwa ngu jscher2000

more options

I have cleared cookies and cache, updated Firefox to 31.0 but it still keeps happening. I have even accessed my Yahoo email through the ATT site because I have an sbcglobal.net address. Nothing works. I can see my Yahoo email just fine through Internet Explorer but would prefer to do all of my internet related work via Firefox. I have no idea what to do.

All Replies (6)

more options

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if any content is blocked and has a file size 0 (zero).

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Hi avidreadr, the URL in the screen shot on the left is m.yahoo.com, which is the mobile-optimized version of the site. I don't know why you would see that in your desktop browser, unless Yahoo is unable to identify Firefox properly.

Oh, hold on, look how your Firefox identified itself to this site:

Mozilla/5.0 (masking-agent; rv:13.0) Gecko/20100101 Firefox/13.0.1

The operating system information is being blocked by the "Masking Agent" extension. Can you make an exception for Yahoo? If not, you may need to disable or remove that extension.

more options

So I have to figure out which add on is causing the problem and try to make an exception for yahoo. I will try that thank you.

more options

I have removed the plug in/application you referred to and restarted firefox but it's still showing the older version of Yahoo. I do not know what to do. I'm seriously considering chucking it all in and moving off of Firefox. Does anyone have any other suggestions?

more options

User Agent Mozilla/5.0 (masking-agent; rv:13.0) Gecko/20100101 Firefox/13.0.1 This is what's causing the problem. I have removed/disabled the application masking agent but Firefox is still not working right.

more options

Hi avidreadr, I'm not sure how Masking Agent works, but it might have changed a setting in Firefox that isn't changed back when you disable or remove it. To check that, see this article:

Websites say that Firefox is outdated or incompatible even though it's the latest version

  1. 1
  2. 2