Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My files were converted into Firefox HTML Documents how do I convert them back to their original type?

  • 11 uphendule
  • 56 zinale nkinga
  • 3403 views
  • Igcine ukuphendulwa ngu JoeHill55

more options

Some of my files were converted to Firefox HTML Documents. I don"t know how. Can they be converted back to their original format like Excel, Word or PDF files^

Isisombululo esikhethiwe

Is that only the icon that you see for them or did the file extension change to .html?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 12

All Replies (11)

more options

Isisombululo Esikhethiwe

Is that only the icon that you see for them or did the file extension change to .html?

more options

I have this problem - when I go to open a pdf file received as an attachment to an email, when I go to open the pdf it says the file is Firefox HTML document. Doesn't open as a pdf but only as an HTML file

more options

Is this really an HTML file or a PDF file with the wrong file extension or is it a PDF file with the Firefox icon?

If there is currently no file handler application that handles PDF files then the Firefox updater/installer registers Firefox as the default application to handle PDF file. Bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has

Okulungisiwe ngu cor-el

more options

Could you try the "Open With" solution in this thread: https://support.mozilla.org/questions/1012877

more options

The file extension changed to Firefox HTML Document

more options

Hi JoeHill55

What is your Operating System?

This is likely only a problem with the way the shortcut looks (its icon) and the default action (possibly opens in Firefox).

You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file. If this doesn't change the icon to the icon of that application on the desktop then change this icon via other means. On Windows XP you can check the Windows Control Panel:

  • Control Panel > Folder Options > File Types > New > PDF > Advanced > Associated File Type:"Adobe PDF reader"

You can use the registry editor to check some keys.

  • Registry Editor:
    HKEY_CURRENT_USER\Software\Classes\.pdf\
    HKEY_CLASSES_ROOT\.pdf

Remove the FirefoxHTML value of the Default key and leave an empty value of that key. That should allow you to set another application as the default to handle PDF files via the open with dialog.

more options

First and for most, I am NOT a tech savy individual, what you have explained as a possible solution, I don't believe I could complete the action required without bumping into a step that would cause me to halt for FEAR of doing something even worse to my PC. Second, the Firefox ad that prompted me to download their program, should have had some type of disclosure stating that during the download process, any and all PDF document files COULD OR WOULD be automatically converted to Firefox HTML document files. I then should have been given the option to "continue" or "abort". Obviously, I am not the only person it has happened to. Thus the reason the disclosure should be posted when prompting a person to download your program. That was not given to me as a choice. I have nothing wrong with my PC. It is operating without any corruption. I have AVG as my security, I do full scans constantly and I have no issues. I am also very disturbed and somewhat angry that Firefox/Mozilla makes it almost impossible to talk with a live customer service person regarding a customer's issues. Is it possible for me to talk with a customer service representative live by phone? If so, please provide the phone number and hours of operation. I need to resolve this issue. Please call me if that would work better for you. My phone number is 503-941-9633. Anytime between 8am and 8pm, PST. Thank You. Joe Hill

more options

Hi Joe, this is a glitch that occurs on some systems; most users get Firefox added as an additional way to open PDFs, not the primary way, and not the file type for PDFs.

If you cannot fix it using the menu/button inside Adobe Reader, other users have reported that if you make a different browser your default browser, that also switches the description of the PDF file type. (I haven't tested that -- this issue doesn't affect my Windows 7 systems.)

P.S. There is no official phone support, so I have no idea who is going to call that number. It could be anyone.

more options

What a SHAME!!! Firefox / Mozilla should be TOTALLY ASHAMED OF THEM SELVES. What a screwed up program and screwed up internet company. I would NEVER RECOMMEND THEM TO ANYONE. In fact, I will be telling everyone what happened to me and will be warning them that there is absolutely no CARE OR CONCERN ABOUT CUSTOMERS from Firefox / Mozilla, NO CARE OR CONCERN WHATSOEVER!!! SHAME ON YOU!!! YOU ARE A RINKY DINK OPERATION!!!! TOTALLY SHAMEFUL!!!!

more options

Hi Joe, this notion you have that no one cares about this issue, or about your personal situation, is incorrect. People have been working on fixing this permanently (and finding temporary workarounds until then) since it was first discovered. And you have received several responses here.

I understand that you are reluctant to edit the registry; that's sensible if you aren't already familiar with how to do that. Have you tried making another browser your default to see whether that helps?

more options

No, I have not tried that. If there is not a specific and defined way to get all the Foxfire HTML Documents changed back to PDF, as they were before they were changed without my permission, I really don't want to embark upon trying this and that to see if it works. That is a hit and miss approach and I do not feel I should be put into that position. Again, Foxfire/Mozilla have been aware of this problem before I downloaded their program. Again, they should have, upon becoming aware of the problem for the very first time, immediately installed a warning notice for those future, potential down loaders. But they did not, and therefore incidents like that which has happened to me have occurred. I guess I am stuck with this problem until a solution has been developed or found that will reverse the auto file change over that has occurred. It's not that I cannot open the Foxfire HTML Document file, I can open it and do what ever I need to do with that file. I am most concerned with attaching the file and sending it to someone. They are not able to simply click on the attachment and have the file open up in PDF Format. When you click on the file to open it, you now have to choose whether or not you want to open it as a Foxfire HTML Document or whether you want to choose "other". To my Senior Citizen clients, those extra two to three steps to get the file to open can be the difference of whether or not they have the know how on how to get it open for their review. Some will get immediately confused and abort the effort or close the first message box that comes up and then, they are not able to review the document I intended for them to see. When it was PDF, you simply double clicked on the attachment and the file opened right up to the content you wanted your customer to review. I hope that explains to you why I am not happy with what has happened. Foxfire/Mozilla should have a TECH Person that could be on the phone with me while at the same time be in my computer fixing the problem. But it doesn't sound like they have a service like that or a solution at this time. I do hope they have documented all customers that have been exposed to this radical, unauthorized file change over, so when they do find the solution to fix the problem, they will notify us so we can have our files changed back if desired. That is where I stand at this time. Until I get a positive response from Foxfire/Mozilla, I will not be recommending them to anyone and will share my negative experience with anyone that asks me about them as a default browser. Hopefully they will come up with a resolution soon.