X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

https is loading automatically on my homepage, my.yahoo.com. cannot access any yahoo sites (mail, weather, finances) because "this connection is untrusted"

Kuphostiwe

Cannot stop https from loading on browser on my.yahoo.com homepage. Homepage loads but will not allow access to any yahoo sites (mail, weather, finance, etc.) but I can access news, etc from other sources from the homepage. have tried disabling add-ons, reverting to previous firefox 29.0.1 from 30, manually correcting the address, nothing works. The issue seems to be limited to the yahoo homepage, but I have no idea why, and cannot access any yahoo sites (because of the problem) to try to get info from them.

The message I get is "this connection is untrusted" when I look further, it says "invalid security certificate", but I'm sure that's because browser is requesting a secure connection in the first place.

Any help would be appreciated.

Cannot stop https from loading on browser on my.yahoo.com homepage. Homepage loads but will not allow access to any yahoo sites (mail, weather, finance, etc.) but I can access news, etc from other sources from the homepage. have tried disabling add-ons, reverting to previous firefox 29.0.1 from 30, manually correcting the address, nothing works. The issue seems to be limited to the yahoo homepage, but I have no idea why, and cannot access any yahoo sites (because of the problem) to try to get info from them. The message I get is "this connection is untrusted" when I look further, it says "invalid security certificate", but I'm sure that's because browser is requesting a secure connection in the first place. Any help would be appreciated.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 14.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4246 izisombululo 59405 izimpendulo
Kuphostiwe

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

'''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59405 izimpendulo
Kuphostiwe

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

How to clear the Firefox cache {web link}

and

  • Remove Cookies

This will log you out of all sites you're logged in to. Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache '''[https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache]''' {web link} and * Remove Cookies '''This will log you out of all sites you're logged in to.''' Press the '''Alt''' or '''F10''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Privacy.''' Under '''History''', select Firefox will '''Use Custom Settings'''. There is a button on the right side called '''Show Cookies'''.
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Usually Firefox has no problem with the secure version of My Yahoo!

On the error page, could you expand the Technical Detail section and then copy and paste that into a reply?

If it says something along the lines of "sec_error_unknown_issuer" this can indicate one of these situations:

(1) Incomplete security software installation

Some security suites include a feature to intercept and scan your web traffic, including secure connections. In order to do this, they must present a fake certificate to Firefox, which of course, Firefox rejects. Programs such as ESET and Kaspersky provide a way to either turn off this feature, or import a master certificate into Firefox so that Firefox will trust these programs.

Does that sound relevant?

(2) Malware

Unfortunately, some malware also will intercept your secure connections. Often they can do this invisibly in IE and Chrome because they can inject certificates into the shared Windows certificate store. Because Firefox uses its own certificate file, you may get errors in Firefox that you do not get in IE and Chrome.

To distinguish between these, it's helpful to inspect the "Issued by" section of one of the certificates from a site that works in IE but not Firefox.

When you get the error page in Firefox, you can expand the "I understand the risks" section, and click the button to Add Exception. You don't need to actually save an exception to inspect the certificate, so you can cancel after viewing the certificate.

Check the "Issued by" section to see what you find there. For example:

  • Name associated with your security software, such as ESET, BitDefender, Kaspersky, etc.
  • Sendori (indicates unwanted software from Sendori)
  • FiddlerRoot (indicates unwanted software named similarly to BrowserSafeguard, BrowserSafe, SafeGuard)
  • Something else

What do you see?

Usually Firefox has no problem with the secure version of My Yahoo! On the error page, could you expand the Technical Detail section and then copy and paste that into a reply? If it says something along the lines of "sec_error_unknown_issuer" this can indicate one of these situations: (1) Incomplete security software installation Some security suites include a feature to intercept and scan your web traffic, including secure connections. In order to do this, they must present a fake certificate to Firefox, which of course, Firefox rejects. Programs such as ESET and Kaspersky provide a way to either turn off this feature, or import a master certificate into Firefox so that Firefox will trust these programs. Does that sound relevant? (2) Malware Unfortunately, some malware also will intercept your secure connections. Often they can do this invisibly in IE and Chrome because they can inject certificates into the shared Windows certificate store. Because Firefox uses its own certificate file, you may get errors in Firefox that you do not get in IE and Chrome. To distinguish between these, it's helpful to inspect the "Issued by" section of one of the certificates from a site that works in IE but not Firefox. When you get the error page in Firefox, you can expand the "I understand the risks" section, and click the button to Add Exception. You don't need to actually save an exception to inspect the certificate, so you can cancel after viewing the certificate. Check the "Issued by" section to see what you find there. For example: * Name associated with your security software, such as ESET, BitDefender, Kaspersky, etc. * Sendori (indicates unwanted software from Sendori) * FiddlerRoot (indicates unwanted software named similarly to BrowserSafeguard, BrowserSafe, SafeGuard) * Something else What do you see?

Umnikazi wombuzo

Sorry, but this did not help.

Sorry, but this did not help.

Umnikazi wombuzo

Sorry, this did not help either.

Sorry, this did not help either.

Impendulo Ewusizo

finance.yahoo.com uses an invalid security certificate. The certificate is only valid for the following names: www.yahoo.com, yahoo.com, Here is a copy of the technical details for untrusted conection/invalid security certificate. I get the same response when I attempt to go to any yahoo site, as noted in original post.

hsrd.yahoo.com, us.yahoo.com, fr.yahoo.com, uk.yahoo.com, za.yahoo.com, ie.yahoo.com, it.yahoo.com, es.yahoo.com, de.yahoo.com, ca.yahoo.com, qc.yahoo.com, br.yahoo.com, ro.yahoo.com, se.yahoo.com, be.yahoo.com, fr-be.yahoo.com, ar.yahoo.com, mx.yahoo.com, cl.yahoo.com, co.yahoo.com, ve.yahoo.com, espanol.yahoo.com, pe.yahoo.com, in.yahoo.com, sg.yahoo.com, id.yahoo.com, malaysia.yahoo.com, ph.yahoo.com, vn.yahoo.com, maktoob.yahoo.com, en-maktoob.yahoo.com, ca.my.yahoo.com, gr.yahoo.com, att.yahoo.com, au.yahoo.com, nz.yahoo.com, tw.yahoo.com, hk.yahoo.com, brb.yahoo.com, my.yahoo.com, add.my.yahoo.com (Error code: ssl_error_bad_cert_domain)

finance.yahoo.com uses an invalid security certificate. The certificate is only valid for the following names: www.yahoo.com, yahoo.com, Here is a copy of the technical details for untrusted conection/invalid security certificate. I get the same response when I attempt to go to any yahoo site, as noted in original post. hsrd.yahoo.com, us.yahoo.com, fr.yahoo.com, uk.yahoo.com, za.yahoo.com, ie.yahoo.com, it.yahoo.com, es.yahoo.com, de.yahoo.com, ca.yahoo.com, qc.yahoo.com, br.yahoo.com, ro.yahoo.com, se.yahoo.com, be.yahoo.com, fr-be.yahoo.com, ar.yahoo.com, mx.yahoo.com, cl.yahoo.com, co.yahoo.com, ve.yahoo.com, espanol.yahoo.com, pe.yahoo.com, in.yahoo.com, sg.yahoo.com, id.yahoo.com, malaysia.yahoo.com, ph.yahoo.com, vn.yahoo.com, maktoob.yahoo.com, en-maktoob.yahoo.com, ca.my.yahoo.com, gr.yahoo.com, att.yahoo.com, au.yahoo.com, nz.yahoo.com, tw.yahoo.com, hk.yahoo.com, brb.yahoo.com, my.yahoo.com, add.my.yahoo.com (Error code: ssl_error_bad_cert_domain)

Umnikazi wombuzo

Sorry. this computer does stuff like the above. Just switch the first two paragraphs . . .

Sorry. this computer does stuff like the above. Just switch the first two paragraphs . . .

Umnikazi wombuzo

NOTE: seem to be having the same issue in IE and Chrome . . .

NOTE: seem to be having the same issue in IE and Chrome . . .

Umnikazi wombuzo

Sorry. This did not help

Sorry. This did not help
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Hmm, I think get a different certificate than you do. I have attached a screenshot.

If you use the Add Exception button to view the certificate, what differences do you notice?

Hmm, I think get a different certificate than you do. I have attached a screenshot. If you use the Add Exception button to view the certificate, what differences do you notice?

Umnikazi wombuzo

jscher2000

Didn't get the screenshot. Don't know how to view a certificate. Never needed to check before . . .

jscher2000 Didn't get the screenshot. Don't know how to view a certificate. Never needed to check before . . .
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

The screenshot is here on the site; I guess it doesn't get sent with the email notification.

When you get the error page, is there a third section below Technical Details that contains an "Add Exception" button? You can click that, then Get Certificate, then View to see the certificate. You can cancel out after that; you don't need to add an exception.

The screenshot is here on the site; I guess it doesn't get sent with the email notification. When you get the error page, is there a third section below Technical Details that contains an "Add Exception" button? You can click that, then Get Certificate, then View to see the certificate. You can cancel out after that; you don't need to add an exception.

Umnikazi wombuzo

jscher2000

Appreciate your suggestions. Thank you!

I've been using the 'add exception' button to access my mail on a temporary basis. In spite of the warnings, I'm sure these issues are caused by the 'https' rather than 'http', so my level of confidence is relatively high . . .

I do have a different certificate. It's apparently issued by Kaspersky. Does that make sense? Would send a screen shot, but don't know how . . .

I'm going to crash, and try again tomorrow. Been a long day:-) Thanks again. Paul

jscher2000 Appreciate your suggestions. Thank you! I've been using the 'add exception' button to access my mail on a temporary basis. In spite of the warnings, I'm sure these issues are caused by the 'https' rather than 'http', so my level of confidence is relatively high . . . I do have a different certificate. It's apparently issued by Kaspersky. Does that make sense? Would send a screen shot, but don't know how . . . I'm going to crash, and try again tomorrow. Been a long day:-) Thanks again. Paul

Umnikazi wombuzo

BTW: Firefox has been freezing up constantly over the past hour or so. Every time I try to do something, it does the circle deal and will not clear itself. Updated to 30.0 along the way. Maybe I shouldn't have done that . . . Paul

BTW: Firefox has been freezing up constantly over the past hour or so. Every time I try to do something, it does the circle deal and will not clear itself. Updated to 30.0 along the way. Maybe I shouldn't have done that . . . Paul
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Yes, Kaspersky, good. If you are having Kaspersky filter your traffic, you can set up Firefox to work with that. Which product is it?

The freezing up is a problem, obviously. To rule out extensions as a possible culprit, could you try browsing in Firefox's Safe Mode for a while? That's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

Yes, Kaspersky, good. If you are having Kaspersky filter your traffic, you can set up Firefox to work with that. Which product is it? The freezing up is a problem, obviously. To rule out extensions as a possible culprit, could you try browsing in Firefox's Safe Mode for a while? That's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled Note: Flash and other plugins still run After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (''not'' Reset) Any difference?

Umnikazi wombuzo

jscher2000,

Huge difference! Computer is much faster. Just made the change a little while ago, so don't know if it will start to hang up, but promising start. Thanks. What now? How do I isolate the culprit?

Paulinphila

jscher2000, Huge difference! Computer is much faster. Just made the change a little while ago, so don't know if it will start to hang up, but promising start. Thanks. What now? How do I isolate the culprit? Paulinphila
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

I generally suggest starting by disabling all extensions you do not plan to use in the next 24 hours. You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then you can review and disable on the right side.

Often a link will appear above a disabled extension to restart Firefox. You can complete your work on the add-ons page and click the link as the last step.

If that doesn't help as much as safe mode, then one of the one's that is still enabled could be the culprit.

I generally suggest starting by disabling all extensions you do not plan to use in the next 24 hours. You can do that on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then you can review and disable on the right side. Often a link will appear above a disabled extension to restart Firefox. You can complete your work on the add-ons page and click the link as the last step. If that doesn't help as much as safe mode, then one of the one's that is still enabled could be the culprit.

Impendulo Ewusizo

jscher2000,

GOT IT. KASPERSKY WAS INSTALLING ITS OWN CERTIFICATE WHICH WAS NOT ACCEPTED BY YAHOO, WHICH WAS LOOKING FOR A VERISIGN CERTIFICATE.

WENT TO KASPERSKY/ SETTINGS/ADDITIONAL/NETWORK SETTINGS: UNCHECKED 'SCAN ENCRYPTED CONNECTIONS' THAT DID THE TRICK.

THANKS AGAIN FOR ALL YOUR HELP, PAULINPHILA

jscher2000, GOT IT. KASPERSKY WAS INSTALLING ITS OWN CERTIFICATE WHICH WAS NOT ACCEPTED BY YAHOO, WHICH WAS LOOKING FOR A VERISIGN CERTIFICATE. WENT TO KASPERSKY/ SETTINGS/ADDITIONAL/NETWORK SETTINGS: UNCHECKED 'SCAN ENCRYPTED CONNECTIONS' THAT DID THE TRICK. THANKS AGAIN FOR ALL YOUR HELP, PAULINPHILA
briarcraft 0 izisombululo 6 izimpendulo
Kuphostiwe

If you use KASPERSKY, this is the solution they emailed to me when I encountered this problem. It worked wonderfully.

Here are the steps on what you need to do:


To Show hidden files, folders and drives:

Go to the Start Menu Open up My Documents folder On your keyboard, press and hold 'Alt' key then press 'T' to open the Tools Menu. On the list, please click on 'Folder Options' Go to 'View' tab. Under Advanced Settings, please select or choose 'Show hidden files, folders and drives'. Click on 'Apply' then 'Ok'. Then close the My Documents window.


Deleting and Importing Certificate:

Open up Firefox, click the 'Open Menu' icon or the three horizontal lines. Go to Options Go to the Advanced tab in the top right Click on 'Certificates' tab Click on 'View Certificates' button Under Authorities you will find one or more "KasperskyAnti-VirusPersonalRootCertificate" Select the certificate then delete the file(s).

Select the Import button. Browse to C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\ select the (fake)Kaspersky Anti-Virus Personal Root Certificate, and press open. When importing the certificate, there are three options, select the option for "Trust this CA to identify websites" then press OK on all the windows to save the settings.


Please close the Firefox window and reopen the program then try to access sites again. If the steps stated above solved the issue, follow the steps on how to 'Show hidden files, folders and drives' and please select/choose ' Do not Show hidden files, folders and drives' to restore the default setting.

If you use KASPERSKY, this is the solution they emailed to me when I encountered this problem. It worked wonderfully. Here are the steps on what you need to do: To Show hidden files, folders and drives: Go to the Start Menu Open up My Documents folder On your keyboard, press and hold 'Alt' key then press 'T' to open the Tools Menu. On the list, please click on 'Folder Options' Go to 'View' tab. Under Advanced Settings, please select or choose 'Show hidden files, folders and drives'. Click on 'Apply' then 'Ok'. Then close the My Documents window. Deleting and Importing Certificate: Open up Firefox, click the 'Open Menu' icon or the three horizontal lines. Go to Options Go to the Advanced tab in the top right Click on 'Certificates' tab Click on 'View Certificates' button Under Authorities you will find one or more "KasperskyAnti-VirusPersonalRootCertificate" Select the certificate then delete the file(s). Select the Import button. Browse to C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\ select the (fake)Kaspersky Anti-Virus Personal Root Certificate, and press open. When importing the certificate, there are three options, select the option for "Trust this CA to identify websites" then press OK on all the windows to save the settings. Please close the Firefox window and reopen the program then try to access sites again. If the steps stated above solved the issue, follow the steps on how to 'Show hidden files, folders and drives' and please select/choose ' Do not Show hidden files, folders and drives' to restore the default setting.